Can't add Tasmota Integration


I am new to HomeAssistant. The first look is impressive! I like it very much. So I have some devices with tasmota flashed (Sonoff Basic and Sonoff Touch 2CH, Tasmota 9.2.0) and want to add these devices to my HA installation.

If I try to add tasmota from integrations, the window closes immmediately and an error log appears. There is also a notice that my mqtt config is invalid, but I don’t have anything installed like that. Do I need an additional mosquitto service installed on the same machine?

Here is the error log from HA (Version 2021.1.4, I’ve installed HA from Ubuntu snaps via “sudo snap install home-assitant-snap”):

2021-02-04 09:21:15 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of tasmota. Setup failed for dependencies: mqtt
2021-02-04 09:21:15 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/aiohttp/", line 422, in _handle_request
resp = await self._request_handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/aiohttp/", line 499, in _handle
resp = await handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/aiohttp/", line 118, in impl
return await handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/http/", line 56, in security_filter_middleware
return await handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/http/", line 18, in request_context_middleware
return await handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/http/", line 72, in ban_middleware
return await handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/http/", line 127, in auth_middleware
return await handler(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/http/", line 129, in handle
result = await result
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/config/", line 136, in post
return await super().post(request)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/components/http/", line 60, in wrapper
result = await method(view, request, *args, **kwargs)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/helpers/", line 69, in post
result = await self._flow_mgr.async_init(
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/", line 119, in async_init
flow = await self.async_create_flow(handler, context=context, data=data)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/", line 532, in async_create_flow
await async_process_deps_reqs(self.hass, self._hass_config, integration)
File "/snap/home-assistant-snap/123/lib/python3.8/site-packages/homeassistant/", line 339, in async_process_deps_reqs
raise HomeAssistantError("Could not set up all dependencies.")
homeassistant.exceptions.HomeAssistantError: Could not set up all dependencies.

Please help to find out whats wrong with my installation :slight_smile:
Thanks for your help!
Greetings from Germany

You need the Mosquitto Broker, MQTT integration as well to use the Tasmota integration. I think also maybe firmware? (Maybe wrong about firmware version)

Hi David,

thank you for your fast reply. My fault, I thought HA has an internal MQTT broker. Okay so I will proceed with the mosquitto installation first.

If you are running supervised or HA OS there is an addon broker that works well.

Oh wow! It’s working fine now :slight_smile: I’ve installed mosquitto and add the MQTT integration and now I can control my tasmotas. Many thanks David. Have a nice day.

1 Like

In my case I had MQTT installed, but I have not press “Configure” button on MQTT and when I wanted to add Tasmota integration I received an error “Config flow could not be loaded”.
After pressing Configure and submitting provided options I could install Tasmota no problem.

Hi, i am new in home assistant, have the same problem, i.e. If I try to add tasmota from integrations, I received the same error “Config flow could not be loaded”. I’ve already installed mosquitto Broker and add the MQTT integration. but still not solved.
Please help to find out whats wrong with my integration.

@wejdani I’m also new in HA so it is two of us :wink:
Anyway, let’s try to find the problem.

  1. Go to Supervisor and you should see Mosquitto broker. Click on it and then check for "Start, Stop, Restart buttons. If you see Start that would mean you have not started it yet so please click it.
    Please make sure you have check box Start on boot selected as well.
  2. Now let’s go to Configuration->Integrations. Do you see any buttons there like Configure?
    If so, click on that. What do you see?

Yes i see here 2 configure buttons:
1- on the Mosquito Broker box in red Color with an error message on the top of this box: “Not loaded, Check the logs”
2- on the Supervisor Box
Thanks for Help

Hi again,
The problem solved, i.e. i click on configure button on the mosquito broker box and on next page i push the reconfigure button, after a seconds was O.K., and now appear the Tasmota on my configuration page.
thank you very much for your Help
RGDS wejdani

Excellent. Glad it worked for you.

Thanks for the info :slight_smile: , I wish the “Config flow could not be loaded” error could be replaced by a dependency error, that makes a whole lot more sense.

edit: Got Tuya smartplug (flashed with Tasmota) now working in HA.
edit2: It’s detected and switch works, but not getting all measurements for some reason. The entities are there, about 20 of 'm, but besides the switch that’s working, only total measured kWh is displayed, everything else is zero.

1 Like