Can't add zwave integration 'homeassistant-pyozw’

In my configuration.yaml file I am trying to enable z-wave integration

  usb_path: cu.usbmodem14401
  network_key: [hidden]

I didn’t include my real network key!!!
I get the following error in Configurations/Server Controls
=> Clicked on “Check Configuration”
Component error: zwave - Requirements for zwave not found: [‘homeassistant-pyozw==0.1.10’].

If I try and install through the UI, I click on configuration/integrations
=> click on add integrations “+” button
=> pick z-wave in the list

the spinner sits there for like 30 seconds and the screen reloads to the integration a modal as if nothing happens.

Any ideas how to add zwave to my system?

I am running on macos Mojave with a python 3.7 installation.

You need to specify the path to the stick :wink: See here in the Z-Wave docs.

I did that when I stated in the line above:

It seems to me that something is broken with the integration feature for macos for installing the zwave integration. Both the manual way and the UI both error out when looking for “homeassistant-pyozw==0.1.10”.

I tried manually installing this missing thing “homeassistant-pyozw==0.1.10” by going into terminal and telling pip3 install homeassistant-pyozw==0.1.10. But after it downloads all but I still get the same error.

Ok, I see now that I was missing the path. So I updated to /dev/cu.usbmodem14401
but I am still getting the same error.

Looking at my Log file there is a huge log dump but it starts with the following message:
[homeassistant.util.package] Unable to install package homeassistant-pyozw==0.1.10: ERROR: Command errored out with exit status 1:

It looks like I am getting same error problems as this post:

All the solutions for this error are linux specific

sudo apt-get install libudev-dev

Is there a Mac equivalent solution for “sudo apt-get install libudev-dev”?
Mac in terminal doesn’t support apt-get

But it appears both mac and windows are experiencing the same error.

apt-get is not linux specific, it is debian and derivatives (dietpi, ubunutu , other debian forks) specific. Won’t work on linux distributions which use other package managers.

That aside, maybe this topic is helpful:

That would be awesome. Let me give it a try and report back.

Well I tried installing python_openzwave manually like the post described. But it still won’t turn zwave integration on. I get the same error output when I click Check Configuration.

Component error: zwave - Requirements for zwave not found: homeassistant-pyozw==0.1.10.

HA doesn’t use python_openzwave anymore, it uses homeassistant-pyozw (a fork).

Ok, thanks everyone for help.
I ended up uninstalling Home Assistant and making a clean install.

I have the zwave integration setup now.