Can't backup and restore?

I have been trying to get HA working and the mobile app part is proving a bit troublesome. I am running a virtual machine and wanted to clear some things in the .ios.conf file so made a snapshot. What I tried didn’t work so restored. My ecobee sensors now do not work complaining about bad tokens. Tried restoring my HA snapshot same deal. Is there a way to back up the system and restore so this doesn’t happen? Taking a VMware snapshot, trying something, then restoring within 5 minutes wouldn’t think you would have these issues.


post the error. Sounds like an auth issue, which typically aren’t carried over in snapshots… This would be akin to relogging in.

A fix is in the pipeline.


Nice, thanks Rob.

I have the same issue. I’ve been eagerly awaiting the fix.

Here’s where I first saw the issue being discussed:

I ended up having to remove the ecobee integration and add it again. Then paste in my original API key, then go to the website, delete the “app” I had created on ecobee’s website and create a new one and paste in the 4 letter code. Now back again. None of the sensors auto show at the top of the default page anymore but it’s there again. Still annoyed I have like two of everything because HA sees the HomeKit capabilities of the ecobee. Oddly that kept working. Wondering if I shouldn’t do the HA integration and just use the HomeKit integration. I haven’t automated anything yet, but not sure if one or the other can enable the away comfort setting and also then set it back to run on the schedule and lift the hold overriding does.


There are reports that reintegrating the api only works temporarily. After seeing those posts, I’m electing to wait for the PR to be integrated.

Here’s the latest on the issue: