Can't change HA ip address for new router

Replaced faulty ASUS router ( with new TP-Link router ( All the existing devices were detected by the TP-Link except for a few with manual ip addresses including Home Assistant. I cannot access the HS interface due to this and have not been able to find a way to change the HA ip address without that access. HA is running in a Virtualbox on Win 10. Virtual box shows that HA is running on Advanced IP scanner also shows the same. If I stop HA and restart it will not correct the problem. The PC has been rebooted several times. If nothing else, I would like to save all my congfig.yaml files and reinstall HA.
Is there another way to to access HA and change the ip address. I looked at trying SSH via VirtualBox and was not able to follow it.

Thanks for your ideas.


Change the ip of the router to log into home assistant switch it to, then switch the router back. It would probably be under the dhcp tab of the router settings.

Worked like a charm. I had not realized it was possible to change the ip address of the router.

Another way would have been to manually set ip address of another machine (laptop/ipad) to, connect to HA and change its IP address.
Don’t forget to switch the other machine back to DHCP :wink:

I was able to correct the HA IP address using the recent responses. However, there is a new problem which may be related:
Supervisor was not able to update
I tried the recommended manual update from the system and also via CLI ha supervisor update with the same result.
Abort update because of an issue with AppArmor: Can’t fetch AppArmor profile Cannot connect to host ssl:default [Try again]

#include <tunables/global>

profile hassio-supervisor flags=(attach_disconnected,mediate_deleted) {
  #include <abstractions/base>
  #include <abstractions/python>

  deny network raw,

  signal (send) set=(kill,term,int,hup,cont),

  capability net_admin,
  capability net_bind_service,
  capability dac_read_search,
  capability dac_override,

  /bin/** ix,
  /usr/bin/** ix,
  /bin/udevadm Ux,
  /sbin/udevd Ux,
  /usr/local/bin/python* ix,
  /usr/bin/git cx,
  /usr/bin/gdbus cx,
  /usr/lib/bashio/** ix,
  /etc/s6/** ix,
  /run/s6/** ix,
  /etc/services.d/** rwix,
  /etc/cont-init.d/** rwix,
  /etc/cont-finish.d/** rwix,

  deny /proc/** wl,
  deny /root/** wl,
  deny /sys/** wl,

  / r,
  /** r,
  /tmp/** rw,
  /data/** rw,
  /os/** rw,
  /run/** rwk,
  /dev/tty rw,
  /etc/resolv.conf rw,
  /run/docker.sock rw,

  /usr/local/lib/** mr,

  profile /usr/bin/gdbus flags=(attach_disconnected,mediate_deleted) {
    #include <abstractions/base>
    #include <abstractions/dbus>

    signal (receive) set=(int),
    unix (send, receive) type=stream,

    capability sys_nice,

    /** r,
    /lib/* mr,
    /usr/bin/gdbus mr,
    /usr/local/lib/** mr,

    /run/dbus/system_bus_socket rw,

  profile /usr/bin/git flags=(attach_disconnected,mediate_deleted) {
    #include <abstractions/base>

    deny network raw,

    signal (receive) set=(term),

    /bin/busybox ix,
    /usr/bin/git mr,
    /usr/libexec/git-core/* ix,

    deny /data/homeassistant rw,
    deny /data/ssl rw,

    /** r,
    /lib/* mr,
    /data/addons/** lrw,
    /usr/local/lib/** mr,

    capability dac_override,

Tried again to no avail.
Any ideas from this helpful group?

try here

I have tried the suggestions but no success.

If no progress soon, I may reinstall HA.

Finally solved the problem. During the recent replacement of a failed router, I overlooked updated the default gateway for the DHCP server. After making that change I was able to update everything in HA and all appears good now.

1 Like