Can't connect to homeassistant.local:8123 - no access via lan but works with Wi-Fi

Hello Everyone!

New to Home Assistant. Currently Home Assistant Installed on Windows 11 machine in VirtualBox. This PC is on Wi-Fi, since there’s no possibility for me to connect it to lan. I also have other PCs in my house that are connected via LAN cable.

I’ve been using Home Assistant successfully for a couple days with no issues. And were able to access homeassistant.local:8123 with my PC that is connected via lan.

Since today for some reason I’m no longer able to open homeassistant.local:8123 from browser - receiving an error saying that “The connection to the server was reset while the page was loading.” I’ve also tried accessing it from different pc that is also connected via lan and received the same error.

What I’ve noticed that if i access http://homeassistant.local:8123 from my phone that is connected via wi-fi, the page does open. APP is also accessible via Wi-Fi.
I’ve disconnected my PC from LAN and connected to the wi-fi. And now I’m able to open homeassistant.local:8123 again. So it seems that for some reason I’m able to access this page only through wi-fi but not LAN.

Automatons seems to work properly.

What I’ve tried so far:

  1. Access through IP:8123 with no luck.
  2. Restart all PC, including one with virtualbox, no luck.
  3. Update Home Assistant, no luck.

What I’ve noticed so far:

  1. When I tried to open the page I got an error in system log (not sure if it’s related, but seems so):
    Logger: homeassistant.components.websocket_api.http.connection
    Source: components/websocket_api/
    Integration: Home Assistant WebSocket API (documentation, issues)
    First occurred: 7:06:23 PM (1 occurrences)
    Last logged: 7:06:23 PM

[140093464458176] from fe80::43e6:9178:27c0:8e58 (Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:122.0) Gecko/20100101 Firefox/122.0): Disconnected: Did not receive auth message within 10 seconds

  1. If i try to ping the homeassistant.local, via my PC connected to lan, I am able to do that, but I receive reply as a IPV6 address, if I disconnect from lan and ping while using wi-fi, i receive reply in ipv4 address

Can someone help me out with this one? It’s strange that I receive different replies IPV4 and IPV6 if I ping when connected with LAN and Wi-Fi.

some questions to help debug:

when you connect on the pc that hosts the virtualbox, i presume it connects just fine?

can you try doing a wired connection going straight to your router? ie, laptop wired straight to router to connect?

i’m suspecting a loose or noisy wire between the router to the end point you’re trying. what you are describing sounds a lot more like an issue between the connection than at either end point. the things you’ve described has been more working on identifying an issue in the endpoints…

On your LAN PC, try http://ipv4-from-wifi-mentioned-above:8123

In general, it sounds like a DNS resolution error. You shouldn’t get 2 different address resolutions from the same server changing when switching from wired to wireless.

I’m able to connect to pc that hosts the virtualbox. Since it’s just pc without monitor, there’s no other way to connect for me to it.

Wired connection you mean from HOST pc that has virtualbox to the router? Unfortunately it is not possible. My router is in the same room as my 2 other PC and both of these pc connected via lan.

Don’t know about lose or noisy wire since:

  1. 2 wires goes from router to my 2 PC, which are connected to the internet via lan. Both PC connected to the internet and everything works perfectly fine.
  2. There was no such a problem for 3-4 from my initial setup and now it just stopped working.

Does pinging homeassistant.local should return different IP address as described in my my initial post? Pinging while connected Wi-Fi returns IPV4 address, when pining while connected to ethernet returns IPV6 address

You mean the one in ipv4 addresses?

ping homeassistant.local /4

Yes, you should.

1 Like

pinging with homeassistgant.local/4

Ok one more strange thing.
I was able to access the page by using Tailscale local IP, but can’t access it by using

Here’s an error that just occured in system log while trying to connect to homeassistant.local:

way above, i meant trying moving the client (not the one hosting the vm) pc to another connection… because you can connect reliably from your mobile device, i’m presuming the connection from router to host pc is fine.

you just said you cannot access it by using the ip, i presume you mean it does partially connect then times out.

curious that it craps out in the same spot.

for diagnostics, i’d try a few things to narrow it down… and i’d do it all via ip4 ip address to reduce variance.

  1. on the client pc, can you switch to a different hardwire location?
  2. can you switch that client pc, does it have wifi? can you try via wifi from that pc.
  3. can you try connecting from a clean browser on that client pc? edge, firefox, chrome… pick one that you’ve never tried to connect with.

Thank you @armedad for helping out with debug.

  1. On the client PC I have only one ethernet port I can connect to. Therefore I can only test connecting via that ethernet port or via Wi-Fi.
  2. As mentioned in my initial post, I’m able to access homeassistant.local from my PC when connected to the internet via Wi-Fi. I also just tried connecting directly via IP to and the website opened up correctly…
  3. I tried connecting from a clean browser (installed Chrome). Getting same error that site cant be reached took too long to respond.

I have no clue why does PC with Ethernet can’t connect to ipv4 address and homeassistant.local:8123, but it CAN when connected on Wi-Fi. That’s just does not make any sense :smiley: I’m not in networking, but can it be somehow related to my ethernet configuration? But why then it worked perfectly in the past 3-4 days and stopped working without me making any changes.

By the way, as mentioned previously I also have other client pc connected to the lan network and it also can’t access the homeassistant.local, although can’t check whether it will access it through wi-fi since it doesnt have it.

Care to elaborate? I understand IPV4 and IPV6 have different addressing schemes and DNS record types, but in my experience on a home LAN toggling from wired to wireless clients doesn’t typically switch you to different protocols as your primary network. I find that both are consistent between the data link types, either IPV4 or IPV6.

All of my servers and devices with both WiFi and Ethernet interfaces have two IP addresses.

1 Like

Sure, but the OP stated that only the WiFi interface was active on his LAN.

Not sure what does it mean, but I’m connecting to Wi-Fi only when I unplug my ethernet cable. But yes, pinging homeassistant via wifi returns ipv4 while ethernet returns ipv6

Did you read post#6?

ping homeassistant.local /4

I did and replied, that after trying it did returned ipv4 with /4 command. So it seems I can ping the IP address but request to open the website take too long to respond.
Any other suggestions?

Open a cmd window.
Enter ipconfig
Under Ethernet Adapter, what is the IPV4?
And under the Wireless LAN adapter?
SSH into Home Assistant. What is the IP address of Home Assistant?

i think op already essentially gave us most of that. is his local address for his homeassistant.

all his devices (pc and mobile) can all see it and at least initially connect. he’s hitting it via direct ip4 address, so no name resolution. but for some reason his wired connection isn’t maintaining the connection long enough to authenticate.

i’m not sure what’s going on. i’d have to just started eliminating variables step by step and narrow it down.

boyudag, you asked why it was working before and suddenly stopped… we can’t really answer that, but i’ve certainly seen similar before when someone didn’t realize some change had an unintended side effect. maybe you updated your router, maybe you installed some software that mucked with your firewall, maybe something auto-updated and changed a setting. something could have changed without your intentional action if you had something on auto-update.

i’d still do what i could to either eliminate or change out components on your wire connect. you might also see if you can maintain a smb connect between your wired pc and homeassistant. see if it’s down low level or not… that would eliminate the browser.

Huh? What does tailscale have to do with anything? You’re trying to access this from inside your network. That is not what tailscale is for.

Betting that’s at least part of your problem…

I had the same thought.
Disable / turn off anything to do with tailscale, as potentially thats causing issues,.

Is your LAN network and WiFi network on the same IP range ? Is that IP range the same or different to the one the HA VM is getting from virtualbox ?