Can't connect to homeassistant.local:8123 - no access via lan but works with Wi-Fi

On my Client PC? Here you go:

As for the Wi-Fi, here are the info what I see when ethernet cable plugged in and wi-fi turned off:

And here’s the info when I unplug the ethernet cable, turn on wi-fi and connect to it:

Thank you for helping out. How exactly I can maintain this connection?

Ok Tailscale if turned off. Still can’t access the website.
It seem to be on the same IP range:

  • Client PC Connected via Ethernet ipv4 IP
  • Client PC Connected via Wi-Fi ipv4 IP
  • Host PC Connected via Wi-Fi ipv4
  • Virtual Box IPV4 address


Thank you for helping out. How exactly I can maintain this connection?

what i meant was to connect to it via a unc path. \\config
enter that in file explorer or in a cmd window do:
net use * \\config

that creates a connection to your homeassistant for filesys access. would be interesting to see if that connection is reliable or if it times out as well.

Thank you. When I enter net use * \\config into CMD on my client pc i get that System Error 67 occurred. The network name cannot be found.

sorry should be


2 \'s to start. i didn’t notice that editor here uses \ as an escape key and turned my \\ into \

Thank you. Now it took like 30 seconds to actually show some message, but still I received same error:
System Error 67 occurred. The network name cannot be found.

Doesn’t this require Samba Share add-on to be installed?

1 Like

yes… thank you! i about take it for granted now.

go to add-on and install samba… something pretty much every homeassistant should have :slight_smile:. super useful.

Start with Windows. (LOL)

The reason I wanted to see all of the IP addresses in one post was to verify that all the pieces are on the same subnet. I do not use VMs or containers but I have seen cases where the VM IP address is different from the Home Assistant IP.

Boyudag - Are you using a separate PC to ping Home Assistant? Also, why can’t you connect Home Assistant by Ethernet? That would seem to be a preferred fix to the issue.

1 Like

up above a bit he says he’s pinging it from his separate pc and is able to do so.

that’s what he’s trying to figure out. he’s trying to connect it via hardwire ethernet from his client pc to the vm running on the host pc but that’s failing. however when he pulls the ethernet and runs over wifi from that 2nd client pc, it works.

so far, i’m a baffled, so trying to eliminate different elements to narrow down to the problem component.

To clarify-
With Ethernet connected, he cannot log in to Home Assistant.
With Ethernet unplugged he can.

Have you tried rebooting the router?
Do you have any IP reservations in the router?
Are you trying to use Static IP?

I would like to see the output of ‘ipconfig /all’ with Ethernet plugged in.

1 Like

I would like the same. I suspect that his device is configured to use Ipv6 binding first on the ethernet segment (default for win10+) while ipv4 on wifi (depends on how dhcp is set on the two segments.) if ipv6 is misconfigured it would do exactly what op says. Works on wifi and doesn’t work on ethernet. But it’s actually an ipv6 DNS issue v. Ipv4 DNS.

1 Like

Application installed. I receive same error System error 67. Strangely I do see that some kind of Linux appeared in the tab:

To sum up, correct here’s my current build:

  1. Host PC on Windows 11 connected to the internet via Wi-Fi running Virtual Box with Home Assistant running on Linux 64.
  2. In a different room there are 2 PC that are connected via Ethernet cable to the internet. Both PCs CAN ping the IP address of the home assistant, but can’t open up the http://homeassistant.local:8123/ address - Request takes too long.
    If I unplug the ethernet cable and enable Wi-Fi on my client PC, I’m able to open up the address.
    As mentioned previously, it was running perfectly fine for a 3-4 days before that. I turned off the Client PC, went to sleep, woke up, started pc and no longer able to access it.

Yes, rebooted everything - router, client pcs and host pc. IP reservations? How to check that? I’m not using any static ip and haven’t made any network changes at all during my initial internet set up.

Here’s ipconfig /all with ethernet plugged in.

Could it be that router made some network changes even though we were using that site perfectly before?

If you want I can also run the ipconfig /all on other client pc that connected to the internet via cable.

What happens if you enter

Http:// in the browser? Can you access it then?

Kindly post a Pic including the address bar?

And you said that you ARE able to access it via the tailscale ip from the wired client, is that correct?

How do you have the networking configured on the vm?

Correct. That’s how I’m able to connect to HA for now at least.

How are your urls configured in HA?

Sorry for clarifying you mean this?

To be honest, I haven’t made any changes in networking at all, since it all worked fine on initial setup.