Can't connect via IOS App

I signed up for the Home Assistant Cloud but I can’t connect to HA from my phone when I am not connected to the same wifi. If I turn WiFi off I get a blank screen with the configuration icon in the bottom right. As soon as I connect the iPhone to the WiFi it connects no problem.

I’ve restarted Home Assistant with both the server controls and a hard restart of the Raspberry Pi.

Thanks,

Robert

In the Home Assistant sidebar, go to App Configuration -> Connection and then make sure you see the checkmark for Home Assistant Cloud and that the “Connect via Cloud” is toggled on.

Sean, thanks for the quick response. I do not have that option. Below is a screenshot of my connection page on the iPhone. The part blacked out has the internal IP address for the HA instance. I tried changing to the external link but it won’t allow me and says the app will automatically detect my Nabu Casa Remote UI and can’t manually enter it.

Anyone else have any ideas?

Unfortunately I think this is a bit of a design flaw with the app.

The initial setup process of the iOS app detects your Home Assistant Cloud details automatically and configures everything properly for you. This is why it prevents you from entering the Nabu Casa URL manually, so that users don’t accidentally misconfigure things.

However it hasn’t taken into account users like you who have already configured the app and then signed up for Cloud afterwards.

Although it’s a bit inconvenient, I think your best way forward is probably to re-install the iOS app so that you can go through that initial setup process again and have it automatically detect your Cloud details.

I just updated to recent version of app 2020.6.1
I noticed it changed switch Connect via cloud to disabled. But even after re-enabling it, application shows only blank page (plus configuration button).
After a while it reports connection time out.
External URL remains configured correctly.

I canfirmed that Connection via Nabu casa is working through www. So definitively something is wrong with app.

HA v0.114.x
iOS: 13.7

I ended up having to delete the Integration and Device on my HA and reinstall the application on the phone. Once I did that the option to open with Home Assistant Cloud became available in the settings.

Thanks for the assistance!

1 Like

I did the same previous time when app got new owner. Do we have to do that with every update?

Just a note, my case is different to Robert’s above since app detected both access URLs properly.

Any idea how to solve it?

edit: it seems it’s reported to github since 2 days ago. https://github.com/home-assistant/iOS/issues/1071
No message from devs over there.

Can we ask devs for notifying us on the forum in case of such show stoppers to help us in avoiding breaking functionality?

It seems like there’s only a small group of users that have this issue, which could mean it’s not related to the app.
I think it’s a really bad idea to post issues from github on the forum as well, they should just stay in github where they belong. Otherwise the forum will be filled with redundant issues and it’ll become a huge mess quickly, I guarantee you.

I cannot agree. If a user with a problem comes to forum it’s usefull to inform him that issue is already reported and redirect him to exact page giving him a chance to get more information and/or track the issue.

BTW my application has started to work on its own after half a day. Maybe it was executing some task in the background. Who knows. Still sad we cannot see devs responsible for app trying to help here on forum

2 Likes

I agree that’s useful, but you can’t expect devs to come here to the forum and check each and every post and link the corresponding issue on github if it exists. Remember, most of the devs do all their work for free in their spare time.

I remember but again I have different understanding of it. I’m a developer who maintained free software for more than 10 years and never left a user without response/help.
Anyway we are drifting offtopic now. Using ‘free software’ argument should be banned imo cause it’s aften used wrongly and actually never help in solving OP’s issue

That’s nice to hear and probably highly appreciated by the users of this product, but this is simply not possible for a product as huge as Home Assistant with 100s of devs.

I agree it doesn’t solve OPs issue, but people complain here all the time and barely anyone of them realizes that there are working people in their free time for no money for a great part of Home Assistant. If I program a component for HA in my free time and spend countless of hours to develop, test, fix, etc. and then people on a forum complain that there’s a bug in my code and why I did not come to the forum and reply to them that an issue was already opened, I’d be pissed as f*** and would probably stop spending my free time to provide free stuff.

This is exactly my problem, however just reinstalling the app doesn’t solve anything. After a new install, it just connects to home assistant as if I never uninstalled it. Even after removing the integration from home assistant it just reconnects again without me ever needing to enter any credentials or it updating the connection settings.

I really do not want to have to reinstall my whole home assistant installation and start over. Any idea how to reset just the app connection?

edit: I’m an idiot, scrolling all the way down in the app config there is a reset option. Interestingly, the auto configure puts my local internal lan address in the external URL field, so I’m not sure it will actually work, but I’ll test tomorrow.

1 Like

That’s exactly what I get. There’s no way to edit the external address yet it never “detects my Nabu Casa” connection and nothing I do causes this much talked about “switch to use external connection.” Does anyone know how to make that switch appear?

External address is under App Configuration “You have to be connected to the server first with internal address on the app”- Then click your user/home, There you can CLICK external URL and choose Home assistant Cloud it fixed the issue for me.

1 Like

Hi there,

having no luck at all getting the Ios app to work outside of the network despite trying all of the above.
I have deleted the device/integration on HA and then deleted the ios app from phone and then upon restart reloaded the app from app store and restarted and it is like nothing happened - it logs straight into the HA. the “home assistant cloud” and “Connect via Cloud” option button despite when the I have reset the app and it shows that Nabu Casa is detected.

What am I doing wrong ?

I also note that on the ios app when I show the configuration, I only have the options of internal and external URL and it tells me how it is connected.

Thanks, this worked out for me!

Came here to discover the “reset” option when faced with a blank screen in iOS and only the configuration gear. No amount of deleting and reinstalling the app worked, but reset had me going in about 3 seconds.

Started receiving 403:Forbidden errors from an already well-established iOS app a few days ago. Learned this was a forced logout/update due to a home-page/app store location change for the app. Zeroed out the file ip_bans.yaml file and the app still complains. Double-checked, and ip_bans is not the issue. :frowning: Is this an IPv6 issue, perhaps?

Nope, it was the internal_url: line in my configuration.yaml file that was the issue. Corrected, and now all is well on the phone, once again. :slight_smile: