Can't connect Zigbee wall socket

I’ve just got a Home Assistant Yellow and am trying to connect a Zigbee wall socket to it. This is the device:

I can get it into pairing mode by long pressing either power touch button, but the HA never sees any device. I’ve tried moving the HAYellow as close as possible (not right next to it since I need ethernet) with no difference.

I’m totally new to HA and I have no idea if the socket is faulty, the HAYellow is faulty, or whether there is some magic incantation I have to invoke. I have power cycled everything as well and moved my WiFi channels to ones that should not overlap the Zigbee channel 11 that is shown as in use.

Any ideas?

I saw that people having ha yellow have problem with connecting zigbee devices using z2m, but somehow it can connect using zha. It’s probably related to ha yellow or coordinator, not the device. Maybe you got faulty device.
You didn’t wrote did you use z2m or zha.

Is your device supported? I cannot find “Jinvoo” in this list. Database of Zigbee devices compatible with ZHA, Tasmota, Zigbee2MQTT, deCONZ, ZiGate and ioBroker

This switch should work with ha based on q/a

In home assistant zha does it create individual switches to control?
Answer:Yes, it does , 4 for each power outlet, only one for the USB slots however. There is also an overall stitch that controls turning all outlets on or off, which all switches are an entity of this device.
By stuart sayer on 16 March 2023
Yes, there are 5 switches that you can control individually
By Brata W. on 17 March 2023
4 switches for the power outlets and 1 switch for the USB outputs
By Amazon Customer on 16 March 2023
In zigbee2mqtt there are separate switches for each of the mains 4 power outlets but the 4 x usb ports are controlled together by 1 switch
By Nicola on 17 March 2023
Don't use zha but in zigbee2mqtt it certainly does
By Luigi on 16 March 2023

Yeah might be that it is supported but listed under a different brand. OP should provide details about his setup (ZHA? Z2M?), are you running other zigbee devices successfully or is this your first device?

To answer some of the questions; I have no other Zigbee devices, I’m a HA novice and this is a first time setup for the Yellow. I am using the Zigbee Home Automation/Yellow Multi-Pan integration that was installed by default.

It was showing as configured, but I went in and tried “Migrate radio”, choosing /dev/ttyAMA1, SiLabs, 115200 and hardware flow control.

That failed with an error:

Logger: zigpy_deconz.api
Source: components/zha/
First occurred: 07:29:42 (3 occurrences)
Last logged: 07:43:17

No response to 'Command.read_parameter' command with seq id '0x02;

Now the integration is showing “Retrying setup”. So I’m now worse off :frowning:

Hi Clyde, welcome to the forum!

I see a lot of issues with the yellow and zigbee: Search results for 'yellow zigbee' - Home Assistant Community
1 of the results: Yellow ZHA failed to connect

So now I’ve tried reflashing the radio. After jumping through numerous hoops I can get to the point where the radio appears to be in bootload mode, but the universal_silabs_flasher won’t talk to it.

+ universal-silabs-flasher -v --probe-method bootloader --device /dev/ttyAMA1 flash --allow-cross-flashing --firmware EmberZNet/NabuCasa_Yellow_EZSP_v6.10.3.0_PA32_ncp-uart-hw_115200.gbl
2023-05-23 11:58:57 a0d7b954-ssh asyncio[1662] DEBUG Using selector: EpollSelector
2023-05-23 11:58:57 a0d7b954-ssh universal_silabs_flasher.flasher[1662] INFO Probing ApplicationType.GECKO_BOOTLOADER at 115200 baud
2023-05-23 11:58:57 a0d7b954-ssh universal_silabs_flasher.common[1662] DEBUG Connection made: SerialTransport(<_UnixSelectorEventLoop running=True closed=False debug=False>, <universal_silabs_flasher.gecko_bootloader.GeckoBootloaderProtocol object at 0x7f9c503790>, Serial<id=0x7f9c4e02e0, open=True>(port='/dev/ttyAMA1', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=0, xonxoff=False, rtscts=False, dsrdtr=False))
2023-05-23 11:58:57 a0d7b954-ssh universal_silabs_flasher.common[1662] DEBUG Sending data b'3'
2023-05-23 11:58:57 a0d7b954-ssh universal_silabs_flasher.common[1662] DEBUG Received data b'l\r\n2. run\r\n3. eb'
2023-05-23 11:58:57 a0d7b954-ssh universal_silabs_flasher.gecko_bootloader[1662] DEBUG Parsing State.WAITING_FOR_MENU: bytearray(b'l\r\n2. run\r\n3. eb')

I’ve tried various serial terminal programs to see what is happening:

  • cu - can’t seem to install it in the ssh container
  • screen - doesn’t seem to connect (screen /dev/ttyAMA1 115200) - it just blocks until ^C.
  • minicom - shows data coming from the bootloader, but it’s garbled. Not sure if that’s a mincom issue or not. It just spits out stuff like this, which shows that there is a radio there and the serial port is working, but not much else.
Gecko Bootloader v2.00.01
   BL >
Gecko Bootloader v2.00.l info
BL >
Gecko Bootloader
3. ebl info
BL >
Gecko Boo
cko Bootloader v3. ebl info
BL oader v2.00.01
1. upload gbl
BL >
Gecko Bootloader v2. ebl info
BL >

I’m pretty frustrated by this - the whole idea of buying the Yellow was that I expected it to work out of the box. Right now it’s just an expensive Raspberry Pi with no radio.

So while I have had no luck updating the radio firmware, it is working. By moving the Zigbee socket right next to the HA Yellow, it has found it and can control it. Looks like the range is pretty poor, but I don’t know if that’s an issue with the socket, the HA Yellow, or just Zigbee in general.

Range is not poor but zigbee as a mesh network uses routers, like outlet socket, to expand network. Maybe you have problem with a coordinator or some settings in z2m, or just your zigbee channel is overlapping with wifi channel - most likely.

Nope, as I mentioned above, I made sure my WiFi channels are not conflicting with the Zigbee channel.

It may just be that my expectations of Zigbee were unrealistic - I had expected that using 915MHz would provide better range, but I now realise that there are very few Zigbee devices on the market using that frequency. I think I’ll just stick to WiFi, and BLE for battery powered devices.

I had expected that using 915MHz would provide better range

I’m using channel 11 and this should use 2.4 hgz frequency according to this.
When I expanded my wifi netowk with another wifi mesh node I noticed that my zigbee network is having better connections. So I believe that zigbee is using 2.4 freq created by router. In my opinion if your zigbee network has a connection problem and is using 2.4 freq than you will most likely face the same problem with wifi devices.
Any special reason you decided to use this freq ?

That is Z-Wave, not Zigbee. All Zigbee devices use 2.4 GHz.

Not strictly true, Zigbee is also implemented in the 915MHz band. But from a practical perspective you are right, in that it is very hard to find any Zigbee devices other than 2.4GHz. I know that now…