Home Assistant Community

Can't find new device?

#1

I just added another device but can’t seem to find it? It says its discovered but the node Id is the same as the first one but the friendly name is not. This is my second wall power outlet but I don’t think it was discovered??

I did group my switches, does that make a difference?

ID 2

ID 2

I want to name the second device “Backroom_east” and entity id be called “Switch.light_backroom_east”

When I try to rename this it says, “Domain needs to stay the same” ???

#2

How many “zwave.xxx” devices do you have in that list?

I think you should have two zwave.xxx devices.

#3

This is what’s in Entity Registry:
image

  1. Switch for my outlet in Living Room next to my couch (node_id:2)
  2. Aeotec ZW090 Z-stick (node_id:1)
  3. GE 14288 Duplex Receptacle (node_id:2) ( This has the same Entity Id as my Living Room Couch). When I try to change the Entity ID default (“zwave.ge_14288_duplex_receptacle”)of this GE 14288 Duplex Receptacle To a better description, It says, the “Domain needs to stay the same”
#4

When you change the entity_id you still need to leave the “zwave.” portion intact. You can only change the “ge_14288_duplex_receptacle” portion.

you can make the friendly name anything you want.

#5

@finity
Ok. I did do that and it worked, BUT I am trying to make another Switch entity id like the one in the screen shot. How do I create another light switch under the Switch entity id? The one in the
screen shot does work.
image

#6

@finity
Here is more info on the two devices.
I want to put the “BackRoom East” on a Switch like I did for “Living Room Plug Couch Rt”
image

#7

@finity
One more piece of info

#8

When you paired the other zwave device to HA it should have created another switch entity already.

Take a screen shot of all of the zwave.xxx entities like you did above for the group.all_switches entity. That is the information I need to help you further.

#9

Here it is

#10

Not sure why this groups.yaml is empty?

#11

no, those are “groups.xxx”. i need the “zwave.xxx”.

#13

These are the 3 zwave devices I have:

  1. This is the first wall outlet I added and changed it to a switch somehow and it works

  2. USB hub

  3. Another wall outlet. can’t get this to turn light on or off like #1

#14

From those images it looks to me like you only have two zwave devices - one being your z stick hub (node 1) and the second being your GE duplex receptacle (node 2).

as an FYI, every time you add a zwave device it will create one or more entities. The number and type of entities depends on the purpose of the device. however, you will ALWAYS BY DEFAULT get a zwave.xxxx entity when you add a zwave device.

In your case you put in a zwave hub which creates one zwave.xxx entity and no others since it is the hub.

then when you added the outlet it created a zwave.ge_14288_duplex receptacle entity as the “base” entity and then a switch.ge_14288_duplex receptacle as the “active” entity. then you changed that entity_id to switch.light_livingroom_couch.

Then it seems that you changed the friendly_name of the entities for the node 2 entities (zwave.ge… & switch.light.livingroom…) to different things and that confused things.

so you now have two zwave nodes (devices)

node 1 = the Aeotec stick ( includes only zwave.aeotec_zw090_zstick_gen5_us)
node 2 = the receptacle ( includes both zwave.ge_14288_duplex receptacle and switch.ge_14288_duplex receptacle which you renamed to switch.light_livingroom_couch)

if those are the only devices you have and you think you should have more then something might have gone wrong in the pairing process for the other device. Or it’s in there and you aren’t seeing it.

But since you are only showing me two zwave.xxx entities then I’m going to assume the former.

#15

I do see your point. There should be 3 nodes and there are only 2. Should I just remove node 2 and start over?

#16

Not necessarily.

I would try to pair the other node that isn’t already paired first.

#17

How do I do that?

#18

You don’t know how to pair a new node? Didn’t you already pair one node before? How did you pair that one?

#19

How should I pair the outlets? Switch? Keep Zwave.xxx?

#20

I think you might be very confused on how this works. I thought I explained it above already but let me try again. I’m going to assume you have no idea how the pairing process works so I’ll start from there:

you go to the “configuration->z-wave” page. There you will find a couple of “buttons” - “add node” & “add node secure”. Depending on the type of device you have (does it support the security features?) then you will click on the applicable button.

then you need to do what ever is required on the device itself to complete the pairing process.

after the pairing process is completed the device/HA/zwave will automatically add up to several “entities” that all will all get there own entity_id’s based on the class/type of the device. HOWEVER, EVERY DEVICE WILL ALWAYS CREATE A ZWAVE.XXX ENTITY_ID.

examples:

light bulbs will at a minimum create a zwave.xxxx entity_id and a light.xxxx entity_id.
switches (outlets are switches too) will at a minimum create a zwave.xxxx and a switch.xxxx entity_id
sensors will at a minimum create a zwave.xxxx and a sensor.xxxx entity_id

all of the above are also likely to create several more entity_id’s based on the same node number. so if you click on (for example) the zwave.xxxx and the switch.xxxx you will see that the node numbers are the same. and you might see other entity_ids like sensor.xxxx_alarm_level or sensor.xxxx_burglar all with the same node numbers.

Then lets say you add another (for example) outlet that is of the exact same kind as the first one that you added. Then the system will create all of the identically same entity_ids as the first node but will then add a “_1” to the end and the next one will add “_2” to the end, etc… And you can see that all of those entities are associated with the same node numbers. If the controller is node 1 then the first thing you pair with it will be node 2 and the next thing you pair will be node 3 etc.

so a long answer to a short question. But the bottom line is you don’t pick which way to pair the devices. the system does and you need to keep them the same. the only thing you can change is the “xxxx” stuff after the domain (zwave., light., switch., etc) which you can’t change.

#21

I feel like i screwed this up, at least the outlets/switches.

I purchased all Z-wave Plus devices, so I added devices as “add node secure” even though my hub shows “is_zwave_plus: false”

I was going to remove the switch node #2, but when I try to remove the 2nd node [switch.light_livingroom_couch] in “Remove Node” in configuration->z-wave page, it only shows me the " BackRoom East" which is the friendly name of another device ( guess it could even be the second part of the zwave identity_id which you mentioned above).

Bottom line is, how do I start over without having to remove the hub? I’d like to remove node2 and pair it again as the original default settings.
So when discovery finds a new device I can “add secure node” with manufacturers zwave.xxx entity_id and switch.xxx entitiy_id

Btw, thank you for the explanation!