Can't get HACS to install -

Trying to install HACS - following the install instructions but
wget -O - | bash -
only seems to download “index.html” - can’t see anything like the outputs in other topics on the subject.

New to all this and don’t know what to try to diagnose/fix.

HAOS on Rasbperry Pi 4 - installed following standard instructions. Terminal and SSH Add-0n installed and working - using Putty on PC to talk to pi. (Struggling to copy to or from the Add-on webui on Homeassistant itself hence the screenshot)

Where am I going wrong? Thanks

If I try the same command again I get

[core-ssh ~]$ wget -o - | bash -
Connecting to (
Connecting to (
wget: can’t open ‘index.html’: File exists
[core-ssh ~]$

Seems to have downloaded something that looks like a ‘batch’ file but isn’t running it?

Ran the index.html file using source index.html

Output as follows - seemed to work…

…but still no HACS showing up in integrations

[core-ssh ~]$ source index.html
INFO: Trying to find the correct directory…
INFO: Found Home Assistant configuration directory at ‘/root/config’
INFO: Creating custom_components directory…
INFO: Changing to the custom_components directory…
INFO: Downloading HACS
Connecting to (
Connecting to (
Connecting to (
saving to ‘’ 100% |*******************************************************************************| 1964k 0:00:00 ETA
‘’ saved
INFO: Creating HACS directory…
INFO: Unpacking HACS…
INFO: Removing HACS zip file…
INFO: Installation complete.

INFO: Remember to restart Home Assistant before you configure it
[core-ssh custom_components]$ ls
[core-ssh custom_components]$

1 Like

OK fixed. Clearing browser cache in Chrome does not do the job

Ctrl-F5 does do the job

Can’t help thinking this could all be easier/better documented.

1 Like

I was having the same issue until I realized the HACS page advises to use “” but it should be “”. I cleared cache until the cows came home, but I knew the install part didn’t look right.

I’m facing the same problem.
I executed the job wget -0 | bash -
But the program also stops at index.html saved.

unfortunately when I run your suggested code
wget -q -O - | bash - it says:


“can’t open ‘’: file exists”

Any ideas?

1 Like

Sorry for delayed response, been away.

I’m no expert but that ‘Can’t open message’ means you already have on your disc.

So I think there’s two possibilities:

  1. the file has been downloaded but not ‘installed’ - I’d find it, delete it and try again.
  2. It’s a browser caching issue - in Chrome I needed CTRL F5 to make HACS appear.

Don’t forget to restart HA.

Good luck

Don’t think you want the ‘-O’ option. You want ‘wget | bash -’. This command will just output the file to stdout which gets passed to bash. A ‘man wget’ will tell you all you need to know (plus a lot more).

Upon new install of HA, I have the same issue. None of the suggested solutions seem to work. Using any command, I get the same response:
wget -q -O - | bash -
wget: can’t open ‘index.html’ : File exists

Reloading the page, clearing the cache does not help. It seems it downloaded this ‘index.html’, and now, it’s interfering with the install process. How can I find this file and delete it? What is the download folder on a Virtual Linux Machine used for HA?

P.S. I powered the Virtual Machine completely. Started it anew, and copy pasted the command into the terminal window using CTRL+SHIFT+V:

wget -O - | bash -

And the installation went on as usual.

For anyone on this thread the correct command syntax to install HACS is:

wget -O - | bash -

O is letter O (capital O, not 0 or o).


When I try to install openSSH according to the instructions (Download | HACS) I get a message like this when I press open web ui.
What am I doing wrong.

Help please anyone

I’ve downloaded everything and have it appear

When I click on it I just get this

And then when I click on the I just get

I’m a complete noob like 2 days old. How do I get to this page

Click in the red circle or type something in the search bar.

1 Like

Thanks for this

This worked for me installing via Integrations. But on my Mac it was “Cmd + Shift + R”

This is the anwer for me.

new to this, total noob, installed HAOS 12.4 on virtualbox VM in Windows 11 and it booted to CLI interface great, then logged into browser and created new account and installed ssh and terminal without any problem and used both wget get and install commands, rebooted HAOS on virtualbox and cleared data on chrome and reconnected, repeated it multiple times but still HACS wont show up, i believe its because my isp is double nat and its not letting me but not sure, any help appreciated much.