Cant get Nest integration to work

I’ve followed the steps to the T, twice. When I add the intergration and then enter my project ID, I get taken to this page. I’ve made sure the user I am signed into in google is in the authorized users

Yes, I am in the same boat. Was working fine until today and I started getting Error 400 errors on my Nest Thermostat. I created a new integration using the updated instructions twice. I am getting the same error.


I have no errors in the log either.

@allenporter - It appears you are the resident expert in the Nest Integration. Has something been broken in the 2022.7 release in the Nest Integration that you know of?

I have went back into my Google Cloud Account and double-checked everything shown for can’t link in the trouble shooting guide. My web oauth client id matches the oauth id in the device access console. It is the OAuth id given along with the Client Secret right?


Hi, Typically the best advice is always to look at the current documentation which is quite extensive. See Nest - Home Assistant in particular for troubleshooting under " *Can’t link to [Project Name]: Please contact [Project Name] if the issue persists".

This is a very common misconfiguration, which is understandable given the number of changes you’ve been asked to make to keep nest authentication working (e.g. see active alert)

I give up. I have tried 3 different times. I have read the docs and meticulously made sure the OAuth for Web matches the OAuth in the Device Access Console. Everything matches.

It says it can take up to a few hours, maybe that is it. If it is not up in the morning, I give up. Will probably give up on Nest as well LOL. Tired of Google mucking something up. It shouldn’t be this freaking hard.

And the sad thing is that is was working up until about 3 hours ago when my Thermostat stopped responding. Thought it had something to do with all the changes from Google and the Nest change in 2022.7. So I deleted everyting from Google Cloud. I didn’t see the Troubleshooting piece about the Thermostats until after I deleted everything. Bout my luck!

Did you check all three places called out in the troubleshooting i pointed out, including application credentials? I’m guessing you missed that since you didn’t mention it.

I’ve never seen it take a few hours, there is just a detail you’re missing.

No idea what you’re talking about regarding thermostats. Let’s just keep it focused on the specific 4 points under “can’t link” – this is very simple to resolve if we check all of those four points.

I did miss the Application Credentials part. I did not click on the link and delete my old credentials. I did delete it out of the configuration.yaml, just not the other part of it. That part is easily overlooked in the Troubleshooting guide.

This is what started this whole exercise in the first place. My thermostat started showing as unavailable, but my cameras were working. I stumbled across this after I deleted my integration:

Anyways, it is working now. I appreciate you helping me successfully fix my issue.

Yes I added the text there, but as you can see the entire page has a massive amount of content, and many possibilities of things that can go wrong.

I see, thanks for that context. The idea is there are warnings in the logs with instructions and a “reconfigure” alert for the integration, as well as breaking change in the release notes. So it’s not just the thermostat unavailable but the entire integration was broken.

Did you see a red alert for nest after upgrade? It is supposed to walk you through the steps for upgrade, and the documentation is supplemental on case something gets configured wrong.

No I did not get the red alert that I can recall. If I did, I must have just clicked right through it and paid it no mind. I did remove the credentials from configuration.yaml but don’t kniow if I read that in the release notes or I did get the alert after all LOL. But I do not remember being walked through the steps for upgrade.

As info, I never received any Nest related info in the logs even after adding the logger logs found in the troubleshooting docs.

Again, Google doesn’t have to make it this hard. Hell, I am a tech guy that does programming on the side, and I find their whole flow and process to be confusing and cumbersome. But that discussion is for another day LOL.

Yes the problem here is a bit complicated – you are an end user but have to use a flow meant for application developers. Nabu casa is not an approved partner due to Google having a very high security bar (some details not worth getting into here) so thefore you have to go through the developer path to get access to your data.

The problem here is somewhat my fault also – we went back and forth on which authentication method we were using and unfortunately i picked one that had security issues that needed to be resolved.

I am facing the same problems as @spalexander . Scott, did you ever get this resolved?
@allenporter I have followed the troubleshooting procedures outlined in the documentation, including recreating my complete HA instance from scratch, all to no avail. Would there be any additional information in the logs? I am comfortable using SSH to get into HA, but haven’t seen anything helpful there so far.

This thread is hard for me to follow. What’s the problem?

It is confusing, but if you follow the video and directions (slowly) they do work. I had the video on one device, the written directions on another and on the third I implemented the my setup. The confusion for most is that you are going to two different sites on Google with the same or similar names and you need stuff from both.

I completed all the steps in the documentation, and am getting an error message when opening this link:

Can’t link to Nest Access

Please contact Nest Access if the issue persists

Believe me, I followed the instructions to the dot.

I had this error once. Follow the troubleshooting and remove credentials (integration then the three dot menu.)


@dschmidtadv yep what @bschatzow said is right check out the “can’t link” error in troubleshooting.

I have a fix in progress to help make this easier to find by prompting when deleting the integration.

1 Like

Yes, I missed the step in the troubleshooting about removing the credentials in HA. Go to Settings/Devices & Services and click the 3 dots on the top, right hand side. Click on Application credentials and delete the Nest credentials. Once I did this, it authenticated and has worked ever since.




Thanks, @allenporter, for your instructions and patient re-explanation.

I’m so over it with this. I’ve tried this 5 times now and each time I completely remove everything, follow the the luckily very detailed instructions (much appreciated) to the letter and get “Can’t link to Home Assistant Please contact Home Assistant if the issue persists”.

The whole process feels a bit like “first go see Lenny under the bridge in east Los Angeles. He’ll give you 50 tokens for Chuck E Cheese. Take those tokens over to Mr. Cheese and win 200 tickets for the goodie counter. Get 5 mood rings and trade them with the guy at the drive through at the Dunkin Donuts for a sausage egg and cheese and then finally present that sandwich to the guy wiping windshields on the off ramp across from Denny’s. That man will now punch you in the face because of reasons. If it’s still not working just contact an email address of your choosing.”

Much respect to whoever got this integration working in the first place but at this point I can’t justify wasting any more time on Nest as a service. Google has completely ruined the whole experience. It’s literally easier to build a camera from a youtube video tutorial than it is to just look at Nest cameras on my own LAN. Absurd.

Sorry for the rant.


Sorry to be clear I’m not trying to be a negative nancy here. I’ve been in IT for a long time and I try to use humor when I’m frustrated and I was frustrated with what has been happening to Nest since before I got into HA. I’m not frustrated with any of you or the wonderful people who put together the docs for this integration. I just can’t believe how much easier it is for other products to integrate seemingly more complicated tech into HA without charging me for more subscriptions and making the community jump through hoops like this. Sorry I yelled :smiley: