Can't get Z-wave up and running

I had an old topic about this but it quickly became too convoluted talking about other problems so I decided to make a new one specific to this issue. I feel like I’ve ALMOST got Z-wave working but I’m stonewalled by this error log, I don’t know what to do about it, any help would be appreciated.

2019-01-23 23:16:53 WARNING (Dummy-4) [openzwave] Z-Wave Notification DriverFailed : {'notificationType': 'DriverFailed', 'homeId': 0, 'nodeId': 255}
2019-01-23 23:21:53 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave not ready after 300 seconds, continuing anyway
2019-01-23 23:21:53 ERROR (MainThread) [homeassistant.core] Error doing job: Future exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/zwave/", line 703, in _finalize_start
    network.set_poll_interval(polling_interval, False)
  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 894, in set_poll_interval
    self.manager.setPollInterval(milliseconds, bIntervalBetweenPolls)
  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 564, in manager
    raise ZWaveException(u"Manager not initialised")
openzwave.object.ZWaveException: 'Zwave Generic Exception : Manager not initialised'
2019-01-24 00:00:00 WARNING (SyncWorker_6) [openzwave] Network must be awake

Not entirely sure what it means by Manager not initialized but none of the commands work in the Z-Wave Network Management besides “Start Network” which seems to call and then do nothing. All other commands fail to call.

How do you have this installed? What is your Zwave configuration?

@zarthan Sorry I always forget some of these basic details! I have Installed on a Raspberry Pi 3 and a Linear HUSBZ-1 USB stick to pickup the Z-Wave devices.

  usb_path: /dev/ttyACM0

and I got that going on in the configuration.

Are you sure the device is detected as /dev/ttyACM0

No I am not! But looking through the System>Hardware thing then the only two things that show up are /dev/ttyACM0 and /dev/ttyAMA0 and I’ve tried both

What does the OZW_Log.txt show?

2019-01-24 14:04:45.725 Always, OpenZwave Version 1.4.3322 Starting Up
2019-01-24 14:05:07.455 Info, Setting Up Provided Network Key for Secure Communications
2019-01-24 14:05:07.455 Warning, Failed - Network Key Not Set
2019-01-24 14:05:07.456 Info, mgr,     Added driver for controller /dev/ttyAMA0
2019-01-24 14:05:07.456 Info,   Opening controller /dev/ttyAMA0
2019-01-24 14:05:07.456 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2019-01-24 14:05:07.456 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2019-01-24 14:05:07.458 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2019-01-24 14:05:07.458 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2019-01-24 14:05:07.458 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2019-01-24 14:05:07.458 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2019-01-24 14:05:07.458 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2019-01-24 14:05:07.458 Detail, 
2019-01-24 14:05:07.458 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2019-01-24 14:05:07.459 Detail, contrlr, Notification: DriverFailed

@firstof9 There’s the full log, hopefully none of that is sensitive information haha

Ok so that’s saying ttyAMA0 isn’t a Zwave controler, can you change your setting to ttyACM0 and see what the log says then?

@firstof9 Restarted HA with the same usbpath (ttyACM0) and the exact same log comes up. Either usbpath causes the exact same log

What is displayed when you enter the command hassio hardware info into a shell?

@MichaelGuyYo, you can also get the hardware output at: http://yourip:8213/hassio/system and clicking the hardware button . If you dont want to enable ssh to get to the console you can use this.

@hometoast Thank god for your explanation because I would’ve been a little lost with @firstof9 haha anyway!

* serial:
  * /dev/ttyAMA0
  * /dev/ttyACM0
* input:
* disk:
* gpio:
  * gpiochip0
  * gpiochip128
* audio:
  * 0:
    * name: bcm2835_alsa - bcm2835 ALSA
    * type: ALSA
    * devices:
      * [object Object]
      * [object Object]

There’s that! And like I said, I’ve tried both usb_paths

I still don’t have an answer, but just double checking, you used the hassio/hassos installation, and not hassio as a container under raspbian, correct?

That’s correct, yes

Try what’s mentioned in this post:


That’s what did it firstof you are my savior! Like really, alright now I just gotta get comfortable with the Z-Wave Network Manager but seriously, thank you so much.

Glad I was able to help :slight_smile:

1 Like

I am not having much luck zwave seems to be hosed it, the devices that are showing up are not responding.