Can't install homeassistant on VirtualBox for over 6 months

A very long story short, I had a catastrophic failure with my server about 8 months ago, main drive failed, all backups of drive failed, all backups of homeassistant fail to restore (regardless of installing the exact version of homeassistant I was on).

Tried the restore process about 20 times on different pcs, on my main gaming desktop that has an i9 13900K, so I know it’s not CPU bound or anything like that.

Anyway I’m so bored of trying to get the restore to work I’ve decided I’m just going to start again, but I can’t even do that, installing a brand new copy returns this error every time, specs of the server;

512GB C drive SSD

I’m at a complete loss, I’m an IT manager by day so I’m not what you can consider a moron but I’m just lost as to what I’m doing wrong here.

I’ve tried uninstalling VirtualBox, it makes no change but does seem to work on my gaming PC if I install fresh, but have no idea how a fresh install can fail on one specific PC? Unless it could be driver related but how I’d figure that out I don’t know.

VB sucks, VMWare player/workstation is 100% more reliable (but a bit harder to set up)


My main requirement is USB pass through so I can have zigbee/zwave, if that works I will setup whatever apart from a standalone Pi, because Pis suck

VMWare supports USB passthrough :wink:

1 Like

Is the error I’m getting likely due to be because of VB?

If you will be running a hypervisor on a Windows machine I suggest Hyper-V, as it comes with Windows and supports USB passthrough - Beginners’ Guide: Hyper-V USB Passthrough - BDRSuite.

If you want to BM install a hypervisor I suggest Proxmox VE.

Do you have USB pass through working on Hyper-V?

I remember ages ago I was trying to migrate to it but couldnt get Hyper-V USB pass through to work for love nor money!

Can’t really help you with your specific problem but for me, Virtualbox works just fine. So it’s not that per se. I’m running it from Linux Mint, but I have successfully started an instance from VB on Windows too.
I assume you followed the exact instructions, there’s a few non-standard options that have to be checked IIRC.

Yeah I’ve followed the instructions to the T.

Just downloaded the VHDK for Hyper-V (as that is actually my preference, and if I can get USB pass through working we’re golden).

It booted up right away no problems… super weird!

As far as i know, hyperV doesn’t support usb pass through

Yes, it is.
When i started with HA, i used HyperV.
With the Zigbee i used then it was possible to configure it for ser2lan,.
When it died, i found out my new zigbee usb did not support ser2lan, so i needed to switch to another VM.

For my work i used VMware already with great satisfaction, but VB being freeware and all I figured lets give VB a try with HA.
But i found it was highly unstable (I had the same errors and I never found out what exactly the issue was).

So i moved to VMware and never looked back.
It is a bit harder to configure, but worth it :wink:

PS, Vmware’s player is freeware, but workstation is not. So i used my workstation on my work pc to set it up and configure it, and then moved it to player…that made it a lot easier :innocent:

Unfortunately, USB passthrough is not natively supported in Hyper-V environments. However, you may still use the following methods to accomplish Hyper-V USB passthrough:

  • Activate the Enhanced Session Mode.
  • Start an RDP (Remote Desktop Protocol) session.
  • Install USB solutions that are network-based.
  • Install USB solutions that are software-based.

For sure it wasn’t supported when i started with HA, not so sure now, but no intentions to move back, also because in the meanwhile i dropped W10, my host now runs Debian12.
(Originally i intended to run debian supervised, but found out it has too many restrictions :wink:)

I started with VMware, but once tried VB and Hyper-V each, NO reasons to try ever again , if we just “ignore” VB, and look at Hyper-V vs VMware,
Windows will increase in usage much more, with H-V, and one never knows with Windows, if it’s not a slimmed dedicated “server”, then many things can happened with Microsoft Updates, last updates (for W10) was killing 2 machines here, took hours and i had to reboot 3 times , and who knows what changes they do that could affect H-V , VMware is just so much more reliable, and one can shut it down and copy/backup-the whole VM-folder, and fire it up on any other machine

Even when the old host is windows and the new one Linux :nerd_face:

1 Like