Can't install node-red

Tried all. Can’t find it in add-ons. Tried to install with HACS, then activate in integrations. But no luck to get it in add-ons. I’m running latest version of hassos on a RPI4. Tried to add the repository in add-ons, but no luck there

Just to make sure… You went to Supervisor -> Add-on store and searched for “node” and nothing shows up? Normally you wouldn’t even need to add the repo…

FYI: The one from HACS/integrations is “only” an extension to the Add-on and not Node-Red itself.

Yepp, nothing comes up when I’m searching

1 Like

Can you give me some examples of Add-ons that are there?

Did you add this repo?

You mentioned you added a repo - which one?

Was it the one in my comment above?

Don’t know wich one. But it didn’t work so uninstalled it. It’s strange though, I can only search the official add-ons. If I remember correctly, I had a lot more add-ons to choose from about a month ago.

Yeah that’s also what I noticed. Try that one, I checked my repo-list and found that for the community addons.

Your link above isn’t complete

it is?

or this

1 Like

yeah, that one I’ve tried. Just says Unknown

Don’t know what I am doing wrong…

1 Like

Did you try to reload from the 3-dot menu? What happens if you try to add ? Also unknown?

At the bottom it says you might have to check your system log:


If you have added a repository, but it’s not showing up, it means that the repository contains invalid configuration. Go to the Supervisor panel and then the System tab to find the System log. It should tell you what went wrong. Report this information to the repository author.

20-09-12 14:23:18 ERROR (MainThread) [] Can’t load from repository

20-09-12 14:23:18 INFO (MainThread) [] Clone add-on repository
20-09-12 14:23:18 ERROR (MainThread) [] Can’t clone repository: Cmd(‘git’) failed due to: exit code(128)
cmdline: git clone --depth=1 --recursive --shallow-submodules -v /data/addons/git/981db822
stderr: 'Cloning into ‘/data/addons/git/981db822’…
fatal: repository ‘’ not found
20-09-12 14:23:18 ERROR (MainThread) [] Can’t load from repository

You can’t add this: as a repo. You have to add this:

Haha, of course! Maybe I should leave the computer for a while and get some fresh air :slight_smile:

1 Like

No, now it’s time for some nice node-red automations :wink:

Yeah, Never used it before sm got some reading to do :face_with_monocle:

I’m having the same issue where the add-on isn’t available in the Supervisor store. I followed the instructions above but it wont let m add any repository. Not even the example from