Cant setup Xiaomi Mijia Smart LED Desk Lamp

Hi, yes it works.

Mine was working until I made an HA update from 0.118.5 to 2020.12.1… I removed the Yeelight integration and try to add it back but without any success… So for now I haven’t found a solution how to get it back into the HA.

I’m on the 2021.1.1, and the integration works. I have enabled LAN Control in Yeelight application just like for Bedside Lamp or Lightstrip Plus.

I updated HA to the latest 2021.1.1 and my MI Desk Lamp 1S isn’t working. It is automatically found by Yeelight integration but that’s all. Lamp is not listed in devices and there is no entity related to my lamp. Yes I have enabled LAN control as it was needed also in HA version 0.118.5. I can control my lamp via yeelight application without problem.

1 Like

I’m running model MJTD01YL and have the same issue. Auto-discovery finds it, but doesn’t add a device or entity. It did the first time before I updated HA to 2021.1.5

Same problem here, I’ve noticed that the “Lan Control” option is gone in the Yeelight app. There is a webserver running on port 80 but that says “This uri doesn’t exist”. There is no pairing code on the lamp so I can’t add through homekit.

Hi all. I’m no longer able to conect the lamp. Through the yeeelink integration, via IP I have a ‘Failed to connect’ error.
Anyone can help me?

1 Like

Same problem here with the integration of MJTD01YL, tried via yaml and yeelight integration without success.

This is the error i get:

Logger: homeassistant.components.yeelight.config_flow
Source: components/yeelight/config_flow.py:152
Integration: Yeelight (documentation, issues)
First occurred: 12:44:16 PM (1 occurrences)
Last logged: 12:44:16 PM

Failed to get properties from 192.168.1.220: A socket error occurred when sending the command.

Found my problem after some googling: Yeelight Bedside Lamp 2 - LAN Control issue after update fw to 2.0.6_0041 - #300 由 Pabert - YEELIGHT Bedside Lamp - Yeelight Forum

It looks with new yeelight app updates they disabled LAN control inside app, i had to install and old yeelight app, (Yeelight 3.2.00 version) and then enable LAN control, after that integration works perfectly fine again.

1 Like

Hi, can you please tell me how to install the 3.2.00 version?
Thankyou

On an android device you can install the app via an APK like: https://www.apkmirror.com/apk/yeelink/yeelight/yeelight-3-2-34-release/yeelight-3-2-34-android-apk-download/

iOS… Apple doesn’t allow to choose what version to download

Next rainy day I think I am going to open it up => next project

Bad News… the switch is disabled. May be the lamp firmware was updated too?qb qa

they disable lan mode in all xiaomi/mi branded yeelight products. xiaomi decision due to security policy.

confirmed. cannot activate lan control for desk lamp 1S latest firmware

If anybody is facing this problem: you should enable LAN control in the Yeelight app before adding your lamp to Home Assistant. If you don’t have that switch in the app, try installing an older version of the app. I was able to do it in yeelight v 3.2.14 with my MJTD01YL desk lamp

it is not necessary to have lan control enabled to control the lamp. It is possible to pair it through the home assistant homekit controller, everything works without problems.
If the lamp is not present in the list of homekit additions, it probably thinks it is already paired; in this case it is necessary to carry out a reset with the button under the base and re-insert the lamp in the yeelight application. The pairing code is present in a sticker under the base of the lamp (it is important to enter it in the format requested by the home assistant, with the numbers separated by “-”)
mi_desk_lamp_homekit

Hi there, I bought a Xiaomi Mi Desk Lamp 1s and I’m facing some issues while trying to pair it using Home Assistant installed on my Raspberry Pi 4 4GB.

More specifically, I tried adding a Homekit Controller integration but it keeps telling me that no device is present, so I can’t proceed pairing the lamp.

Do I have to follow some special steps? I tried resetting the lamp, as well as adding it onto Yeelight and them add the Homekit integration but nothing, it still complains about no device found.

I’m running on firmware version 2.1.7_0016 in case you need it

Please note that the code of the lamp is in the format XXXXYYYY. Should I add a dash after the first 4 numbers?

Many thanks

I am also using version 2.1.7_0016, after the lamp reset and the pairing with the Yeelight app, appeared among the discovered devices. Attention, the integration to use is not “HomeKit”, but “HomeKit Controller”. The code format to use is 123-45-678.

Yeah. I finally managed to get it working. Basically I had to change the network from “bridge” to “host” in my docker installation and everything started working again

Back on mi desk lamp issue… I tried this but I get…

Pair with a device via HomeKit Accessory Protocol

HomeKit Controller communicates with MiDeskLamp1S-BB1D over the local area network using a secure encrypted connection without a separate HomeKit controller or iCloud. Enter your HomeKit pairing code (in the format XXX-XX-XXX) to use this accessory. This code is usually found on the device itself or in the packaging.

An unhandled error occurred while attempting to pair with this device. This may be a temporary failure or your device may not be supported currently.