Cant setup Xiaomi Mijia Smart LED Desk Lamp

Hello, im new to home assistant. Home assistant has automaticaly detected all my yeelight lamps both color and white, but the Xiaomi Mijia Desk Lamp cant be detected or added manually. Is there anything i can do ??? Thanks in advance !!

It appears that there is no way to add it to the gateway so for now I can’t see a way for HA to control it (at least in my app it’s not listed).

Thank you for your reply, but i believe there must be a method.

these are the only things supported by the xiaomi aqara compnnent

and i couldnt see your lamp listed

Did you connect the lamp to your wifi already? Could you tell me the hostname of the device (listed at your router). May be we can try to get it working.

You might be able to use this to control your lamp…but it’s a bit complicated …

Perfect! I will provide some mirobo raw_commands (python-miio) for testing. If the lamp is controlable I will extend the light.xiaomi_miio platform.

I think I was wrong. Actually the Desk Lamp can turn on the Developer Mode. I’m sorry that I didn’t notice before. Maybe it is brought by firmware update. So the Yeelight approach is potentially available.

And, yes. No need to change codes, this lamp can add to HA through Yeelight Platform.

My Desk Lamp detects into HA successfully. Have you updated it to the latest firmware and turned on Developer mode? Try to use Yeelight paltform here. Although it’s branded under Xiaomi, in fact it is produced by Yeelight.

1 Like

Thank you all for your replies, I actually have it in developer mode and used the Yeelight platform ,i will try again today in case i did something wrong.

In case someone is looking up this thread: Xiaomi Desk Lamp is actually working with the light.yeelight component. You can set it up via the yeelight APP (enable Dev Mode - now called LAN mode). Then use the light.yeelight component to add it to your hass. Thx @cxlwill !


@hank, thank you very much for your post. I was struggling to connect it. Went the xiaomi route pulling the token from the database, etc, etc and didnt work. This worked right away. Thank you again

Hi Guys, sorry to totally necro this thread, but do any of you see problems with the desk lamp?
I have added it to HA previously but recently the lamp is unavailable/missing in to HA.

  1. It has worked well previously
  2. I dont see errors in the HA log.
  3. The lamp is available in Yeelight app.
  4. The local API access is still enabled in yeelight app

Im thinking of reflashing the lamp with tasmota or ESPHome to get it working again.

1 Like


I have exactly the same problem since a couple of days. I can’t recall with which version it changed, but since then it shows unavailable in HA.

Does anyone knows how to fix?


For me it was that the component changed from being light to yeelight, which I didnt notice…
See here: 0.91: More streaming, better Zigbee, cameras with ESPHome

1 Like

As @hijinx noted, there was recently a breaking change for Yeelight. Your config should now look like:

      name: Living Room

Mine is working fine on 0.92.1


After searching everywhere on internet, I try to search in that Lamp and found pairing code in the bottom. Just for whom still try to solve this issue

Hi, I tried to fill in the lamp code on the bottom but ha says it is already connected to another controller.
It is connected to the mi app becouse i need to join the wifi network.
I’m stuck with my MI LED Desk Lamp 1S.


Solved, I added the Yeelight integration from integrations.

1 Like

I would like to buy MI LED Desk Lamp 1S but in this page I read that MJTD01SYL is not supported. Can you confirm this model works with integration in the above link? thanks