Can't update installed on linux docker

I’ve been running HA on a RP3 for the last year - it died on me and I figured now was a good time to upgrade to a linux box. I still want to use so I followed the instructions found here to install it inside docker on a linux box:

Everything worked fine for a few days and I could install add-ons just fine. After a few days I couldn’t install addons or updates anymore. I reinstalled everything and again it worked fine for a few days - then I would get the errors again.

The errors look like this:

19-09-28 16:10:20 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.99.3
19-09-28 16:10:20 INFO (SyncWorker_3) [hassio.docker.interface] Update image homeassistant/qemux86-64-homeassistant:0.99.2 to homeassistant/qemux86-64-homeassistant:0.99.3
19-09-28 16:10:20 INFO (SyncWorker_3) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.99.3.
19-09-28 16:10:23 ERROR (SyncWorker_3) [hassio.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.99.3 → 404 Client Error: Not Found (“no such image: homeassistant/qemux86-64-homeassistant:0.99.3: No such image: homeassistant/qemux86-64-homeassistant:0.99.3”).
19-09-28 16:10:23 WARNING (MainThread) [hassio.homeassistant] Update Home Assistant image fails

The above is for upgrading to the new version of HA, but even if I just try to install an add-on I get something similar. Any ideas?

You’re running out of disk space. Look at this thread, though it’s about Proxmox: Proxmox storage

Awesome thanks! I’ll give it a try