Proxmox storage

Hello friends,
I made the move to proxmox and a mac mini server using a certain @drzzs video and install script - and everything was great for a while… snappy, simple, just what I wanted. But I can’t update

19-09-25 07:16:16 INFO (SyncWorker_1) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.99.2.
19-09-25 07:16:55 ERROR (SyncWorker_1) [hassio.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.99.2 → 404 Client Error: Not Found (“no such image: homeassistant/qemux86-64-homeassistant:0.99.2: No such image: homeassistant/qemux86-64-homeassistant:0.99.2”).
19-09-25 07:16:55 WARNING (MainThread) [hassio.homeassistant] Update Home Assistant image fails

I have been researching the problem for quite a while and I think it relates to temp storage. for instance once I was able to delete the homassistant database and do an update, but that hasnt worked recently.

so I wonder has anyone used the install script from whiskers and either come across the same issue, or resized. I have followed the git install options.

1 Like

You’re probably running out of disk space. I’ve had the same issue.
That is why hassio cannot download the new image and therefor it’s not available.

You can read more about this on Whiskerz007 Github page: GitHub - whiskerz007/proxmox_hassos_install

After script completes, click on the new VM ( the script will tell you the ID ), click on the Hardware tab for the VM and change the Memory and Processors settings to what you desire. The Hard Disk can be expanded by clicking on it, then click on the Resize disk button above ( Note: additional steps must be taken for storage to take effect in the VM after the first boot ). The network MAC address can be changed by selecting Network Device and clicking Edit above. Once all changes have been made, click Start above.

Resize Disk

To resize the disk after the first boot

  • At the root prompt type df -h /dev/sda8 and note the Size
  • Shutdown the VM
  • Resize the disk to the desired size
  • At the root prompt type sgdisk -e /dev/sda
  • At the root prompt type reboot
  • Verify resize was successful by typing df -h /dev/sda8 at the root prompt

yeah I have followed the git install options and it didn’t help sadly. I will try again though

this might be user error. when I run df -h /dev/sda8 do I run this from the proxmox shell?
because I get this

df: /dev/sda8: No such file or directory

df - h gives me this

Filesystem Size Used Avail Use% Mounted on
udev 3.9G 0 3.9G 0% /dev
tmpfs 786M 9.0M 777M 2% /run
/dev/mapper/pve-root 58G 16G 40G 28% /
tmpfs 3.9G 43M 3.8G 2% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
/dev/sda2 511M 312K 511M 1% /boot/efi
/dev/fuse 30M 20K 30M 1% /etc/pve
tmpfs 786M 0 786M 0% /run/user/0

Login in the Proxmox Virtual Environment as root and choose your Hassio/HassOS VM.

Click on ‘>_ Console’.

Press ‘Enter’ so that the HassOS login prompt becomes visible.

Login with root (without password).

The hassio prompt becomes visible.

Type ‘login’ and press ‘Enter’.

The ‘#’ becomes visible.

Now type ‘df -h /dev/sda8’ and note the Size.


you are a GOLDEN GOD

1 Like

i just get unknown command for these commands using the same drzzzs install script

EDIT: Nvmnd i didnt see the part where you have to type “login” to get to #