Caseta non-pro workaround

Due to the Lutron Caseta non-pro hub no longer working, I made a workaround configuration to control my lights that relies heavily on IFTTT. It’s a hassle because you have to make two IFTTT applets for every light switch you have (one for on and one for off).

Here is how I did it:

  1. Setup IFTTT
  2. Make a bunch of This=Webhook / That=Caseta. The names and friendly names are important.
  3. Create some input_booleans in configuration.yaml:
    name: bathroom
    icon: mdi:lightbulb
    name: kitchen_island
    icon: mdi:lightbulb
    name: kitchen_oven
    icon: mdi:lightbulb
  1. In your automations.yaml:
- alias: 'caseta lights'
  initial_state: true
    - platform: state
      entity_id: input_boolean.bathroom
    - platform: state
      entity_id: input_boolean.kitchen_island
    - platform: state
      entity_id: input_boolean.kitchen_oven
    - platform: state
      entity_id: input_boolean.kitchen_table
    - platform: state
      entity_id: input_boolean.kitchen_window
    service: ifttt.trigger
    data_template: {"event": "{{ trigger.to_state.attributes.friendly_name }}_{{ trigger.to_state.state }}"}
  1. In your groups.yaml (or however you show your views):
  name: kitchen lights
    - input_boolean.kitchen_island
    - input_boolean.kitchen_oven
    - input_boolean.kitchen_table
    - input_boolean.kitchen_window
  name: misc lights
    - input_boolean.bathroom

I can now turn my lights on an off again in HA and reconfigure my automations.

I hope this helps folks.


Thanks for your work. The switches are now working again.

Works for me as well! Took a little bit of figuring.

Here’s what I did, in case it helps someone else. I set up an ifTTT with event name basement_off and then did the following in my config:

- alias: Turn off basement light 10 minutes after last movement
    platform: state
    entity_id: binary_sensor.vistacam_700_motion_sensor_18
    to: 'off'
      minutes: 10
    service: ifttt.trigger
      event: basement_off
      value1: off

This doesn’t update the status of the switch (yet), but it appears that’s possible by having IFTTT call back to HASS and then updating the input_boolean.

Thanks, @GervaisdeM!

1 Like

Looks like there is interesting work going on over here: Lutron Caseta - Leap SSH integration

If I read that posting correctly, we might have a working Lutron Caseta component working again as it did before.

1 Like

[UPDATE]: Looks like non-media third-party devices integrated in to Harmony Hub (such as lights), are not accessible or visible via HA, only the media devices and actions. Not sure why this is, but if anyone has suggestions (until Lutron Caseta can be fixed directly) please reply…

[UPDATE 2]: Also, looks like the HomeBridge Harmony Hub plug in is getting some update love and may be getting more stable, fyi…

Another workaround option I’m exploring is to use my Harmony Hub, as a bridge. I’ll be digging in to this further and will share any specifics I can, but I’m really just gleaning info from other posts on how to access/control Devices connected to the Harmony Hub. Use the remote: component to send commands to Harmony Hub to control Devices (such as my Lutron Caseta dimmer switches), using HASS Template Switches as a mechanism. This is in addition to accessing Activities on my Harmony. My real goal is to have my Activities available via HomeKit and Siri, as the Harmony Hub functionality of Homebridge is flaky and crashes Homebridge often, but I digress…

Since it appears Caseta integration with Harmony, and 2GIG Go Control panel (and are still functional I’m hopeful some of the other efforts to get direct integration working again in HASS are achievable.

1 Like

I’ve got it working with my Vera device.
Not sure if anyone wants to dig into his source to get the answer, but he got it working somehow. Needs the luton username/password to function.

The work around talked about on this thread worked for me, and sounds as though its being prepared for roll-out (so it won’t require custom components).