CCU2 w/ HomeMatic and homematic IP devices


#41

Make your config look like this:

homematic:
  interfaces:
    wireless:
      host: <ccu-ip-address>
    ip:
      host: <ccu-ip-addres>
      port: 2010

IP-devices (as well as wired devices and thermostat groups) are accessed by using different ports.


#42

Awesome! Worked! :slight_smile: Thanks a lot!!!


#43

It’s me again :slight_smile:
Today I got a new router and the IP-Addresses changed. I used to have them be like 10.0.1.x and not they are 192.168.1.x
So I went ahead and updated my config file with the new ccu-address but it’s not showing up any more in home-assistant. And I have no idea on how to debug something like this?!?
Last week or so I also changed the security of my CCU a bit and require a login now. But it worked until today even with that change. But can that have something todo with it?
I don’t really know where to start looking…

EDIT:
After a bit of digging I found the following in /config/home-assistant.log:

2019-01-23 22:53:21 WARNING (MainThread) [homeassistant.setup] Setup of homematic is taking over 10 seconds.
2019-01-23 22:55:24 WARNING (SyncWorker_16) [pyhomematic._hm] Failed to initialize proxy
2019-01-23 22:57:37 WARNING (SyncWorker_16) [pyhomematic._hm] Failed to initialize proxy

which also maybe explains why my startup-time is soooooo super slow?!?
Are there any other logs that I can have a look at?


#44

After changing a network in such a dramatic way the first thing I would suggest to do is to restart all the relevant devices. Once that is done, ensure you have the correct IP addresses in your configuration. Also don’t forget to adjust firewalls. The CCU has a builtin firewall. There you have to allow access from the new network or at least the new IP of your Home Assistant machine.
The error itself from your log means that Home Assistant is not able to connect to the CCU.


#45

And once again you are my hero!!! The firewall on the CCU was the problem!!! Didn’t think about that!!!
DANKE DANKE DANKE :slight_smile: