Any news about circle-sensor-card not anymore working? Where to get a new working release?

This is what i get since 10 days…


Do a search on github using google for that custom card. You’ll be able to find the repo and see if it’s been updated.

Do this for your google search


Edit, found the repo. Looks like it’s been deserted:

What’s the errors in your log?

1 Like

I get no error in the logs… only in the frontend…

You should have an error in your home-assistant.log, not the UI log

Yes, i checked home-assistant.log, but no error regarding that card

Then verify that the resource exists, the error on screen is that it cannot find the custom card. Also, I believe there was a change to how custom cards work between august and now. So it may just not work until someone fixes it.

I doubled checked and the path is correct… it was working till some days ago… just after updating to 0.85.1

what version were you at before? Also, have you tried clearing your cache and reloading the page?

Yes, i made all of this… changing from type: module to type: js i get the following error:

circle-sensor-card.js?v=1.2.0:1:8 Uncaught SyntaxError: Unexpected token {

Well looks like it’s broken for this version. So, either you need to wait til someone fixes it, fix it yourself, or downgrade to the version it worked.

I must only wait as i am NOT able to fix by myself… Are u using this card?

If i open the developer console i get these errors about the card:

Are you able to trace where it is wrong?

There’s already a PR open to fix this issue
You basically just have to remove one character in the code, so you should be fine making this change yourself until it’s merged/fixed.

I did the change removing the ^, but the card refuses to work… @kalkih

Sorry, I don’t use the card. Either way looks like there is a fix. Thanks @kalkih

1 Like

Change back to. type: module and clear the browser cache.

Yes, already did… i always had module as type

The manual change worked for me. You may need to change the version number on the lovelace link so it knows to update itself.

No way for me… it always give me the same error.
I tried all the fix options…
EDIT: In the mobile chrome browser the fix was working and i can see again the data, but in the MAC Os Chrome Browser still having same errors

Regularry got

[frontend.js.latest.201903051] TypeError: color is undefined


ERROR (MainThread) [frontend.js.latest.201903210] Uncaught TypeError: Cannot read property 'substr' of undefined

in log
Any ideas how to fix?