CLI not starting on new install

Your HA is installed. Unfortunately, you masked the ip. Just type in http://your masked ip:8123 on another computer, and you should see the on-boarding screen.

Thanks a lot! it works

thank you so much for this as it solves the first issue of DNS and connection then i re-flashed my ssd by rpi imager for Home assistant and that git the HA start normally.

As tried install HA 9.4 & 9.3 with no luck. Imaging it straight into Raspberry 2.
Just described message seen and nothing installed into docker.

The reason was this :

  • wrong local time as the image has NTP -setting in /etc/systemd/timesyncd.conf,
    which wasn’t responding, and local time was somewhere in year 2022.
    This caused docker image not to load.

Changing own NTP -server puts everything to continue.

1 Like

seemed a very simple fix here - Plug in a wired network connection as the setup hadn’t found my wifi dongle

I am having the hardest time installing this operating system, everytime I change the DNS and save! I get the same stupid error code when I reboot… Why is it not saving and why is this so hard :frowning:

This worked for me: Stuck waiting for home assistant cli to be ready · Issue #2272 · home-assistant/operating-system · GitHub

Finally, to solve the problem of the screen being stuck on ‘waiting for the Home Assistant CLI to be ready’, I had to make sure all partitions on the drive were removed. This was necessary because Balena Etcher doesn’t completely wipe the disk. Then, I connected the target disk to an external reader and used Balena Etcher to write the latest Home Assistant OS onto the disk. This solution worked like a charm. I hope this helps

I had the same on my QNAP, installed a fresh HAOS in a VM (Virtualization Station)
Turns out that the DHCP server on my QNAP disapeared after creating a virtual switch (done by the Virtualization Station app.
So HA did not get an IP address. After seting up the DHCP server and entering ‘login’, it worked.

Later on I entered a fixed IP via the HA GUI

I think I helped someone to apply this “workaround” under his x86 VM with Proxmox which created by tteck helper script.

After the “incident”, I tried to see if there any report on tteck page as well and I found one. Home assistant VM on proxmox not starting · tteck/Proxmox · Discussion #3356 · GitHub

For quick summary, under my testing on different PVE nodes

  1. Some VMs work without any problem
  2. For VM in trouble (stuck at emergency console), “login” did not help
  3. “systemctl status docker” shown problem related to external DNS issue, that’s why HA can not start as expected. However /etc/resolv.conf, ping and nslookup result show they are good
  4. workaround applied (assign dns setting via nmcli) and issue resolved.

However want to raise one extra point - for HAOS VM which are working fine

  • nmcli shown ipv4.dns is blink too. :slight_smile:
  • that means some setup are fine even without that setting.

Seems issue is between HA docker and host (VM) on some setup, but I am not sure it is host related nor anything.

Just my 2 cent under x86 with PVE at 2024, using haos12.4 qcow image

RPi4 Imaged HA 12 using RPi Imager 1.8.5. Failed to start CLI. Changed out uSD card. Tried again. Same results. Moved to RPi 400. No change. Pulled out brand new RPi5 and used appropriate image. Same issue. 3 Months the RPi4 was running when I turned it off. It was shelved for that time.

Did something change in the way network is handled? I do not get a successful start even using wired ethernet. I am going to see if I can roll back the Imager and/or HA version to see if I get a good start. First I will try the current RPi O/S to test the Imager. I will post more as I have result from different testing.

Cheers.

1 Like

Update: RPi5 O/S w/ Desktop loaded. I am going to say that a bad Imager program is highly unlikely. Next step is to find my old HA image from a while ago.

Maybe a DNS fault.

1 Like

Update: Used images for v11.5. One for My RPi4 and one for my RPi5. They both booted into the HA Cmd Line which I didn’t get with v12.4 nor 12.3. I still have to sort my network config as they are not obtaining an IP addr neither over hardwire or wireless. DNS could be still be a factor but at least now I can dig further with the CLI.

Thanks for the suggestion @nickrout (love the handle). BOWMAP is an acronym for Balding Over Weight Middle Aged Programmer.

DNS… well that wasn’t the root problem. After manually configuring the wlan from the cli it obtained an IP and is now getting back to normal. Neither the NIC port nor the wireless was enabled. So I am letting it do it’s thing that a new install will do. I will probably keep it on my Pi4 as that is mounted to a 7 inch screen. I know there ain’t much to watch so the screen isn’t need except during startup. But that same rig also has a 512GB Sata SSD on it. Connects via USB though.

Thanks again for chiming in.

Wlan does complicate things. It isn’t set up by default.

Friends don’t let friends run servers on wifi.

2 Likes