Cloud does not initialize due to incompatible packages

Upgraded to 0.74.0 which ran fine. Then activated cloud in the configuration to enable Alexa.
This fails with the message that the configuration is wrong.

The message is misleading. After starting in Debug mode, it was having problems with warrant==0.6.1 which could not be installed due to the fact that requests==2.19.1 is not compatible with warrant=0.6.1

Let me know if i can help with further testing / diagnosis.

You can ignore that - it’s not related to your problem.

The information about the configuration would help us work out what the problem really is, as would a copy of your cloud: section.


The cloud section just contains “cloud:” and nothing else. It was commented out before and i wanted to configure it now for alexa. So very initial for the cloud section.
Wanted to upload my configuration.yaml but it seems it is not allowed for new users ;-(

Extract from configurations.yaml

    # Cloud

Messages in log

2018-07-22 20:50:51 ERROR (SyncWorker_9) [homeassistant.util.package] Unable to install package warrant==0.6.1: pyowm 2.8.0 has requirement requests<2.19,>=2.18.2, but you'll have requests 2.19.1 which is incompatible.
Command "C:\Users\edwen\AppData\Local\Programs\Python\Python36\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\edwen\\AppData\\Local\\Temp\\pip-install-n60nrbrc\\pycryptodome\\';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\edwen\AppData\Local\Temp\pip-record-uzhbflbl\install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in C:\Users\edwen\AppData\Local\Temp\pip-install-n60nrbrc\pycryptodome\
2018-07-22 20:50:51 ERROR (MainThread) [homeassistant.requirements] Not initializing cloud because could not install requirement warrant==0.6.1
2018-07-22 20:50:51 ERROR (MainThread) [homeassistant.setup] Setup failed for cloud: Could not install all requirements.
2018-07-22 20:50:51 INFO (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=persistent_notification, service=create, service_data=title=Invalid config, message=The following components and platforms could not be set up:

     - [cloud](

    Please check your config., notification_id=invalid_config, service_call_id=2470947478104-2>
    2018-07-22 20:50:51 INFO (MainThread) [homeassistant.core] Bus:Handling <Event state_changed[L]: entity_id=persistent_notification.invalid_config, old_state=None, new_state=<state persistent_notification.invalid_config=notifying; title=Invalid config, message=The following components and platforms could not be set up:

     - [cloud](

    Please check your config. @ 2018-07-22T20:50:51.560598+02:00>>

Please, please, please use markup as explained in the large blue box at the top of every page on this site.

The blue text seems to have disappeared (in my browser anyway.)

Yes, did not find it either :slight_smile:

Adjusted the message though as it really did not look good.

Anyway, back on topic, the requirement of requests==2.19.1 has had implications for other components too.

pyowm springs to mind.

If it’s causing problems, please raise an issue.

I’m not seeing it on 0.74, with Python 3.6.3, but there may be something specific about your setup that’s causing the issues (that is, it’s Windows specific).

I was running py 3.6.5. Did an upgrade to 3.6.6 but it did not make a difference.

Found this issue

No resolution was posted.

I’ve figured out what the problem was. One needs a C++ compiler for the crypto package.
I’ve used VS 2017 with only the C++ components. Started the command prompts for x64 and installed warrant.

If you get issues that something is missing (like malloc.h), then you did not install enough of VS.

Now Coud startsup and can be configured.

Hi, I’m having the same issue, any chance you recall which VS 2017 packages you needed to install?

I’ve installed everything that had to do with C++ (which took a while).
Then it was possible to install the warrant package.
subsequently i deinstalled vs as it was taking up a lot of space.