Is this wifi switch supported? ANKUOO / MS6126


#46

@psyciknz note the MS6126 device is not a Broadlink device so I don’t think it’ll work (the MS6124 and MS6122 are broadlink devices).

I just bought a MS6126 from Jaycar so looking forward to seeing how these will work via UDP sniffing in the coming days.


#47

Did you manage to get anywhere with that power monitoring version? I’m just trolling to decide if I want one and to hack around, or take the road easier travelled and just extend my zwave network.

The price difference is considerable though. But there is something to be said for convenience - zwave works, no need to block outgoing connections, no need for bridging software etc.


#48

More than willing to help; " http://blog.giuliomontagner.com/post/155085663708/trying-to-hack-ankuoo-rec-switch-and-make-it " has everything you need. if promiscuous mode in wireshark doesn’t work… you might need to setup a “man in the middle” method of capture.


#49

@MarkPartlett thanks for that. I’ve figured that I’m able to issue an ON and OFF command from home assistant using “google assistant webserver” hassio addon. This saves the need for me to wireshark UDP packets.

Did you manage to figure a way to capture the switch’s status? I can see the Google Assistant can ask “is the switch on” and it’ll respond correctly however how do I get status information into home assistant?


#50

I’m a bit confused, what is the message broadcasted with the webserver addon that interacts with a switch on the network?
I can’t use the instructions in the link by MarkPartlett due to using OSX.


#51

@CampbellFabrications refer here Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)


#52

@MarkPartlett,
Would you be so kind as to elaborate on how you used switch.command_line to control your Ankuoo REC switches? I have some of these and have been banging my head against the wall trying to figure out how to integrate them with HA so any help would be greatly appreciated.

Thank you!


#53

just picked up a ms6124 at jaycar and have been trying to get this setup through hassio as a sp2 broadlink device (using the custom component here: Broadlink SP3S Power consumption sensor) but have had no luck.

I’ve also tried the broadlink to mqtt python program here: https://github.com/eschava/broadlink-mqtt. It detects the device (as Unknown, though), and connects to it, but no power consumption is listed (only as None).

Anybody have any thoughts if these devices are capable of power metering through home assistant?


#54

Hi everyone.
This is the first time I have used this chat. I have 8 of these Ankuoo MS6126. About 12 months ago I purchased 5 and installed very easily. To add the 5 Wi-Fi switches to the REC app was too easy. I used the 2.4G Wi-Fi with security mode WPA2 PSK. About 12 months later I purchased another 3. Before I install these 3, I set them up on my test bench wired up and tried to connect / add the 3 new Wi-Fi switches to the REC app. Everything I tried failed to add the device to the App. Nothing has changed with my Wi-Fi hardware and software and is all the same as what was there when I connected the first 5 a year prior. The 3 new Wi-Fi switches make all the correct noises when trying to add to the REC app but then says “device not found”

After hrs of playing with modem settings and trying to get these to connect I changed my Wi-Fi security to NONE and the 3 Wi-Fi switches added with no issues. I can’t run my Wi-Fi without security. I changed the Wi-Fi security to WPA2 PSK and still have the original connection issues. We checked the password many time and it is correct. I even shorten the password to 8 characters still no good. I booted all Wi-Fi devices off my network to make sure there wasn’t to many devices on my network and still no change. I even turned my Guest Wi-Fi on, connected my phone and tried to connect the Wi-Fi switches with and without security but still no joy.

Can anyone help?? Has anyone else had these issues?


#55

do you have VLAN?
do you have 2.5mhz and 5mhz wifi using same ssid?
do you have special character in password? try 11111111

You switches are purchased many month apart and may be same model but different version with different firmware. you may better contact APP maker and report this issue and see if they have recommended action.


#56

Hi
Not sure about VLAN.
Yes have 2.4 and 5 on the same SSID. I did make sure that the phone was connected to 2.4. Yes the password has got special characters so I also changed the SSID to 123456789. Still didn’t like it.
I even connected to the Wi-Fi switch with no security updated firmware on Wi-Fi switches and changed back to the WPA2 PSK but still made no change.

Do you know the APP maker contact details?


#57

Try make unique 2.4 ssid and see if that make difference
If possible, can you compare software versions for other switches?

contact Ankuoo support. Should be on their website


#58

My broadlink didn’t work because my 2.4 and 5.0 wifi were the same ssd. I had to disable the 5.0 radio then reboot my phone to get it to connect after which i was able to re-enable it.


#59

Ok thanks for the help. I’ll give that a go. :+1:


#60

@kiwijunglist is also right
Temporarily disable 5mhz while connecting switch may be enough


#61

Hey. I have tried this. I turned off the 5GHz and tried to connect. Still didn’t work. Did the password change on the 2.4 too.


#62

Hey Everyone.
I have tried all the suggestions everyone has recommended and still not adding the Wi-Fi switches to the REC app.

I sent an email to REC app support over a week ago and still no reply. Sent many emails to JayCar and have had many recommendations. They have now told me they will send me 3 new ones and send the old suspected faulty ones back.

Once I have received and installed I’ll update everyone as someone may get this same issues in future.


#63

Hi Everyone

Jaycar sent me 3 new Ankuoo MS6126 Wi-Fi switches. After setting these 3 new MS6126 switches I found the that 2 of the 3 original MS6126 are faulty. These 3 new ones were not as easy to add to the REC app then the 5 previous ones I added to the REC app 12 months previous. I found that my Samsung Galaxy S7 would not add the MS6126 to the REC app. REC app kept telling me that “device not found” I had to use an Apple iPad 3. Once all the MS6126 were added to my REC app account I could work them from any device.
To add the MS6126 to the REC app I had to:

  1. Change the 5Ghz password to make it different to the 2.4Ghz password and also disable the 5Ghz Wi-Fi channel on my modem.
  2. Remove all passwords and have “NONE” security on the 2.4Ghz Wi-Fi.
  3. Add all 9 Wi-Fi MS6126 to the REC app while there was no security setup on the 2.4Ghz channel.
  4. Once all added I had to update the firmware on the 3 new MS6126.
  5. Once each firmware was updated the REC app told me the firmware upgrade failed. Restart the REC app and all worked and updated fine.

Not sure if anyone else has had the Samaung Galaxy S7 issue like I experienced? Could it be that the S7 is to advanced for the MS6126 or the REC app. Maybe the REC app needs updates to keep up with the technology?

Anyways after all of that I got them all installed and found 2 of the MS6126 faulty and would not add to the REC app.

Also what I noticed with the faulty MS6126 is when the manual override light switch was turned on the MS6126 would turn the light on for about 2 minutes and then turn the lights off then for 2 seconds then light back on for another 2 minutes and so on.


#64

I’ve re-setup my 21 devices about 10 times now without issue. Did you turn off ‘Mobile Data’ while you setup the devices? Maybe something to try.


#65

To use the switch.command_line I had to setup batch files for each actions(on/off) for each of the switches. The batch file contained the full command eg. ‘echo –n –e “\x01\x40\xac\xcf\x23\x8b\xfa\xaf\xfa\xfa\xaf\xfa\xaf\xfa\xaf\xfa\xaf\xfa\xaf\xfa\xaf\xfa\xaf\xfa\xaf” |nc –w1 –u 10.10.0.1 18530