Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f203dae6708>

#405

You need to call it like this:

http://ip:port/broadcast_message?message=blah

Also, no quotes or anything around the message.


#406

Ah, thank you!!! Is the command working? I got the broadcast to work with that, but the command will not do anything, just says ok but no action


#407

MThe command endpoint is like this:

http://ip:port/command?message=blah

The command endpoint is to control smart home things that currently are controllable through google, but do not have a way to integrate into home assistant directly.

For example, if you had a bathroom light that was added to your google home, but that brand is not able to added to home assistant, then the command could be “turn off the bathroom light”


#408

Thank you sir, working now.


#409

doesnt seem to work for playing things on youtube tv. I have a nvidia shield i can say ‘hey google turn on fox on youtube tv on living room tv’ and it goes right to it. the command through the add on shows me ‘i dont know how to help with that’. I looked through my activity and worded exactly the same as I spoke it. I was going to use it for some quick buttons to goto dif channels. and some automations…


#410

Looking through the thread it looks like google have disabled being able to cast things through this unfortunately


#411

Thanks so much for your work on this!!! Getting this up and running was a major break through for me, and has enabled me to finally control everything in my house without having to re flash it all.

Thank you!!


#412

I’m having some trouble creating the notify component for /command. I’m able to use the command without issue from a web gui, but I would like to use a hard coded /command notify that I can use in an automation or script. I see in posts above that people seem to be using input text to form a command, but I am wanting to send the same command each time, not type input for the command. Perhaps I’m not understanding what the input text components are as mentioned above. If someone could provide a little guidance, that would be great. (I’m pretty new to Home Assistant)

The entry in my notify.yaml looks like this:
- name: Turn Off Bathroom Plug
platform: rest
resource: http://192.168.200.2:5000/command?message=turn off bathroom plug

When I call the service I get the following error:
Invalid service data for notify.turn_off_bathroom_plug: required key not provided @ data['message']. Got None


#413

that error comes up if you have incorrect indentation. you need to use the code button when posting on here but it looks like your code is missing the required two spaces. when posting code, select the code and use the </> button


#414

I assure you the code in the yaml file has the two space indention, using the code button here actually made it look worse. I think it’s because I copied it from a Remote Desktop session and didn’t bring the proper formatting with it.

Anyway, let’s say I have the indention, is the rest of the notify entry correct for this add-on? I feel like it’s not, and I should have a ‘message’ parameter, but the REST notify component doesn’t list message as an available parameter.


#415

Notify components are not designed to be static, so in the service call you have to include a message. You should be able to include it with any data and it should work.


#416

Of course, that’s it! Duh! I had it in my mind that this was somehow supposed to be different. I set it up like my iOS notifications, works fine. Thank you!!


#417

Beautiful add-on! Thanks for sharing it
I noticed that the maximum of characters that can be sent (including spaces) is 180 ~ 192 maximum. Is this my problem, or a limitation of google APIs?


#418

hi @AndBobsYourUnclem thanks for the add-on. I have some problems with the google_assistant.json file and i hope you can guide me:

I 'm running Hassio on docker on ubuntu 18.04, with the following add-ons samba, ssh, duck-dns. I installed the component Google Assistant (NO the Cloud setup) the manual setup and now i can see the HA devices, automations, etc… on my phone and control them with the GA.
I’m trying now to install the google assistant webserver add-on. I added the repository to the add-on store and installed.

My problem is that I don’t know where is the json file or how to genereate one. this link is outdated https://www.home-assistant.io/addons/google_assistant/ so i’m not sure if i can follow this instructions and also because I first installed the GA component I already have an project_id and a App_key created for the component to run.

thanks in advance


#419

Google limitation I think, I’ve noticed it myself around 200 characters.


#420

Hi,
Can I use this to get my google mini to start playing a Spotify playlist.
The official Spotify component keeps loosing my sources and I would really like some way to resolve this.


#421

Thank you.
mmm I will have to study a way to divide the information into two or more parts. A counter of characters or similar things.


#422

No, not possible at this time.


#423

I thought of doing something similar myself, but then realised I would get the BING before the broadcast twice and didn’t fancy it.


#424

Just installed the addon with the json, great work @AndBobsYourUncle
Broadcast commands work fine, but I’d like to be able to get “turn off tv” working (which works fine from the google assistant phone app or with the home mini)

However, when trying with the browser I get a “message”: “Internal Server Error” response instead of “status”: “OK”

EDIT: SOLVED AFTER A HASSIO RESTART!