Community Hass.io Add-on: Home Assistant Control Panel

hassio-addon
hassio-repository
Tags: #<Tag:0x00007f1ba521fa58> #<Tag:0x00007f1ba521f3f0>

#1

This add-on is provided by the Community Hass.io Add-ons project.

GitHub Release GitLab CI Project Stage Project Maintenance

Supports armhf Architecture Supports aarch64 Architecture Supports amd64 Architecture Supports i386 Architecture

:warning: Deprecation warning


This add-on is in a deprecated state!

This add-on is no longer supported or maintained.

You can still install this control panel manually or use the hosted version offered by the author. For more information see:

https://reformedreality.com/home-assistant-control-panel

About


Simple to use control panel for the ultimate home automation setup.

Using a phone or tablet device, you can hook into your Home Assistant server and get access to a simple to use Control Panel. Mount the device on your wall to create the ultimate home automation accessory and unlock the true potential of your Smart devices.

Repository on GitHub


Looking for more add-ons?


The primary goal of our add-ons project is to provide you (as an Hassio / Home Assistant user) with additional, high quality, add-ons that allow you to take your automated home to the next level.

Check out some of our other add-ons in our Community Hass.io Add-ons project.


Home Assistant Control Panel does not open
#2

About the author of this add-on

Hi there!

I am Franck Nijhof, and I have 30 years of programming experience, in many languages. I am using this experience to work on the Home Assistant project by giving back my knowledge and time to the open source community.

The add-on you are currently looking at right now was developed/packaged by me. It is not the only add-on I have created; there are many many more :wink:

However, I have a problem… I am an addict. A :coffee: addict that is. Lucky for you, I turn that C8H10N4O2 (caffeine molecule) into code (and add-ons)!

If you want to show your appreciation, consider buying me a cup of high octane wakey juice by clicking on the “By me a coffee” image below! :heart:

Buy me a coffee

Or, become a Patron and support my work!

Support my work on Patreon

Enjoy your add-on, while I enjoy the brain juice. :coffee:

Thanks for all the :two_hearts:

…/Frenck

Join our Discord server Follow me on Twitter Flollow me on Instragram Follow me on GitHub Follow me on YouTube Follow me on Twitch patreon-icon

P.S.: In case you want to ask me a question: AMA (Ask Me Anything). Most of the time I am online at the Discord chat. (I go by @Frenck in there as well).


#3

Nice. Is the HACP a new UI or was it already existing and did you just create an add on for it?


#4

@metbril, all add-ons essentially wrap existing software, so does this one.

You can find the Home Assistant Control Panel here:

http://reformedreality.com/home-assistant-control-panel


#7

Apparently I’ve done something wrong I guess. After adding the addon and the lines to http: cors_allowed_origins:
- http://addres.to.your.hass.io:7080

HASS wouldn’t load via my duckdns.org url. After uninstalling the addon and deleting the http: lines using the direct IP of hass I’m now getting a ‘403: Forbidden’ error no matter what when I use the duckdns.org url.

Any ideas? Thanks.


#8

@ikonixx Try checking your port forwarding rules.


#9

Thanks. Checked and good. I finally ended up rolling back and then updating again. no clue what the deal was but all is good now.


#10

Any ideas on why I would be seeing this error?

Unable to connect to Home Assistant. Please check the Server URL is accessible from this device or change the URL below:

Tried my local ip as welll as my duckdns url (in both the config file & the browser)


#11

hmm, Unfortunately I’m getting the Same thing. I’m running my Home assistant using SSL and an certificate from lets encrypt. That side of it is working for me, but this addon doesn’t seem to want to connect.

Matthew


#12

Further to this, I get a warning on my Homeassistant Gui stating there was a Failed Login attempt.

“Login attempt or request with invalid authentication from 192.168.0.80”

The IP is my web client, not my hassio install nor the Home assistant Control Panel Server.

Matthew


#13

If I clear cookies / cache and reload I get the auto detect or manual setup screen if I choose auto detect it finds my server but when I click next to check api access it throws the unable to connect error.


#14

Got it to work!

Under here:

http:
api_password: YOUR_PASSWORD
cors_allowed_origins:
- http://addres.to.your.hass.io:7080
Blockquote

I added an “S” to “HTTP://” then restarted and cleared cookies.

Update: This only works on my desktop? Trying to connect on my ipad results in the unable to connect error…


#15

Hey what worked for me is when it ask to manually setup or auto detect the server you actually have to use the hass ip and port:8123 and password not the addons port 7080 which it auto detects.


#16

Im stuck at the loading screen. It just wont connect.
Same IP adress ass HA


#17

I also can’t connect, I receive a popup

Unable to connect to Home Assistant. Please check the Server URL is accessible from this device or change the URL below:
http://192.168.1.12:7080

the URL is fine


#18

The server URL is not fine… What port is your Home Assistant server running on? :wink:

The detection is pretty dumb… it just picks the current URL, which is a wrong assumption 99% of the time (when using this addon).


#19

Putting 8123 doesn’t change


#20

That indicated you didn’t or wrongly setup the CORS configuration. Please be sure to check the documentation.


#21

Maybe the documentation is not clear
That’s my configuration

http:
  api_password: xxxxx
  cors_allowed_origins:
    - http://192.168.1.12:7080

#22

@frenck Should this say “Home Assistant Control Panel” instead of “Homebridge”?