Community Hass.io Add-on: IDE, based on Cloud9

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd08373a8d8> #<Tag:0x00007fd083f1bdb8>

#83

legend! I will buy you a coffee or 3 :smile:


#84

This works really nicely. Thanks a lot. I would have the following ideas for future improvements:

  • Include a possibility (menu item) to “check config” from the IDE
  • Include a possibility (menu item) to “restart server” from the IDE

This would mean you could do all the changes from the IDE without the need to change UIs.


#85

That is actually already in!

I’ve tested the feature in my live broadcast yesterday. Please see my last broadcast on YouTube for a demonstration (1:40:00)


#86

I’m having an issue with 0.3. The interface looks good, but for some reason when I open a file the entire file is rendered on one row of overlapping text. Not sure if there is a setting I need to adjust or something? Stop/Start the add-on didn’t resolve (I’ll try a reboot of my Pi).

Any other suggestions?


#87

Flush your browser cache?


#88

Awesome, thanks.


#89

I really like the look of this but in light of recent events I have a naïve question.

Does this add-on inherently have more, less or the same security as using the Samba add-on?

I don’t mean in the way @frenck has written it, I am in no way questioning anyone’s skills, knowledge or the implementation of the add-on, I simply mean are there any inherent differences security wise with the methodology employed?

Yes, I am getting a little paranoid…


#90

There are no such things as more or less the same security. Any system or program can be compromised when a vulnerability has been found. So yeah… there is no answer to that question.

Use SSL and use the password protection offered by this add-on, if you decide to make it available outside of your network (which you generally should avoid as much as possible for anything! so that is not perse related to this addon). The password protection offered by this add-on is provided by NGinx, which is a well-known web server that handles it. Since this project is so major, the chances for having it issues is far less. Nevertheless, new issues could be found.

As for my add-ons, they are all monitored actively by my friends at anchore.io. They know exactly what software is used in the add-on containers and monitor security feeds. As soon as a vulnerability is discovered, they will notify me immediately.


#91

@frenck Thankyou for such a well put reply to what I suppose could have been taken as a provocative question (which it certainly wasn’t meant to be).


#92

When I hit the install button in the app store, the button turns red then fades back to normal, and it doesn’t appear to install. How do I troubleshoot this?


#93

Check the Hass.io Supervisor logs (Hass.io panel -> System tab -> Refresh the logs).
It should show a message why…


#94

:tada: Release v0.4.0

This release is packed!
It upgrades the Cloud9 IDE and has tons of improvements to the terminal.

Full Changelog

Added

  • Adds ZSH autosuggestions
  • Adds ZSH Syntax Highlighting
  • Set ZSH as the default shell in the IDE terminals

Changed

  • Upgrades base image to v2.0.1
  • Upgrades Cloud9 Core to d8917f3
  • Updates MOTD to match the core SSH add-on
  • Upgrades build-base to 0.5-r1
  • Upgrades g++ to 6.4.0-r8
  • Upgrades libxml2 to 2.9.8-r0
  • Upgrades make to 4.2.1-r2
  • Upgrades openssl-dev to 1.0.2o-r1
  • Upgrades yarn to 1.7.0-r0
  • Upgrades bind-tools to 9.12.1_p2-r0
  • Upgrade mariadb-client to 10.2.15-r0
  • Upgrades mosquitto-clients to 1.4.15-r3
  • Upgrades ncurses to 6.1-r0
  • Upgrades git to 2.18.0-r0
  • Upgrades libxml2 to 2.9.8-r0
  • Upgrades net-tools to 1.60_git20140218-r2
  • Upgrades nginx to 1.14.0-r0
  • Upgrades nmap to 7.70-r1
  • Upgrades nodejs to 9.11.1-r2
  • Upgrades openssh-client to 7.7_p1-r2
  • Upgrades openssl to 1.0.2o-r1
  • Upgrades py2-pip to 10.0.1-r0
  • Upgrades Python to 2.7.15-r0
  • Upgrades sqlite to 3.24.0-r0
  • Upgrades sudo to 1.8.23-r2
  • Upgrades tmux to 2.7-r0
  • Upgrades zip to 3.0-r5
  • Upgrades zsh to 5.5.1-r0

#95

I tried installing this for the first time yesterday and again this morning. I am receiving the following error;

18-07-16 15:43:25 INFO (SyncWorker_1) [hassio.docker.interface] Pull image hassioaddons/ide-armhf tag 0.4.0.
18-07-16 15:47:48 ERROR (SyncWorker_1) [hassio.docker.interface] Can’t install hassioaddons/ide-armhf:0.4.0 -> 404 Client Error: Not Found (“no such image: hassioaddons/ide-armhf:0.4.0: No such image: hassioaddons/ide-armhf:0.4.0”).

This is hass.io on pi3. Thank you.


#96

I was able to get this installed by restoring a full snapshot on a new hassio 1.7 image. Funny thing is after restoring the snapshot it said 0.73.2 was available and when I tried upgrading the logs showed the same 404 no such image for the update. I then tried and installed the IDE add-on. After that I could upgrade to 0.73.2. Weird.

Doing a hassio ne info also still shows the 404 not found error. I guess this is a known bug and off topic here.


#97

404 by Docker can be either one of these two things:

  1. The Docker image with the specified tag does not exists (d0h).
  2. You don’t have enough diskspace (yeah really… it is documented by Docker as well…)

So since the image exists, check here:

https://hub.docker.com/r/hassioaddons/ide-armhf/tags/

I guess you’ll have an issue at point 2.


#98

@frenck I’ve managed to get the DuckDNS add-on working so I can access https://mysite.duckdns.org:8123 working, but how can I get https://mysite.duckdns.org:8321 working with the IDE editor?

{
  "log_level": "info",
  "username": "uname",
  "password": "pass",
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "packages": [],
  "init_commands": []
}

#99

:tada: Release v0.5.0

Full Changelog

This release adds password checks against the HaveIBeenPwned password database and now supports the use of your Home Assistant secrets file!

So you can now use !secret ide_password as your password and the add-on will fetch the actual password from your secrets file.

Added

  • Checks used password against HaveIBeenPwned
  • Enforces the use of authentication

Fixed

  • Fixes YAML error in GitLab CI build file

Changed

  • Upgrades openssl to 1.0.2o-r2
  • Enables SSL by default
  • Upgrades zip to 3.0-r6
  • Upgrades Cloud9 Core to e9490da
  • Upgrades hadolint to latest
  • Upgrades base image to v2.1.1
  • Sets default Shell
  • Updates README and links
  • Pins yamllint to 1.11.1

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck


#100

:tada: Release v0.5.1

Full Changelog

Changed

  • Upgrades base image to v2.1.2
  • Upgrades Python to 2.7.15-r1
  • Corrects typo in error message

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck


#102

Is there any possibility to run this addon, when my Hass.io on Rpi3 is running on different port than 8321? If yes, what should I change to make it work?


#103

You can set a custom port for this add-on in it’'s configuration.