Community Hass.io Add-on: IDE, based on Cloud9

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd07a3771a0> #<Tag:0x00007fd07a377010>

#104

But how? There is nothing about port in docs


#105

When you istall the add-on you will see this:
image
Under the “Config” part, this is where you set it :slight_smile:


#106

Thank you. When I tried to change it into my port (2222), then Cloud9 IDE addon won`t start anymore :frowning:


#107

That port may already be in use by something else.
Why do you need to change this port?


#108

This should not be the same port as your hass.io instance is running on, then two things will try to happen at once…


#109

Umm, this could be a cause. Thank you, I will try different port after work at home.


#110

I use port 2222 for my Home assistance Web UI.
Yesterday I finished my SSL DuckDNS setup, setup port forwarding for 2222 and everything seems to be working fine.
Now I needed to edit something in my configuration.yaml and found out, that Configurator and Cloud9 IDE cannot be opened from my remote location. So I changed this port from 8321 to 2222 in configs of both above mentioned addons, but it did not help.

So I guess, that based on reply from @teachingbirds I should setup different port for Cloud9 and make port forwarding to that port on my router, right?


#111

Yes, that is correct. You can never have several applications use the same port on the same device. How would it know which one to go to?


#112

It works now, thank you :slight_smile:


#113

Having an issue on my NUC deployment of hassio. ssl cert is in /config/ssl. When i point to the cert, i get an error saying it can’t find the cert


#114

From the manual:

https://github.com/hassio-addons/addon-ide#option-certfile

The file MUST be stored in /ssl/ , which is default for Hass.io


#115

Thanks! I think I had a bit of a reading comprehension problem when reading the docs :slight_smile:


#116

I just installed this add on. I can access it locally “hassio_ip_address:8321” and everything works fine. I am not able to access it through my Duck DNS address. The following does not work for me: “https://my_domain.duckdns.org:8321”. I get a ‘took too long to respond’ error. I have already done the port forwarding in my router for port 8321 on the hassio_ip_address.


#117

Anyone had any luck running this though an SSL Apache Reverse Proxy (Apache VirtualHost Proxy with a Subdirectory)?
I get the login dialog from the IDE, but then it switches to it’s programmed absolute URLs, which breaks the proxying. I.E. Absolute URLs are being used rather than relative ones. :frowning:

What happens, login dialog then blank webpage:
https:/mywebsite/hasside --> https:/mywebsite/ide.html

What should happen:
https:/mywebsite/hasside --> https:/mywebsite/hasside/ide.html

Most applications i’m running allow you to set a webprefix (I.E. “/hasside”).

Any ideas?


#118

Is there a trick to accessing the IDE when you aren’t on your home network?


#119

No special trick… replace “IDE” with Home Assistant in your question, same story and answer.

Multiple options: port forwarding, tor, VPN, SSH port forwarding, online proxy service (e.g. ngrok)


#120

I am able to access home assistant outside of my local network without any issues. I am not able to access IDE when outside of my local network. I am not sure how to debug this. Any suggestions?


#121

Note that by default, IDE uses a different port (8321) so make sure your router is set up for forwarding from that port to your host.


#122

Finally got it working. I had to set up port forwarding on 2 routers, the one from the cable company and google wifi. I forgot about that. Had to do the same thing with HassIO.


#123

:tada: Release v0.6.0

Full Changelog

Changed

  • Upgrades bind-tools to 9.12.2_p1-r0
  • Upgrades ncurses to 6.1_p20180818-r1
  • Upgrades nginx to 1.14.0-r1
  • Upgrades openssh-client to 7.7_p1-r3
  • Upgrades Hassio CLI to 1.4.0
  • Upgrades base image to v2.3.0
  • Adds Hassio API security role
  • Upgrades g++ to 6.4.0-r9
  • Upgrades OpenSSL to 1.0.2p-r0

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck