Home Assistant Community

Community Hass.io Add-on: IDE, based on Cloud9

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fcf50eb41b0> #<Tag:0x00007fcf50eb4200>
#165

please let me ask again:

i use 2 HA instances both of which id like to use this add-on on. they are both on mydomain.duckdns.org and I can reach these with that url using a specific port setting, I forwarded in my router.

As such I use the default settings for IDE (port 8321) for one instance and try to use a changed port 8322 for the second instance. I can see the port forwarded being in effect by using https://ip_addres:8322 which brings me to the IDE interface. login in with my HA credentials et voila.

I can not however use the button Open Web-ui in the add-on, because that brings up the error it can not connect to the server, which is listed alright as being https://mydomain.duckdns.org:8322 and that is in fact used in the address field of the browser…

What can I try to solve this issue?

Update

just for reference… solved this. had the port forward’s listed with both the incoming and local port. deleted the local port, and now all is well. Both systems connect…

#166

3 months later. Still an issue.

#167

It will stay an issue as it seems, since Cloud9 is pretty dead (thanks Amazon). I’m looking into alternatives, but that process it slow (since a lot is going on at the online IDE apps at this moment).

#168

Agreed. I posted a few months ago about Eclipse Che, but it never did get any traction. It is probably the single most viable alternative that I have found so far, but I’ve yet to have much of a chance to really work with it.

#169

To be honest, I’ve been working and testing a lot with Theia (Che) a lot…and there are alternatives (code-server for example). Both are insanely close… but still have issues. So just so you known @Apocrathia, I don’t loose track :wink: )

#170

I did not even know that code-server existed. My vote would be there as vscode definitely has better support. They even had the same issue with zsh in vscode and it appears to have gotten fixed there. code-server runs great on their site (and the scroll wheel issue definitely isn’t there). I’ve written some basic vscode extensions before, and they’re not terribly hard. You could probably ship a code-server add-on relatively easily, and I can see if I can throw together a basic Home Assistant extension. (possibly even utilize hass-cli with it)

#171

“easy”… try ARM (which is our largest user-base giving the Raspberry Pi) :wink:

#172

Fair point. I’m the weirdo running hassio in a vSphere cluster. So, I don’t even have an ARM system to test it on. I would assume it would work, given that it’s all TypeScript, but I haven’t looked too deeply into the shenanigans that vscode/proton may be doing under the hood.

#173

Thanks for responding and letting us know that you haven’t forgotten about us. Hopefully, code-server can overthrow the Cloud9 IDE we have soon enough.

#174

I don’t forget, I keep all add-ons I have out updated as much as possible. As a matter of fact, I’m coding the IDE add-on as we speak.

#175

And you’re doing the lords work. I think we’re all still pretty dependent upon the Cloud9 IDE, and Amazon’s lack of support for it since its acquisition has been a little disappointing. Again, thanks for the update.

1 Like
#176

@frenck thanks for what looks to be an amazing add-on. I’m having the following error:
FATAL: The configured certfile is not found
and I’m not sure how to resolve it.

I’m running Ubuntu with a hassio docker. So I installed the addon from the add-on store, as I think is suspected.

The files in question fullchain.pem and privkey.pem exist in /usr/share/hassio/homeassistant which is where hassio apparently wants it to be (SSL works for the frontend).

Any ideas on how to help the add-on find the files? (I realize I could turn off SSL, but would rather not!)

Thanks

Update: I’ll note that the MQTT broker addon also has the .pem files listed and appears to be working.

#177

I have the same issue.
Found this solution https://github.com/c9/core/issues/436, but I don’t know how to implement it in HA :confused:
Any ideas?

#178

:tada: Release v1.0.0

Full Changelog

This release is a maintenance release, upgrading all parts of the add-on to the latest and greatest.
It is now running on Node 10.x, Alpine 3.9 and also optimized for ARMv7 based machines :racing_car:

:tada: The add-on version is now v1.0.0. After all this time, we think it is time to call it stable.

:hammer: Changes

  • :hammer: Makes log_level optional
  • :fire: Removes custom log format override
  • :arrow_up: Upgrades base image to v3.1.0
  • :sparkles: Adds ARMv7 support
  • :sparkles: Adds port descriptions
  • :arrow_up: Upgrades g++ to 8.3.0-r0
  • :arrow_up: Upgrades libxml2 to 2.9.9-r1
  • :arrow_up: Upgrades openssl to 1.1.1b-r1
  • :arrow_up: Upgrades yarn to 1.12.3-r0
  • :arrow_up: Upgrades bind-tools to 9.12.3_p4-r0
  • :arrow_up: Upgrades git to 2.20.1-r0
  • :arrow_up: Upgrades mariadb-client to 10.3.13-r0
  • :arrow_up: Upgrades mosquitto-clients to 1.5.6-r0
  • :arrow_up: Upgrades ncurses to 6.1_p20190105-r0
  • :arrow_up: Upgrades nmap to 7.70-r3
  • :arrow_up: Upgrades nodejs to 10.14.2-r0
  • :arrow_up: Upgrades openssh-client to 7.9_p1-r4
  • :arrow_up: Upgrades openssl to 1.1.1b-r1
  • :arrow_up: Upgrades pip to 18.1-r0
  • :arrow_up: Upgrades python to 2.7.15-r3
  • :arrow_up: Upgrades sqlite to 3.26.0-r3
  • :arrow_up: Upgrades sshfs to 3.5.1-r0
  • :arrow_up: Upgrades sudo to 1.8.25_p1-r2
  • :arrow_up: Upgrades tmux to 2.8-r0
  • :arrow_up: Upgrades wget to 1.20.3-r0
  • :arrow_up: Upgrades zip to 3.0-r7
  • :arrow_up: Upgrades zsh-autosuggestions to 0.5.0-r0
  • :arrow_up: Upgrades zsh to 5.6.2-r0
  • :arrow_up: Upgrades hassio-cli to v2.2.0
  • :ambulance: Patches C9 to be compatible with Node 10.x
  • :fire: Removes broken run definitions from workspace
  • :fire: Removes tmux plugin from ZSH
  • :hammer: Rewrite add-on onto Bashio
  • :hammer: Changes add-on URL
  • :fire: Removes default config options
  • :shirt: Fixes Markdownlint warnings
  • :tada: Moves project out of experimental stage

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck

1 Like
#179

I use Zero Tier add-on
Example my hass io ip Zero Tier http://27.64.222.122
After install Add-on IDE
I can open UI http://hassio.local:8321/ide.html succecessfull, and it work very well
But i can connect http://27.64.222.122:8312

This site can’t be reached

27.64.222.122 refused to connect.

Please help me

#180

Have you forwarded port 8312 from external to your HA server IP address?

#181

8123 not 8213 I think. No port forwarding required for ZeroTier

#182

I use 4G Wifi pocket and no option NAT . mobile provider use CGNAT and dont have real IP address
ip in wlan and in whatipsmyip is diffenrent .

#183

ok, I actually dont know about ZeroTier so was way off-course…!

#184

So you can’t use duckdns/letsencrypt if no real up address - and you don’t need to anyway. That’s the beauty of ZeroTier One. It makes it as if your hassio and your internet on phone for example are on the same network.

1 Like