Community Hass.io Add-on: IDE, based on Cloud9

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd07cba61a8> #<Tag:0x00007fd07cba5f78>

#145

sorry you were right I was entering the good password but I forgot that my home assistant user is not admin


#146

How do you copy/paste on iOS? on PC I just use keyboard, but when editing remotely from iOS, I have to type everything manually both on Chrome and Safari


#147

so I have 2 systems /HA setups, both via duckdns.org. Both have their own port forwarding in my router, so I can reach system 1 via mydomain.duckdns.org:8123 and system 2 via mydomain.duckdns.org:8124 (just for illustrative purposes here…)

Installed the IDE add-on on both systems. System 1 can open the IDE interface through the regular portforwarding settings :8321

39

of course I can’t use that same port forward to my second system, so tried :8421 for Host. Hoping mydomain.duckdns.org:8421 is forwarded to my local second systems port 8321.

This fails, and no matter what port I test it with, it never opens the IDE editor.

Isn’t this add-on able to use another port?


#148

Hi. Great addon! I tried to figure out how to do an indentation check inside IDE. It looks like that is possible on the screenshot. I’m talking about the tab on the right side of the terminal tabs. I suppose that’s what it is?

I tried to figure it out but had no luck.
Anyone know how to do this?


#149

Has there been any update on anybody figuring out how to disable this? It makes the terminal window pretty much useless.


#150

Great Addon! However whenever I try to run commands like Check Configuration and restart home assistant it just keeps hanging until I press stop.

In the logs I’m getting spammed with GET and PUT, POST commands that looks something like this

x.x.x.x - hass [26/Jan/2019:09:43:08 -0500] “POST /vfs/1/xxxxxxxxxxxxx/workspace///tab9?access_token=token HTTP/1.1” 200 0 “http://x.x.x.x:8321/ide.html” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36”


#151

:tada: Release v0.8.0

Full Changelog

Changed

  • Refactor of GitLab CI
  • Updates maintenance year to 2019
  • Removes Anchore.io links
  • Removes BountySource links
  • Upgrades add-on base image to 2.3.1
  • Upgrades hassio-cli to v2.0.1
  • Upgrades sqlite to 3.25.3-r0
  • Configure Renovate (#30)
  • Fixes spelling error in Dockerfile
  • Upgrades MariaDB client to 10.2.19-r1
  • Upgrades wget to 1.20.1-r0
  • Upgrades YAMLlint to 1.14.0

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck


#152

Version still shows as 0.7.2 here…


#153

Have you tried the refresh button in the add-on store?

From a production system:

image


#154

Yes I did refresh before. Just tried again now and it’s there. Thanks.


#155

EDIT: nm. I’m dumb. It apparently uses the HA username and password.

I installed this addon, and it’s asking for a username and password. I don’t know what that is. So I stopped the addon, set the username and pass in the config screen, hit save. But when I reload the configuration screen, the username and pass are gone. And the username and pass I set doesn’t work when I start the addon and try to login.

I know that the config is saving in some way because when I change a setting for the other options, it takes the change. It just drops the username and password.


#156

As anybody benn able to solve this issue: (I am on odroid C2 with latest hassos version 3 build 0)

Getting this message while starting the IDE :

 Cloud9 is up and running_
 PANIC: unprotected error in call to Lua API (bad light userdata pointer)_
 INFO: Starting the NGINX daemon_
 PANIC: unprotected error in call to Lua API (bad light userdata pointer)_
 INFO: Starting the NGINX daemon_

HA is running on a Pine64 with Debian 64 bits… looks to be releated to nginx

found this (having the exact same problem): https://github.com/kubernetes/ingress-nginx/issues/2802

Anyway to update nginx in the IDE docker ?


#157

Did you disable protection mode?

You don’t update anything in the docker container.

I’m running on Debian 64 bit and no issues.


#158

Hi David,

Thank you for your feedback.
Unprotection mode is set to off.
I did not change anything in the docker containers.


#159

I thought I saw in the changelog that this pluin contains hass cli. But when I type hass-cli in the command line screen on the bottom all I get is command no found. Is it supposed to just work, or am I missing something?


#160

It contains the hassio-cli, which you can invoke by typing “hassio”.


#161

Ah, I didn’t realize these were two different CLI applications. Or was something renamed?

Thanks!


#162

Related question: the shell you get in the IDE, is that the shell inside the hass.io container? The same one you’d get by using the SSH plugin? Or is it something else? Is it also the equivalent of running, from the host system, the command docker exec -it 4db...362 /bin/bash? Or is this a separate shell environment inside the IDE container?

Sorry if this is basic, I’m very new to docker, and still trying to figure out the different levels of shell access.


#163

No, nothing renamed. hassio-cli is for controlling Hassio, hass-cli for controlling Home Assistant.

You get into the same container as the IDE itself is running.


#164

Gotcha, thanks!