Component Toon not working?

Hi all,
First i like to say i’m a newbie. So dont shoot me.
Its i think a week that i trying to get my home assistant to work. Maybe i want to much at the same time but for now i’m trying to get my Toon thermostat to work.

I created the API keys and have them in my configuration.yaml
Then you go back to the toon integration and i have to put my username and password in there. Also i need to say Tenant: Eneco.
But for some reason i cant login. I got the msg: your account is invalid. But i know for 100% it is the right account (same as app account). What am i doing wrong? Not always but sometimes i got this error msg:
Unexpected error while authenticating
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/homeassistant/components/toon/”, line 90, in async_step_authenticate
KeyError: ‘tenant’

I really really like to get this working so i hope some one is willing to help me. I can give a donate for the effort.

Can you please post your configuration redacted of course?

What do you mean with this? Did you have to enter this somewhere? If so, it should be tenant: eneco, all lowercase, not Tenant: Eneco


mode: yaml


your configuration.

themes: !include_dir_merge_named themes

your configuration.

themes: !include themes.yaml

javascript_version: latest
#---------------einde frontend

Configure a default setup of Home Assistant (frontend, api, etc)


#install addons:

minutes: 60
- ping
- download
- upload

client_id: REDACTED BY MOD
client_secret: REDACTED BY MOD
scan_interval: 60

#einde addons!



Text to speech


  • platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

What i forget to mention is that i installed 6 other vm situations with other home Assistant. With docker without, in centos, debian, ubuntu all no go. I now use the vmdk converted to esxi vmware. (hassio) runs verry good.

And tenant: is eneco (you can choose the energy company.

You posted your secrets! :hushed: Change the secret immediately, I flagged the post to get it removed.

1 Like

Is it a drop down to choose the tenant or did you have to enter it manually?

I’ve redacted the information, but the OP should change/regenerate their client_id/client_secret info immediately.


Thanks for removing! I already told OP to change secrets immediately.

1 Like

ah oke thx Burningstone. I was away. :slight_smile:

Yes its a clickable text and i can then select 3 options. But i need the eneco option. I see on other forums that more people got this problem. For some reason we cant login.

That is what I got too.

Maybe a stupid question, but do you have an active subscription?

And what Home Assistant version are you running?

Btw. I suggest you create a new api with toon. Because the mod may have removed it from your post, but kept the history enabled… i can still view your codes, out of security purposes, start over please.

1 Like

Yes i have a active Toon subscription. I’m running:

arch x86_64
dev false
docker true
hassio true
os_name Linux
python_version 3.7.6
timezone Europe/Amsterdam
version 0.104.3
virtualenv false


mode storage
resources 18
views 8

I just dont get it where it goes wrong. Its not a HA problem because i tryed all the versions.
All the browsers also btw.
Api key is renewed manny thx for pointing to this.

Is there some place where i can trace/see more in a log?
Perhaps i can see whats going wrong then.

Do you have OpenTherm enabled in your settings from the Toon device itself?

OpenTherm is i think for rooted Toon. This one is original. And i need the toon integration thats default in Home Assistant…

Mine is not rooted and its not for rooted toons only. Is it on?

I dont see that option in my toon. I searched everything. Can you point me to the good direction?
And are you sure its not for rooted (openterm sounds also rooted :slight_smile:

Instelling -> verwarming -> opentherm


i have it green and off. (switch to the right) .
But as far is i can see this option is for opentherm protocol for smart CV’s like how much bar you have etc.
Dont see the problem with not getting logged in. But then again i dont really know the script :slight_smile:
My CV is about 12 years old so its only doing on/off i have opentherm but the servicedude told me it have to be off otherwise no heating in the house.

I also cant put it to off… (switch to the left) i think its programmed like this.

I have simular with my Toon / Home Assistant setup.

I have an active Toon subscription.
Configured the configuration.yaml with:

client_id: XXXXX
client_secret: XXXXX
scan_interval: 60

arch x86_64
dev false
docker false
hassio false
os_name Linux
python_version 3.7.3
timezone Europe/Amsterdam
version 0.104.3
virtualenv true

Made new api keys, i have no errors in my logs.
Same problem, can not authenticate my login.
Credentials are 100% correct.
OpenTherm is switched on.

I have no further clues then. Maybe raise an issue in github?

i think i found the solution. Thumbface… check something for me.
Goto and login… goto products what do you see?
We have to see gas / energie abbo toon abbo.
In my account i dont have the gas/energie abbo.
I already called eneco helpdesk (wurst people ever IQ like 50 ) but the system was making the last few months multiply accounts so i have 2 accounts 1 for power and 1 for toon and service contract for CV.
There going to merge it into one account but i cost them some time.
This… this must be the big issue some people have!!
Pls confirm you also missing the power contract?

Hi Tim,

I only have a Toon contract.
My power/gas subscription is with an other company.