Conbee 2, Ikea Tradfri, can't pair bulb

I can’t seem to get my Conbee 2 USB stick to locate my Tradfri bulbs. I’ll give you a breakdown of my setup:

So I started with a Tradfri Hub, a remote and 2 bulbs (the Ikea starter kit). I was able to pair these things up the traditional way and was able to get the Ikea Tradfri integration working fine to control the bulbs through HA.

I’ve decided to use a Conbee 2 USB stick instead of the Tradfri Hub in order to cut down on the number of hub type things I have to run, and to keep the bulbs off of the cloud.

Anyhow, I’m running Home Assistant in a Docker container (using docker-compose to spin up the container)

On my Docker Host, the Conbee Stick is located at /dev/ttyACM0, and I added a line in the docker-compose.yaml to pass that device through from the host to the container.

I use the configuration UI to add the ZHA integration and select the Conbee stick during the setup of the integration.

I tell the integration to add a new device and then turn the bulb off/on 6 times to put it into pairing mode (I suppose? it blinks and pulses for a while)

After the default pairing duration in HA (60 seconds I think) nothing happens. HA can’t seem to find the bulb.

I’ve physically located the bulb about 8 feet from the USB stick.

Am I missing a step somewhere? Anyone have some tips to help me get these bulbs paired with HA/Conbee 2?

If it’s important, the Tradfri Hub is still powered up and connected to the network, but the bulbs are no longer paired to it.

Would love some help!

Here are my notes on what works for me (based on finding notes from other users here). Hope they help.

  1. Pair the remote with the lamp:
  • Turn on the lamp,

  • Hold the remote closely (30cm)

  • hold the reset button on the remote until the lamp stops flashing. (No hurry, let it complete.)

  1. Dim the lamp to minimum (this makes it easier to make sure the lamp is successfully reset in the next step)

  2. Turn the lamp on/off 6 times - QUITE QUICKLY - leave it on the 6th time.

  • It will blink and then go to maximum brightness.
  1. The lamp is now reset to default (fast)

  2. Leave the lamp on.

  3. In deconz go to change timing to 3mins

  4. Then go to Lights>Add new light

  5. It should be added within approx 30 seconds,

  6. if it doesn’t show up then turn the lamp off and then on with the manual switch

  7. Deconz will now find your lamp within seconds.

I found some of the Tradfri bulbs to not want to pair with Conbee 2, and they sometimes required several attempts.

you could also try getting the bulb into pairing mode by turning it on and off, and then start looking for devices through the ZHA integration. I think that is what finally worked for some of my more “difficult” bulbs.

it will work, just keep trying.

At this point, I’ve tried both the ZHA integration several times w/ my 2 bulbs, and I’ve spun up a Deconz container and tried pairing them that way too. No luck so far. :frowning:

Is distance from the Conbee 2 stick an issue? I’ve tried pairing a bulb plugged into a lamp about 10 feet away from the USB stick. I’ve also tried pairing one that was on a different level in my house, a few rooms away. Still nothing so far. I might try a different machine (maybe not in a container too)

Thank you for reaching out.

Did you try plugging the Conbee stick to a USB extension cable? It seemed pointless to me in theory but once I got the USB stick a little bit away from my device, it worked great.

1 Like

This also seems pointless to me too, but I’m willing to try anything at this point! I guess I never really considered the placement of the USB device in relation to the rest of my house. It lives plugged into a Dell mini tower inside a cabinet in my TV stand in the living room. I guess the cabinet/position/temperature could all be obstacles. Thanks for the input. I’ll try an extension and report back what my results are.

Insane, but it totally worked. I bought a 12’ USB extension cable and it totally worked like a charm with the ZHA integration. thanks for the advice.