Conbee II woes - Only works when holding it!

So I’ve spent a couple of hours a night for the last few nights trying to get the start of my Zigbee network setup. What started out as excitement soon turned into severe frustration.

I have the Conbee II and some eWeLink plugs which should just work. Tried ZHA, tried DeConz, just wouldn’t pick up the devices. Yes, I have the dongle in a USB extension, and yes I’ve updated firmware and set Zigbee channel to avoid WiFi interference. I did eventually manage to get a plug connected and it would work for a bit then nothing.

I had been convinced that interference may have been the issue as my router, RPi4, Hive Hub and an O2 boostbox are all on the same shelf. I even tried two different USB extensions, manically checked lots of logs I didn’t fully understand, ready many forum posts etc.

This evening, whilst trying afresh for yet another time I went and held the Conbee in my hand during the pairing process - ping! The plug connented. Great, I thought. But toggling the plug entity via HA did nothing. so I grabbed the Conbee in my hand and tried again, and it switches on and off absolutely fine. Seriously - it only works when I’m holding on to the dongle a squeezing gently.

What on earth is going on here?

  1. Do I just have a dodgy Conbee II with a loose connection and am extremely unlucky?
  2. Are the USB extensions a bit rubbish? If so, what would be a better one? (one of the ones I’m using is brand new).
  3. Am I somehow amplifying the radio signal by grabbing onto the dongle/USB connection?

FYI - the plug is literally about a foot away from the Conbee.

I highly doubt anyone will have some concrete pearls of wisdom from experiencing the exact same thing, but posting here to get any useful thoughts and in case it helps anyone in the future!

Any advice of what I could do next?

Thanks in advance from a weary HA hobbyist.

Check this out 5:30 mark. It might help.


Thanks @kbweathe - but taking steps to avoid interference was one of the first things I looked at.

WiFi router is on channel 1
Conbee configured to use channel 25 (confirmed via deCONZ)
No other WiFi SSIDs in the vicinity (I live in a remote area).

Does interference sound like the most probable cause? I’m not sure it can be.

I just set up a Conbee II with several sensors and a mains powered light switch run with ZHA on a Raspberry Pi. Works great! I would be leaning towards a “doodgy Conbee II”. Wish I could help.

Do not change the channel on the Zigbee coordinator. Instead, use the default channel on the Zigbee coordinator and only change the Wi-Fi channels on your WiFi access-points/router. Not all Zigbee devices will pair using just any Zigbee channel. Some Zigbee devices are limited to one or a few Zigbee channels, especially when pairing. Blakadder db does mention channel limitations on some devices when users added that information (it is only a wiki maintained by users after all):

@Hedda - thank you! I was initially skeptical of your suggestions. I’d already looked at a lot of that documentation and planned channels carefully to minimise interference. Basically, you put me on the right track.

Lunchtime today, I plugged the Conbee into my windows machine and changed channel to 19. This is clear of WiFi channel 1, but also clear of channel 20 which I believe the Hive Hub uses.

I then managed to get a plug and Aqara motion sensor paired via deCONZ. I’m guessing my eWeLink plugs just didn’t like channel 25 for some reason.

This evening, I’ve ditched deCONZ and started to setup using ZHA. Devices didn’t pair first time in some cases, but I was patient and also found that using the ‘Add device via this device’ option provided more success for the pairing process. I now have four plugs paired and a motion sensor, and all seems ok. Will run for a couple of days to see if I run into any further issues.

I had no idea it would require this much trial and error to make the switch to Zigbee. Maybe I was a little impatient, but the feeling when I switch lights off instantaneously knowing it’s local control is very satisfying indeed. Main reason for making this move was being fed up with Tuya stuff, so fingers crossed things continue upwards from here!

Thanks again to you both for the input. Proud to be part of the amazing HA community :slight_smile:

Just hang in there, be a little patient and take it step by step.
I started using zigbee about 6 months ago and it went smooth, with some minor issues and I’m gradually adding devices.

Just a few questions… How far is your eWeLink module from the Conbee II dongle? Do you have the dongle in the vertical position or is it horizontal to your shelf/floor? Best results are in the vertical position. When you pair your devices you may want to install them in their actual location where they will be used, as they will set up the mesh network in a proper order (Controller-Repeater-End functions). Granted the mesh network will do its thing for the best setup. I purchased 90 degree USB adapters (Amazon) so that the dongles I use are vertical.
Good Luck

Yeah especially Zigbee devices by Aqara, Xiaomi, and Tuya devices as infamous for having pairing issues with all Zigbee implementations that are not their own, however adding more known compatible mains-powered Zigbee Router devices does make for a more stable Zigbee network. Again, recommend reading all the tips in those links and specifically seriously consider adding more known compatible mains-powered Zigbee Router devices, (personally I recommend buying a few IKEA Trådfri Signal Repeater simply because they are readily available online and at any IKEA store)

Zigbee specifications are complicated because there is often no hard standards on how exactly devices should work in every scenario and instead more guidelines that engineers at different manufacturers have to try to interpret. That causes issues with interoperability and compatibility problems between brands which ZHA, Zigbee2MQTT, deCONZ, and other Zigbee implementations have to try to work around with translation/conversion layers inside their solutions in order for them to work with as many different devices that does not exactly follow the Zigbee specifications. Read:

By the way, Jeedom developer wrote a great blog article about Zigbee compatibility a few days ago:

PS: If you want stuff to “just work” and are willing to pay for it then maybe consider Z-Wave instead :wink:

Good tips and I believe most of those suggestions/recommendations (and more) are covered here:

Also hope that this PR will get merged into ZHA docs so referencing those tips will get easier:

The eWeLink plug I tried to pair first is about 1m from the Conbee, and that is it’s final position hence why I tried it first. I now have the dongle in vertical position and after 24 hours, all four plugs and the Aqara motion sensor are working solidly and stable.

@Hedda - great shout on those additions to the ZHA docs. If I’d have has that advice before I started I’m sure it would have significantly reduced the frustration!

I know! But decided not to stretch to Z-Wave stuff. For the time being at least.

Thanks for all your input folks. I’ll be adding more Zigbee devices over the coming weeks. I also got a CC2531 from AliExpress which just arrived today. Intention was to flash it as a router should that be helpful. I have a very thick stone wall that runs right through my house.