Configure if rfxtrx device is switch or dimmer

I don’t seem to be able to configure if a rfxtrx switch is a dimmer or just a on/off switch.
If the switch is just an on/off switch it still shows as a dimmer in HA and also in homekit.
Does anyone know a way to fix this?

Have same issue.

You have to add it as a light to be able to use the dimmer functionality

I (We) know that. But not al of my rfxtrx switches with lights attached are dimmable.
So in my config I add a rfxtrx light, but then it automatically assumes that it’s dimmable which isn’t correct.

I’m now thinking that there might be a workaround.
The lights which are not dimmable could be added as a switch to HA. After that with customization I could give them the bulb icon.
But then in the background they would still be switches so they won’t show up as lights in Homekit.

Yeah, that is the only solution for the moment.

Guess I’ll create a feature request for this one. Maybe someone some day will have a couple of minutes to implement this.

It is not just a couple of minutes to change this.
By design, no home-assistant switches have dimming functionality.

(one year later)…
The case is already solved:
Dimming with Rfxtrx #969

One example here

I don’t think that it’s solved.
As far as I know, I still can’t say if a light is dimmable or only on/off.
I can add the lights as switches, but then they’re not lights.

I can dim the lights with HA when I set them as light.

You’re missing the issue here.
The problem is NOT that I can’t dim lights.
It’s that I also have lights which cannot dim phyiscally.
That’s why I want to disable the dimming for certain lights.
I could of course put them up as switches, but then they would show up as the 2 lightning bolts in stead of the light icon.

There is a workaround possible which I’m using (although in a slightly different setting).

My situation: I have a (z-wave) switch that controls a lamp (entity switch.kitchen_lights), but I want to include it in a lightgroup.
My workaround: create a template light, that controls the switch:

  - platform: template
        value_template: '{{ is_state("switch.kitchen_lights", "on") }}'
          service: switch.turn_on
          entity_id: switch.kitchen_lights
          service: switch.turn_off
          entity_id: switch.kitchen_lights

Now you have an entity called light.kitchen_lights, that looks and works like any other on/off light in HA.

Thanks vloris! That’s a workable workaround even though it’s not the most cleanest one. :slight_smile: