Connect with DSlite ipv6

Hi everybody, my ultimate goal is to access the hassio via ifttt and Google Home (without paying the 5€/month for the integration service Home Assistant Cloud of Nabu Casa Inc). For this hassio needs to be connectable externally.

I read a lot through the community but never found a complete solution for the DSlite problem with the German ISP Unitymedia. Trying many things that are replied in the discussion do not make it work for me.
I have a Raspberry Pi3 in my network with hassio installed. I have put this into the configuration.yaml file:

http: server_host: ::0

Using ‘hassio.local:8132’ in the browser address line works great to connect, but using the Pi’s IPv6 address listed in the router (Unitymedia Connect Box) and putting ‘[ipv6-adress]:8132’ in the address line doesn’t. I assume that trying from outside the network doesn’t make sense if it’s not working with the network with ipv6, right?
Thanks for helping me out in advance.

Best regards,

Why should the router’s IPv6 address work in this case? You have to use the Pi’s IPv6 address in front of :8123.

Also don’t forget that (for whatever reason) users should not use server_host: ::0 as stated in the documentation and in your system logs. Consider using a reverse proxy - they usually listen on IPv4 and IPv6 simultaneously making the server_host hack obsolete.

You need IPv6 connectivity to connect to your device from the outside. IFTTT and Google Home may support that, but I did not use IFTTT and the last time I’ve testet Google Home with IPv6 only it only worked after the initial pairing process.

DuckDNS isn’t able to detect your IPv6 address by itself. You may have to use other options/additinal steps to use it.

Whatever you do: Use HTTPS when opening your instance to the world…

My ISP is also Unitymedia but I have my own FritzBox (not rented) and I could only access to my Home Assistant if I set
http: server_host: ::0
In the FritzBox settings you have to set the DNS-Rebind for your domain and of course also set the port forwarding for IPv6 (in my case 8123).

But my problem is, I can not setup a reverse proxy correct. I don’t want to set http: server_host: ::0 so I can use IPv4 and IPv6.
I tried the official NGINX Add-on, the NGINX Proxy Manager Add-on and also the Caddy Add-on. But it didn’t work.
Can someone confirm that it is actually possible to use a reverse proxy with IPv6 and without http: server_host: ::0?

First you should have a DynDNS provider like that can resolve a name to the external IPv6 address of your network (to make this a bit easier).
IPv6 adress should be this one if you have a FritzBox:

Then make a port share to the IPv6 adress of your proxy server:

After that every proxy should be able to resolve the incoming requests and forward them to other internal addresses (no matter if IPv6 or IPv4).
I just tested it with my Traefik Docker installation and it worked so far with entering the external IPv6 address.

Fortunately I don’t have to use it, because I am one of the lucky ones who still have a real dual-stack connection (without Lite) at Unitymedia. :wink:

Thank you for your reply Simon,
My home assistant is running on a Raspberry Pi 3 B and I am using the official Hassio image.
I set the Portforwarding same as yours but still not working.

So you’re saying it should be working with any proxy? I’am using now the Nginx Proxy Manager.
Maybe there is something wrong with my configuration here?

When I try to connect over the Raspberry Pi’s IPv6 Address it’s also not working but when I try to connect over the IPv4 address ( its working.
Do you have any idea what I’m doing worng?

Ahh, I missed you using Hassio. I have Homeassistant Core and Traefik both running in Docker with IPv6 enabled Docker Bridge Network. So my configuration is certainly a bit different.

Okay, one thing at a time. Have you checked if you can reach Hassio at least via the local IPv6 address? It should start with “fe80::”. Attention, in the Fritzbox take out the DNS rebind protection for it, too! Otherwise, we don’t need to mess around with shares here, but first have to see how you can reach Hassio at all.

For my OMV Homeserver the local access looks like this:

After reading a bit more here, it seems that Homassistant is definitely only capable of single stack. So it can not handle IPv6 and IPv4 in parallel. Use IPv4 and IPv6
The only possibility is to redirect all requests to the IPv4 or IPv6 address of Homassistan via a proxy that can handle both protocols.

As said before I use Traefik running on a Docker Bridge network where both IPV6 and IPv4 are enabled. So the question is whether the NGINX Hassio plugin can handle both stacks properly and forward them accordingly. Unfortunately I am not sure about this.

Here is also a very interesting thread about IPv6 Dual Stack Light with and Kabel Deutschland: over IPv6

Sorry for my late reply. I couldn’t find the time to try it out.
Since some days I bought a Intel NUC and installed Home Assistant Supervised.
Installation was pretty easy but here I had the same problem with the proxy…

And since some days also the development for Home Assistant Supervised is stopped :sob: so maybe I will try also your setup.
Can you recomand some tutorials or community-threads for your setup?
(If its in german even better :wink:)

Big Thanks for your help.

Sure, you can send me a PM so we can talk in German