Coral M.2 Dual Edge TPU & HAOS

I would like to ask if it is possible to run the Coral M.2 Dual Edge TPU on the Home Assistant Operating System running on a Lenovo M710q Tiny i3 PC.
At the moment the system does not see that the module is installed.
Is it possible to install drivers?


HAOS has no use for a TPU.

I expressed myself a little badly.
I want to use the dual TPU module in frigate. Unfortunately, HAOS does not see the installed module (M.2)


HA OS comes with the drivers for the m.2 coral pre-installed. The USB based coral has the drivers built in.

Do you not see the hardware in the hardware section of HA OS? Should be /dev/apex_0 and /dev/apex_1

This is also what I expected that apex devices would be visible . Unfortunately they are not available.
Therefore, I would like to know if it is possible to install the modules.
One thing to check is the PCIe settings in the BIOS.The same module on another PC under Debian works without any problems.


@woojtekk did you resolve your problem? I want buy m.2 coral but not sure if I should buy dual edge or A+E version to work in wifi slot in m710q

According to crzynik the drivers are there, at least for the USB version.
The issue to OP had could have been one with the driver for the USB controller missing, but that should be possible to check with any another USB device in that port and see if HA then can detect that.

I have a dual TPU installed in mine.
Alot of the issues you might have are due to the slot you are using not being the proper slot…M key, Bkey, E key etc…
I had to get one of these and it works perfectly.:
Dual Edge TPU Adapter - PCIe x1 Low Profile | Makerfabs

1 Like

Hi @woojtekk have you managed to install your Dual Edge TPU on M710q - I use proxmox and it also does not see the card inserted. I remember some manufacturers have their peripheral slots exclusive for the whitelisted hardware and I am wondering if that is also the case with our Coral not being “allowed” to work.

Hi. Unfortunately I was not successful in configuring the TPU on the PIC. From what I have read it would be necessary to reinstall the BIOS because in my case it may be blocked by the manufacturer (LENOVO) .

I gave up using the USB TPU. PCIE module is waiting for better times


I bought A+E version and its working without problem on my lenovo M710q

1 Like

That also worked on HP ProDesk 400

Hey! I have an prodesk g400 mini, cannot get the coral to work, if i enable the wifi/bt in bios. The ethernet is dropped. Disable the wifi, everything is fine, but no coral is found.
What is your bios settings?
I run haos

@froniusMW which version? I found A+E working in that slot only.

Prodesk 400 G2 mini, a+e key. If the slot is activated in bios the coral is found, I think… apex found via HA CLI.
But ethernet drops

So is that plugged into the wifi slot. I have the M900 lenovo Tiny PC
How can you see in home assistant that it has been detected. I can’t seem to see mine
Thanks Danny

Yes, wifi slot. Solved the wifi problem with an usb-ethernet adapter. The coral shows in settings-hardware as apex_0

Does this look like its installed.
I am running HA directly on the M900 Lenovo, but cannot get Frigate to see the TPU.


Got it working. Thought I had tried this in the frigate.yml, but it works now

type: edgetpu
device: pci:0

After changing this code, tried a reboot of system, that didnt work. Did a restart of the frigate service and that seemed to work.

Now can see it in System in Frigate

1 Like

Super cool that I found this thread here as I am thinking of getting an Lenovo ThinkCentre M700 Tiny | Intel 6th Gen to run Frigate on it. And I’d like to pair it with the Coral “M.2 Accelerator A+E key” TPU.
I’d just like to confirm before I place my order if that setup is supposed to work? As I understood it, you got it working on such a system, right? So I remove the WiFi module (as it will be running via ethernet anyway) and replace that slot with the Coral chip and I should be good to go, right?
Thanks a lot!