Core update 2024.2.0 broke all cloud based custom integrations

I don’t know what’s happening but the latest core update (2024.2.0) broke all my custom cloud based integrations (iCloud3,, Imou Life and AstroWeather).

I really don’t know what’s happening nor what to do. I tried everything, i restored HA from a previous backup with core 2024.1.6, which was working just fine… nothing, I tried reinstalling and reconfiguring the custom integrations and still nothing. Anyone else has encountered this issue?

I’m running HAOS on a raspberry Pi 4B.

These are the logs from one of the custom components:

Logger: homeassistant.setup
First occurred: 17:31:22 (1 occurrences)
Last logged: 17:31:22

Setup failed for custom integration 'weatherdotcom': Unable to import component: No module named 'custom_components.weatherdotcom.coordinator'
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 251, in _async_setup_component
    component = integration.get_component()
  File "/usr/src/homeassistant/homeassistant/", line 827, in get_component
    ComponentProtocol, importlib.import_module(self.pkg_path)
  File "/usr/local/lib/python3.12/importlib/", line 90, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1387, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1360, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1331, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 935, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 994, in exec_module
  File "<frozen importlib._bootstrap>", line 488, in _call_with_frames_removed
  File "/config/custom_components/weatherdotcom/", line 11, in <module>
    from .coordinator import WeatherUpdateCoordinator, WeatherUpdateCoordinatorConfig
ModuleNotFoundError: No module named 'custom_components.weatherdotcom.coordinator'

Looks like the custom integration is the problem. Have you rolled back, removed the custom integration then upgraded without the integration installed?

I believe there are CLI commands that can be used to remove a broken integration from an broken upgrade, however I don’t know what they are. Perhaps try a search on this news group to see if anything shows up.

If a custom integration is failing, take it up on the integrations GitHub.