Correcting incorrect energy statistics

I really like the Energy dashboard. Unfortunately, I got some values in February that messed up the statistics. I was able to clear out most of the incorrect values by using the statistics tools under the development tab. However, I have some mixup that remain that I cannot understand how to adjust.

The energy dashboard in year-mode shows that something is off in February (I have no production, only consumption):

If I look closer at it at a Month level (February), I can see the same for February 9th:

However, when I look at it at a week or day level, there are no odd values in the data. I have reviewed the data through the statistics adjustment tools in the statistics as well, but I cannot see any negative values there.

Any ideas for a next step? I have adjusted about 5 values that were off previously through the developer tools, so I guess something went wrong…?

Hi, I have a the same problem. I could correct the statistics of the daily and weekly stats but the data in montly and yearly stats were not addressed.

I’m seeing this as well. It appears my Inovelli LZW36 (Ceiling Fan + Light switch on firmware 1.34) switches are frequently reporting incorrect data to Home Assistant by several orders of magnitude.

Here’s the Energy Dashboard in Year View - the top 3 entities are all the same Inovelli device on the same firmware. The third one is rarely used, but the top 2 show over 300 million kWh of use!

The top sensor if I click into it shows me an odd reading on the 30th at 12:36, but what’s odd is that I’ve already gone into statistics and removed that as shown in the next image below. The second top sensor from the previous image shows no odd values, but when viewing the Energy Dashboard by YEAR it shows it has over 300 million kWh of consumption.

Here’s the individual sensor at the selected time for the issue, which has already been corrected to 0. Daily views in the Energy Dashboard show correctly for this, but Year shows the huge number and the individual sensor still shows the spike, even though it’s been fixed.

Are these issues related? Any workarounds or do we think there’s a bug with the Energy Dashboard?

1 Like

I have the same problem. Daily and weekly stats look ok but monthly and yearly are wrong.




Hopefully someone out there has figured out a way to fix this… otherwise the stats for 2022 will be always wrong :frowning:

Does anyone find a solution for this? I have the same problem - after the home assistant update early Feb my utility meters wouldn’t work with the energy dashboard anymore. I has to switch their setting from “total” to “total increasing”. They worked again in the energy dashboard, but ever since monthly, and yearly stats for Feb are screwed up - similar posted previously. The hourly, daily, weekly statistics are correct. I searched everywhere for error - even in the database itself, but I couldn’t find the correspondent entries …

A feature has been added recently to fix outliers. Go to Link to Developer Tools: Statistics – My Home Assistant to search for a wrong number and fix it.


It is not working for me. Same behavior that the others mentioned earlier.
Daily energy dashboard looks ok but weekly/monthly/yearly dashboard haven’t changed.

After I changed the incorrect data to 0.

Same here;
sometimes I have a big wrong number in energy sent to te grid. After I correct the value (by developer->statistic tool) there is no way to update in right way energy daily dashboard :frowning:

I had the same issue - when I set up my Huawei system, it imported some crazy numbers

What I did was to go to developer-tools/statistics and even if the initial statistical change in those sensors shows 0 as a value I did put in a negative value of what was shown there. e.g. for my sensor “Stromnetz einspeisung” I did put in “-107374773.29” and my dashboard normalized afterward.

This is no solution, but a workaround!

I’ve just gone back to look at some historic data and noticed that my December 2022 month appears to have had a rogue statistic which appears to have a date of 6th Feb… why this appears in December I have no idea… HA was upgraded on the 7th Feb to 2023.2.2 is about the closest docker upgraded component I’ve got… The actual months of Jan and Feb fine to me

I had the same problem: on 7 Feb at 23:00 I had a very large value.

I used Adjust a Statistic from the Statistics panel of the Developer Tools (there is a little ramp symbol with an arrow on it in the far right column). I did it on Total Power Production, Total Power Consumption and a couple of others and it came right once the next hour ticked over (perhaps it recalculates statistics on the hour?)

Having the same issue after two of my sensor devices (tasmota) were unavailable for three weeks.
when they came back the energy dashboard imported the current values of “total energy” from the sensors as the usage.

strangly enough this is NOT reflected in the statistics ramp area of the developer tools. all values are zero there.

I’ve tried the workaround with manually adding a negative value but this did not change anything.

Is there a way to force an update of the statistics or correct it in a different way?

Same problem for me! I corrected the wrong entries in the statistics editor, but the changes are not reflected in graphs.

Same here. Nothing in the stats at that time. Where does the value come from?

Same problem here. Anyone found a solution?

I had the same problem and tried to correct the statistics may be 2 weeks after the incident back in December 23. No succes, however, it did work suddenly yesterday with the most recent versions of HA.

Same issue here.
For me this is always triggered by restarting Homeassistant. Then the statistics start counting again from zero, hence these high values.

I have known this behavior since version 2024…
Does anyone have a solution for this?