Cover - button open/close unavailable

Sorry to ask this stupid question, but after a long vain search, I’d like to know how to get the “open” button activ, once I used it a first time :

roller
My configuration :

cover:
  - platform: template
    covers:
      volet_1:
        friendly_name: "Volet 1"
        optimistic: true
        open_cover:
          service: switch.turn_on
          data:
            entity_id: switch.grenier_2
        close_cover:
          service: switch.turn_on
          data:
            entity_id: switch.grenier_1
        stop_cover:
          service: switch.turn_on
          data:
            entity_id: switch.grenier_9

And the button :

entities:
  - entity: cover.volet_1
title: Volets roulants
type: entities

It relies on state info to enable/disable up and down. But you don’t have any state info. You specified ‘optimistic’ mode…so it’s going to try to maintain the state for you. Thus, if you push ‘close’, it will assume it’s closed and only allow the open button. Likewise, pushing ‘open’ will only allow close next.

So set optimistic to false.

covers:
      volet_1:
        friendly_name: "Volet 1"
        optimistic: false

If that doesn’t work, also should also specify a position template of 50 so it thinks it’s always right in the middle.

Because it says this, not sure if you can override it by specifying ‘false’.

https://www.home-assistant.io/integrations/cover.template/#optimistic-mode

This mode is automatically enabled if neither value_template or position_template are specified.

covers:
      volet_1:
        friendly_name: "Volet 1"
        position_template: "50"

But keep in mind, it will say your state is always 50.

In an ideal world, you’d have some other sensor you could use to determine your position state. But sometimes you just don’t care and want to make it go up/down.

1 Like

The optimistic false didn’t help, but the second one :

did the job :slight_smile:
Thank you so much !

Also have this issue, raised as an issue here:

1 Like

The easiest way to get the buttons displayed all the time is to add the following to configuration.yaml

homeassistant:
  customize_glob:
    "cover.*":
      assumed_state: true
8 Likes

I’m having the same problem with “template” type of covers…HA ignores the “optimistic: false” (which is actually the default for template covers) and tries to track state, resulting in only one button at a time being enabled in Lovelace.

The other side effect here is that my cover groups are behaving the same way as the default template covers (e.g., only one button enabled at time), and thus far, I haven’t been able to find a workaround for those. Even if all the entities in the group have the position_template hack, the cover group doesn’t display properly.

your solution works perfect for me! thank you!

The workarounds did the job for me in lovelace. Unfortunately in Homekit and on NSPanel I still had disabled buttons depending on the state.

Here my solution for this, in case someone faces the same issues.
I have set the state with the value_template permanently to unknown:

state_topic: "tas-rf-bridge/tele/RESULT"
value_template: unknown

Still is a good workarround, thank you KNXBroker

In my case, the assumed state is generally correct - so I do not want to turn it off. Nevertheless, I do not want the “down” button to be grayed out when the assumed state is “down”, as I want to be able to send that command to the blind anyway. The main reason is that if I have adjusted the tilt angle when the cover is down, I want to be able to reset it to “down and fully tilted”. Is there any way to do this (ie disable the graying out of the “down” button?