Create zwave association in zwavejs2mqtt control panel

I want to associate two switches to create a virtual 3 way. I am running home assistant in docker and am using zwavejs2mqtt to control the zwave stick. I know it involves groups, but I can’t figure out how to actually associate two switches. Also, while the zwavejs2mqtt documentation says this is possible, it fails to specify how. Could someone please point me in the right direction?

Under groups you click “add”, then it should be group 2 basic local load. Then the target is the other device it controls. That’s if your device supports associations though. What Device are you trying to do this on?

1 Like

The only option I have under group is lifeline.

I’m trying to create a virtual 3 way with one switch actually controlling the lights and a remote switch. I’ve tried to add this to the remote switch, but nothing happens.

If the only option is lifeline your switch doesn’t support associations to other devices. Associations in zwave are stored on the firmware of the device and not all devices support them. Group 1 is the “lifeline” association which is the hub/zstick only. If you supply the model of the device I can confirm.

Your other option is to setup an automation in Home assistant that turns the other light/switch on or off based on the state of the switch.

That answers why it doesn’t work. Is there a good resource for this information?

The zwavejs device database containing information usually available in the owners manual for the device?

https://devices.zwave-js.io/

All zwave products must be certified by the zwave alliance, and they maintain a database that lists any certified device’s association and configuration parameters. You can search the database here

https://products.z-wavealliance.org/

1 Like

This is a good resource and I use it all the time, but just beware, it often has wrong or incomplete information about devices, and is missing many devices or their variants.

1 Like

Yes the variants can definitely be a pain, especially for the ge/jasco switches where they reused the same model numbers for multiple versions of their switches

But the manufacturer decides whether it is listed on the site.

I hope this isn’t considered a threadjack, but I have a very similar problem. I have a few smoke alarms that I want to connet to an Aeotec Siren 6. And I can get a group from the alarms, but when I click the “ADD” button here, nothing is saved. I have tried several times, and it just won’t work. I have the latest version of Z-Wave JS to MQTT, running core (without docker). This is what the add dialogue looks like on my system (no local load):

The target node is “Smoke alarm siren” in Norwegian, and endpoint 7 is the alarm tone in it (there are 8 endpoints, which can be programmed with different tones and volumes). To me it seems like it should work, but no. I am unable to add stuff to the groups I already have (from OZW in previous Hass, before I upgraded to Z-Wave JS to MQTT) as well, like this one for a button:

If I try like this:

nothing is added there either. Is there a setting somewhere that I have missed?