Custom Component: Dreame Vacuum


I installed the beta version because I owned a Dreame L20 Ultra.
I have trouble with the integration part. I selected Configuration Type → Dreamehome Account, but the login interface seems normal in Xiaomi Cloud.

How do I integrate with Dreamehome account

any chance to get the l10s pro ultra heat supported?

my mine is ok with beta addon

ahh. i missed to choose the beta. Now it is working
Can you view picture of obstacles and live video?

Cannot stream live video but can display obstacle photos.

HI there,

I have just got the L20 ultra.
I am having issues with the log in as it is requested the Xiaomi login.
I have created an account and when i use it it says there are no compatibnle devices. I cant seem to install the Beta versions. If anyone could help that would be great.


i have tried the call service update but that has not worked either. thanks

Hi, I have version v1.0.4, I can’t update to the beta version. When I select the beta version from the list in HACS, after a while it changes my selection to v1.0.4. Why is this happening?

Have the same issue (removed it, rebooted HA, reinstalled 1.04, but when i choose from the menu the beta version it just select back 1.04).
If i install it using the script, it doesn’t appear under HACS (like it wasn’t installed) but it works normally

I have re downloaded and tried to select the beta version from the drop down menu ot reverts back to the latest version 1.0.4.

it is still asking for a Xiaomi login instead of my Dreame account and i cannot change versions

i get to the part to install the integration, my robot is listed but i get an unexpected error after trying to complete the installation. I have the L20, is this unit not compatible?

Update. after trying to install, I am now stuck on an endless loop of trying to reconnect / loading data and am unable to access my dashboard. I will hard restart the device an update

Update. Upon he installation I unchecked all the map subsections. has installed. Will continue and advise if any further issues

Hey @tasshack I am using the beta version with the Dreamecloud nearly since you implemented that in the first beta version. It works like a charm, no errors, nothing. I just wanted to give you a very positive feedback. I also bought you a coffee :slight_smile:


Hi! Please tell me, my Xiaomi Mop 2 Ultra refuses to work without the “prefer cloud connection” option enabled; the integration detects its IP address correctly, but cannot start working. The robot responds to ping from the local network ( and, the HA server is connected to the same router as the vacuum cleaner, there is one subnet, there are no firewalls on the LAN. Maybe someone has encountered this? Maybe this vacuum cleaner can only work through the cloud?

Hello, downloading the beta version from github and uploading the files manually helped me

Dreame has started to disable local api functionality from their devices but not sure it also cover the Xiaomi branded devices but it might because they share same firmware with the Dreame ones.

I have downloaded and installed the latest beta, but it seems when installing the Integration and selecting to use the Dreamehome App credentials, there is no specific server for Australia (or maybe Asia Pacific?). I tried using each server but it doesn’t seem to recognize my username.

It is a L20 Ultra purchased locally here in Australia, and the credentials work fine for the DreameHome App on the mobile. I’m wondering if another country server needs to be added to the integration setup for Asia Pacific?

Here is the error from the logs:

2024-05-17 09:37:29.260 ERROR (SyncWorker_29) [custom_components.dreame_vacuum.dreame.protocol] Login failed: {"error":"invalid_user","error_description":"Dreame user not found"}

Any other aussies here got this working successfully?

Dreame does not use country system as different servers like Miio instead its just limits the devices can be added according to the region. That means you can login to the any server using the same account (unlike Miio) and you should be able to add your device to HA if it is available to country you have selected.

After doing a wireshark on my phone I found that it does indeed go to the Singapore server (sg). Not sure why it wasn’t working earlier but selecting sg seems to work for Asia Pac as a whole I guess:

No supported devices were found in this Xiaomi Miio cloud account on the selected country., I even made new account as " SG" still nothing for a Dreame Vacuum thing it looks to support mostly MI Vacuums