Custom component goecharger_mqtt - go-eCharger HOMEfix EV charger integration

I’ve prepared a custom component to consume the MQTT messages of the go-eCharger MQTT API v2:

I would be happy about some beta testing and support of the heavy EV charger users. :wink: Naming and value transformations could be improved step by step.

3 Likes

I installed this integration yesterday so I will start playing with it soon. I just got my box two days ago and was planning to use a different integration. But it did not show up in HACS and this one did and I already have MQTT running at home so I thought I would give this a go.

So far I have only seen that it works with reading values and I was able to change the amp setting from HA and confirm that it worked. And for the moment that is all I need.

The plan is to use this integration combined with my solar inverter integration to implement a load guard to allow the charger to use as much power as it can at all times without blowing any fuse(s) :stuck_out_tongue:
The presence of a supported local API, and the fact that it is also portable, was the reason I chose this box since I could then have a load guard without any additional HW since my inverter already has a power meter.

1 Like

is there anything like a installation guide i hav no idea from MQTT but ne i have the GOE Charger an would like to control ist with my HA…

Please google for “homeassistant mqtt beginners guide”. As far as I know there a two ways to setup a MQTT broker:

  1. If your HA setup supports addons and you simply install the “mosquitto broker” add-on: addons/DOCS.md at b4d9ee150aa0558b0fa73bd3399d99e9bc14a247 · home-assistant/addons · GitHub
  2. If your HA setup doesn’t support add-ons you have to install the MQTT broker manually somewhere at your local network: apt-get install mosquitto

As next step you’ve to add the “MQTT integration” to connect your broker (host + port):

http://localhost:8123/config/integrations -> Add integration -> MQTT

As soon Home Assistant is connected to your MQTT broker install the “go-e charger component” and tell your go-e charger to push data to the broker (Android app → Internet → Erweiterte Einstellungen → Aktiviere MQTT API [x] → mqtt://192.168.x.xxx:1883). The data should be visible at Home Assistant immediately.

Please create an issue at the project repository if you need additional support.

1 Like

I have installed the integration but the new sensors does not appear in the Developer tools. I’m running mqtt already for Zigbee2mqtt, and go eCharger is configured with mqtt.
Where do I configure the 6 digit serial number?

Please restart Home Assistant once and go to “Configuration” → “Devices & Services” → “Add integration” and add the “go-e charger (mqtt)” integration. You will be asked about the serial number here. Do you know the serial number of your device already?

1 Like

Thanks for the quick reply - it appeared under “Devices & Services” this morning, and it just needed to be configured. The serial was in the device name. I did not have to enter it.
It works now. I get the data live now and can change the amps, which is just what I needed.
Thanks again for a solid component.

THX syssi!

The integration is working really well. Only thing is, that energy consumption is given in wh not kwh.
I would like to add it to the energy dashboard.

Best regards,
Stefan

The energy dashboard requires kWh and doesn’t support Wh? If this is the case I will change the unit.

@syssi,

I just checked it again. I think it accepts wh but needs a last reset.

The failure is

Letzter Reset fehlt
Die folgenden Entitäten haben die Zustandsklasse "measurement", aber "last_reset" fehlt:
sensor.go_echarger_xxxxxx_wh
Letzter Reset fehlt
Die folgenden Entitäten haben die Zustandsklasse "measurement", aber "last_reset" fehlt:
sensor.go_echarger_xxxxxx_cards

ok, maybe go-e never resets it

I found this:

Best regards,
Stefan

Do you use the most recent release of the custom component? Because the state class is total_increasing already: Use STATE_CLASS_TOTAL_INCREASING to be energy dashboard compatible (C… · syssi/[email protected] · GitHub

Hello syssi,

yes I used your last version 0.10.0 via hacs. It was working fine until yesterday afternoon.
An update of ha os came in and I installed it. I use ha in virtualbox
Now I don´t get a connection from go-e anymore. Everything stays at unavailable.

My Mosquitto runs as HA-addon.
I get this in log

1648903522: New connection from 172.30.32.1 on port 1883.
1648903522: New client connected from 172.30.32.1 as dc8cf344 (p2, c1, k15).
1648903525: New connection from 192.168.88.145 on port 1883.
{"result": "ok", "data": {}}1648903525: New client connected from 192.168.88.145 as c6dea259 (p2, c1, k15, u'mqtt').
1648904703: Saving in-memory database to /data/mosquitto.db.
1648905979: New connection from 192.168.88.155 on port 1883.
1648905979: Client go-echarger_077102 already connected, closing old connection.

I really don´t know what to do. So, it seems the charger connects to broker, but why is it closed again?
I spent now more than 6 hours to get this fixed. Reinstalled mosquitto addon, go-e addon. Changed fw of go-e to beta and back. Turned off go-e.

I have a laptop running with HASS.Agent GitHub - LAB02-Research/HASS.Agent: Windows-based client for Home Assistant. Provides notifications, quick actions, commands, sensors and more. which connects just fine to moscitto.

Any help would be nice. The other go-e addon is working, but only with api1 and its not as nice as yours.

Best regards,
Stefan

Which go-e firmware version do you use? Is Home Assistant (MQTT integration) able to connect to the broker?

I use 053.1
I use HASS.Agent which connects fine to the MQTT Addon and everything works. So I think MQTT Integration is working

Is it possible that you somehow managed to install the custom component twice?

I will check it this evening. I installed it via HACS

Some details about my local setup for comparability:

  1. I don’t use the HA add-on. I’ve installed the broker manually:
$ dpkg -l | grep "mosquitto "
ii  mosquitto                             2.0.14-0mosquitto1~bullseye1                                              amd64        MQTT version 3.1/3.1.1/5.0 compatible message broker
  1. My go-e charger doesn’t connect twice:
$ grep charge /var/log/mosquitto/mosquitto.log
1648995409: New client connected from 192.168.1.11:58084 as go-echarger_072246 (p2, c1, k120, u'sensors').

$ netstat -tn | grep 192.168.1.11:
tcp        0      0 192.168.1.100:1883      192.168.1.11:58084      ESTABLISHED

I like the command line tool mosquitto_sub to subscribe and make some traffic visible:

$ mosquitto_sub -h <BROKER-IP> -u <USERNAME> -P <PASSWORD> -t '/go-eCharger/#' -v 
/go-eCharger/072246/alw false
/go-eCharger/072246/acu null
/go-eCharger/072246/adi true
/go-eCharger/072246/dwo null

You could use any other client software to subscribe to the go-eharger topics. The MQTT integration of Home Assistant also provides some small client for debugging. Please go to

Configuration → Devices & Services → MQTT integration “configure”

The last card is called “Listen to a topic”. Please try to listen for “/go-eCharger/#” messages. Do you see any traffic? If there is no traffic: Please subscribe to “#”. Now you should see every arriving message (at the broker). If there is no traffic try to publish a message manually. The topic and the payload isn’t important.

Now you should be able to answer the following questions:

  1. Is the broker available
  2. Is the MQTT intergration of Home Assistant connected properly to the broker?
  3. Are we able to receive messages in general?
  4. Are we able to receive message from the charger? / Is the charger able to connect to the broker and publish messages?

@Jpsy
no, its installed only one time

  • Is the broker available
    yes, everything works fine
  • Is the MQTT intergration of Home Assistant connected properly to the broker?
    yes it works
  • Are we able to receive messages in general?
    yes listening with “#” gives messages like
Nachricht 888 empfangen auf homeassistant/sensor/DESKTOP-T1ECMFD/LastActive/state um 16:46:
2022-04-03 14:46:11Z
QoS: 0 - Retain: false
Nachricht 887 empfangen auf homeassistant/switch/DESKTOP-T1ECMFD/MediaMute/config um 16:46:
{
    "availability_topic": "homeassistant/sensor/DESKTOP-T1ECMFD/availability",
    "command_topic": "homeassistant/switch/DESKTOP-T1ECMFD/MediaMute/set",
    "unique_id": "1f452925-ac26-4cde-8b69-f3491508c0f1",
    "device": {
        "identifiers": "hass.agent-DESKTOP-T1ECMFD",
        "manufacturer": "LAB02 Research",
        "model": "Microsoft Windows NT 10.0.22000.0",
        "name": "DESKTOP-T1ECMFD",
        "sw_version": "2022.3.27.0"
    },
    "name": "MediaMute",
    "state_topic": "homeassistant/switch/DESKTOP-T1ECMFD/MediaMute/state"
}
QoS: 0 - Retain: false
  • Are we able to receive message from the charger? / Is the charger able to connect to the broker and publish messages?
    no, I do not get any messages from the charger. The broker I entered in the charger is “mqtt://192.168.88.7:1883” which is the IP of my HA installation
    So it looks like I have a problem with mqtt of my charger.
    Do I have to add a username and password somwhere? I could not finde anything to add.

If your broker is password protected you have to embedded username and password in the URL:

mqtt://username:[email protected]:1883