[Custom Component] Jablotron Cloud

Hello Jablotron users!

If you ever wanted to control your Jablotron from HA without connecting directly to it using USB you are on the right place.
Let me introduce you my first integration to control Jablotron remotely using Cloud API. Unfortunatelly Jablotron keeps local API closed and we have only those two options.

Here it is:

I’m open to your suggestions and comments below.

Btw. if anyone can find why first entity created by this integration takes 30s to update please let me know and I will fix it.

Cheers!
Pigotka

1 Like

Does this integration supposed to support Jablotron car alarms?
If so, what pin to provide?

I provided username and pass as well as some random pin. The integration does’t report anything wrong but there are no entities created

Tbh I never heard about jablotron in car. But if you are able to controll the alarm from jablotron cloud accessible on https://www.jablonet.net/ page then yes it should work for you as well.

Yes, I have this device controllable with the mentioned web app.
Then:

  1. what PIN should I enter while adding integration?
  2. how can I debug the integration?

I found in HA logs attempts to create some entities but none of them are available in dev tools

bellow snippet of grep -A5 "jablotron" from HA log (obviously not all records come from jablotron integration)

2023-04-18 22:36:33.619 INFO (MainThread) [homeassistant.setup] Setting up jablotron_cloud
2023-04-18 22:36:33.619 INFO (MainThread) [homeassistant.setup] Setup of domain jablotron_cloud took 0.0 seconds
2023-04-18 22:36:34.946 WARNING (MainThread) [homeassistant.helpers.template] Template variable warning: 'dict object' has no attribute 'power_outage_count' when rendering '{{ value_json.power_outage_count }}'
2023-04-18 22:36:35.975 INFO (MainThread) [homeassistant.components.alarm_control_panel] Setting up alarm_control_panel.jablotron_cloud
2023-04-18 22:36:35.982 INFO (MainThread) [homeassistant.components.binary_sensor] Setting up binary_sensor.jablotron_cloud
2023-04-18 22:36:35.988 INFO (MainThread) [homeassistant.components.switch] Setting up switch.jablotron_cloud
2023-04-18 22:36:35.994 INFO (MainThread) [homeassistant.components.sensor] Setting up sensor.jablotron_cloud
2023-04-18 22:37:19.533 WARNING (MainThread) [homeassistant.helpers.template] Template variable warning: 'dict object' has no attribute 'system_mode' when rendering '{{ value_json.system_mode }}'
2023-04-18 22:37:19.537 ERROR (MainThread) [homeassistant.components.mqtt.climate] Invalid modes mode: 
2023-04-18 22:40:07.027 INFO (MainThread) [homeassistant.components.websocket_api.http.connection] [547723766672] Connection closed by client
2023-04-18 22:40:07.028 INFO (MainThread) [homeassistant.components.websocket_api.http.connection] [547406592656] Connection closed by client
2023-04-18 22:50:55.030 INFO (MainThread) [homeassistant.components.websocket_api.http.connection] [547703403808] Connection closed by client

PIN is mandatory parameter but if you enter random number it will not block the integration but you will not be able to controll sections of alarm that requires PIN.
In your log’s I see that integration was not able to detect any device. To see detailed logs you need to enable debug loggin on the integration.
Here is how:

Anyway in next release I will add more logging to see the problems on unknow configurations more clearly. Hold on.

Hi,
I have the same issue :-/ Can anyone kindly update the status?
This is the only one integration which I am missing after migration from OpenHAB :slight_smile:
many thanks
regards
Petr

Hello guys,

I am trying to add the repository but am getting an error back that it is not a valid add on repository. Any idea, what is wrong?

Thanks,
Fanda

Ignore my post, I found out that I need HACS.

Hi,

I just upgraded my HA to 2023.11.0 and it broke the Jablotron Cloud custom integration. Anyone else seeing this or is it particular to my system?

BR,
/Manu

Never mind my last post. For some reason, everything re-appeared magically overnight.

Is there a way to see when the alarm is triggered?

yes, but I haven’t added it yet because it is a bit annoying to test and it will have 30s delay anyway which is quite bad for alarm

Hi there!

Really like your integration, but still not sure on one topic: How can I get status of the PGs?

All the switches are PG’s. Look how it looks in my integration for example:
image

The integration is great. Thanks for making it. Unfortunately I’m having some issues lately. I’m attaching the first log problem. I need to reload integration to make it work again. Any thoughts what could be wrong? Everything worked fine for whole last year.

Error requesting Jablotron data: HTTPSConnectionPool(host=‘api.jablonet.net’, port=443): Max retries exceeded with url: /api/2.2/serviceListGet.json (Caused by NewConnectionError(‘<urllib3.connection.HTTPSConnection object at 0x7f4b04dc10>: Failed to establish a new connection: [Errno -3] Try again’))

There is currently a bug reported. I’m working on improving the situation but have very limited time right now.

1 Like