Custom Component: SkyQ Media Player

I was going to say, if there is something in entity picture, then the integration can see the image, because it only adds a value if it can do a ‘head’ request to it.

Yep it’s there, it seems to show the string in entity picture as it should but for some reason it’s blocked from loading it into a browser.

Try constructing a url with it, and opening it in Chrome with developer tools open, and see if there are any errors showing in the console. It would be cleaner than opening HASS via Chrome.

I stopped using Pihole when they deprecated it, so use Adguard add on now.

Pihole is deprecated? Nothing on the website that I can see to say that. Did not know that. Maybe I’ll check out adguard.

I’m not sure what’s happening now, pihole isn’t blocking the URL but if I go to

In chrome I get the pihole landing page, I even get this when I stop the pihole docker.
I also can’t see why live images work in the exact same way but the png’s don’t.

Can you tell me where the images are pulled from and cached to? Maybe I could whitelist that URL?

I should have said the pihole add on is deprecated.

I’ve not looked at HASS image caching to be honest because it has always just worked for me. Should be easy to whitelist it though. Best in mind live images are likely using the external URL. When you look at the entity in developer tools for live view it should show a second URL which I think is what it uses to save you routing via HASS, whilst for a local image it needs to serve it so it is accessible via the Internet.

I run pihole in a docker container, I try to avoid home assistant add-ons for stuff like that, if home assistant dies (or I kill it) I would still want my network to function as it normally would.
I may try adguard to see if it fixes my problem.

To be honest if you are going via IP address pihole doesn’t come into play anyway. So if that URL isn’t accessible then something weird is going on. You can also try yourbaseurl/local/community/skyq/netflix.png, and see if that is accessible. If that works I can look at the code at the weekend to see if I can provide via that url.

That’s what I thought, why would an internal IP go through DNS? It looks like the network thinks that URL is trying to access the pihole admin page.
If I go to those URLs then the images show correctly with both internal IP and duckdns so I know I’ve got the images right.

Does it work if you access HASS externally? Or fail both internal and external? Is your router doing something funny?

Accessing the images via the URL works internally and externally but the integration doesn’t work either internally or externally.
I run pfsense for my router so maybe it could be to blame but not sure why it would be.

I can look at the code and see if I can present the /local address instead. But would be Saturday at the earliest.

That would be great for me but don’t rush, when you have time is great, let me know when you can. Thanks

PM’d you with a potential change

Tried the new code and it now shows the local file in the picture_entity field, the picture_entity_local still shows the long api URL, unfortunately neither work for me.
I’ve spent most of the day trying to fix my network, got rid of pihole and moved to adguard. I no longer get the pihole page I just get a straight page cannot be found error.
Thanks for you help though, really good of you to try to accommodate me.

Seems strange to me. Not sure I can suggest anything else. Have you got nginx in use? Is it doing some routing on the /api url?

I do use nginx but to be honest I just followed a tutorial so I could get duckdns working to access ha externally.

A simple question …

Why having configured in yaml file all these sources:


I see only three channels ??? (that are not listed above):


By Pet

Solution (thanks to Gav_in):

List of channels: Options in SkyQ integration panel -> channels at the top under “List of channels sources”.

Channel sources are configured via Integrations now…have been for a while. Yaml is deprecated in this regard
If you already have the component setup, you can reconfigure sources in Options.

A simple answer… :grin:

1 Like

It’s not deprecated as such, just not as simple to use. If you post your config, rather than just as a picture, I’ll take a look at the start of next week.

1 Like