[Custom Component] Tapo: Cameras Control

It will be fixed on next release already merged to main.

1 Like

Hi guys! I’ve readed the Troubleshooting | FAQ regarding the topic “Binary sensor for motion doesn’t show up or work” and I followed all the steps but the one related to webhooks (without success, my C510W Motion Sensor is not showing although the Noise Sensor is showing) and I’ve done a little research about webhooks because I don’t know how to enable or check them. I’ll appreciate any hint or help

:white_check_mark: Make sure the camera has motion detection turned on
:white_check_mark: Make sure the camera has privacy mode turned off
:white_check_mark: Make sure the camera can see you and your movement
:question: If you have webhooks enabled, and your Home Assistant internal URL is reachable on HTTP, make sure camera can reach it.
:white_check_mark: Make sure you have correct IP set for Home Assistant. Turn on Advanced Mode under /profile. Go to /config/network and under Network Adapter verify correct IP is shown for the device. If it is not correct, under Home Assistant URL uncheck Automatic next to Local Network and set it to http://:8123. DO NOT USE HTTPS.
:question: Certain camera firmwares have pullpoint broken, with only webhooks working. If you are not able to run webhooks because of above (https, or vlan setup), binary sensor will never show up.
:white_check_mark: Try walking in front of the camera
:white_check_mark: If above didn’t work, restart the camera and try again

Also make sure that:

:white_check_mark: binary sensor is not disabled via entity, check .storage/core.entity_registry for disabled entities, look for “disabled_by”: “user” on platform “tapo_control”. If it is, remove the whole entity or change to “disabled_by”: null, and restart HASS.
:white_check_mark: binary sensor is enabled in tapo integration options
:question: onvif port 2020 on camera is opened

EDIT: Suddenly it started working without changing anything ¯_(ツ)_/¯

Just waited a few hours

Hint: There’s is no reason for you to post the FAQ, it would be enough if you just said you have read it :wink:

Reinstall the Cams again( And read what’s in front of you(all !) before click anything ;), or go to the integration, and go through “Configure”, Make sure you read it All

Also, i would be a good idea if you tell/show what you have done (beside reading the FAQ),

I only post it with a :white_check_mark: for the ones that I did and a :question: for the ones that I was asking that had no idea how to check it. That was the reason

Who would have known ! :thinking:

Going back to my problem:

The motion sensor is showed now but it does not detect nothing :confused:

Going back to my commends.
Please read this url, and try to “refine” your way of communicating
How to help us help you - or How to ask a good question.

PS: I doubt it would be there, if it haven’t detected motion

The sensor shows up only if the connection already worked one time. If it stops working and you have not changed anything, it is a camera issue unfortunately most likely. You can try the official HA onvif integration to see if that behaves better (it will most likely not).

Thank you all. I’ll check it also the HA Onvif integration.

EDIT: @JurajNyiri I tested with Onvif and it does not show the Motion sensor.
I was testing the motion sensor using Synology Surveillance and the camera detection is working correctly there.
I also tested enabling Tapo App notifications and it shows notifications every time detect something meanwhile HA is not detecting the most of them.

A few weeks ago (posted above) I had problems with the new firmware, but reintegrating solved it and it worked again for some time. But since yesterday I’m getting “Authentication expired” and I am prompted to reconfigure. When I’m doing this I get told that the Tapo Cloud password is wrong, but I am 100% it wasn’t. I reset the password anyway and tried the new one (copied and pasted it to be sure) but I am still getting “Invalid cloud password”. Anyone else having this problem or anyone has a hint for me? I’ll try reseting the pw again later, but I am fairly sure that this is not the problem.

Same problem, I came here looking to see if there is a solution.

Yes scroll a little bit higher or read readme. There is an issue open with solution.

1 Like

So it’s the special characters? Weird, why did it work with special characters for weeks? I’ll try changing it as soon as I get home.

No, ❗❗❗PSA: Firmware 1.3.8 (or build 230921 and higher) and newer might cause integration not to work · Issue #551 · JurajNyiri/HomeAssistant-Tapo-Control · GitHub

Good morning,

My cameras have also stopped working (CS420). “It couldn’t be configured.”

Any solution?

Thank you

Is it possible to put a camera view with a default preset? And not having to change with the “Move to preset” drop-down list

Thank you for this amazing Custom Component, I’ve been using it for a few weeks now and I’m loving it… Most of the functionality is working for me however, I just can’t seem to find a way to trigger the siren on the C500.

Get this error:
Failed to call service siren/turn_on. Error: Parameter to get/do does not exist, Response: {“error_code”: -40106}

I’m fairly new to the HA scene and well smart devices in general, please advise on what I can do to get the camera siren to work, if it’s even possible currently.

Thank you

Yes, When you mount your cam in the ceiling/wall or where ever, you point the Cams Default in the direction it’s suppose to cover , after every restart it goes there :wink: approx in the middle of it’s cover-range

My two C210 cameras have stopped working in the integration, but they still work in the Tapo app. When I try to reconfigure or delete/add the cameras, it won’t accept the cloud password, like so:

Capture

I am entering the cloud password correctly. To check, I logged out of the Tapo app, then back in using the same password. Works in the app, but not in the HA integration. The camera password and the cloud password are the same. Any help in solving this problem is appreciated.