Custom Dark Sky Animated Weather Card


#689

in your config where you specify separator_top_margin: ??? can you copy/paste that here.

Also if you use the separator bar it resets what the card thinks is the top so if you also use current_data_top_margin you need to adjust it’s values as well…


#690

OK… so if I am reading this correctly , you don’t want the separator bar… but you want extra room above the current data slots… Adjust the value of current_data_top_margin…


#691
            separator_top_margin: 5em       #default 5em px or em

yes. understood but I need to use:

            show_separator: true

and it isn’t using that 5em. I put 10em and it looks the same to me.

I’d love to have the extra space without the bar showing…


#692

see my last post… you don’t need show_separator


#693

so adjusting that will move the slots down anyway? (adjusting the current_data_top_margin)?


#694

yep… that is specifically what it is for


#695

we seem to be cross posting a bit hahaha


#696

OK, I’m sorry, but I’ve missed it again, and can’t find it. Please don’t kill me.:crazy_face:

Where is the post about the updated summary area at the bottom with the Summary for: section and the Rest of the week: section. I’ve looked and can’t find it.


#697

That’s my hack …
If I didn’t post it yet I’ll do so tomorrow when my Mac is back online.

Scroll up to 639?


#698

Ah, I was looking under @m.p.frankland, that why I didn’t find it.

Think I found it. Is it this?


#699

That’s it;-)


#700

Hi All, I upgraded to 86.1 today. I was using lovelace yaml before with custom card and eveything was working fine. Since 86.1 allow you to configure UI only if you are not using lovelace in yaml mode I have disabled yaml. Now my custom card does not work . I am not sure where to put resource url when not using lovelace in yaml.
Edit:- I am using Hassbian with 86.1


#701

Hi all. Just updated my HassIO, v0.86.1 and 0.86.2 seems to influence alignment of the main temperature reading…


#702

See my posts from a few days ago. All you have to do is change some options in the lovelace file…


#703

you’re ok? need any help with this?


#704

It’s not a proper fix. Not sure what is happening. I applied your fix and it still happens from time to time.

I haven’t even attempted to try it yet. Been busy with some away from the computer stuff. Where in the about does this code go? I think I’ve worked out the HTML bit, the CSS bit is pretty obvious, but I’m not sure exactly where the var lines go. Would it go in the slotValue(slot,value)} section at the end??


#705

How is it not a proper fix?? It’s not a proper bug! It’s an issue with the layout defaults from 0.86.0 which my customisations fixes. is I made a few changes anyone can make in the lovelace file. If they don’t work for you, just make whatever adjustments you want for your own needs. Also sometimes I find I need to hit the refresh button.

For reference, these are my current settings… (yes I keep tweaking slightly)

            temp_top_margin: -20px          #default 5px px or em
            temp_font_weight: 300           #default 300 numeric
            temp_font_size: 4em             #default 4em em
            temp_right_pos: 0.8em           #default .85em px or em
            temp_uom_top_margin: -14px      #default -9px px or em
            temp_uom_right_margin: 0px      #default 7px px or em
            apparent_top_margin: 45px       #default 39px px or em
            apparent_right_pos: 1em         #default 1em px or em
            apparent_right_margin: 1em      #default 1em px or em
            current_text_top_margin: -4px   #default 39px px or em
            current_text_left_pos: 7em      #default 5em px or em
            current_text_font_size: 1.2em   #default 1.5em em
            current_data_top_margin: 5em    #default 6em px or em
            large_icon_top_margin: -3.5em   #default -3.5em px or em
            large_icon_left_position: 0em   #default 0em px or em
            separator_top_margin: 5em       #default 5em px or em
            slot_l1: daytime_high
            slot_l2: wind
            slot_l3: visibility
            slot_l4: sun_next
            slot_r1: pop
            slot_r2: humidity
            slot_r3: pressure
            slot_r4: sun_following

NOTE: I have put all options in my lovelace, even ones that are the default just to make them all easier to tweak and also so people can just cut and paste the lot of then so they can tinker.


#706

It goes in the lovelace card. I have it right at the bottom before I define the next card.


#707

I don’t know… ¯\_(ツ)_/¯

I’ll have a look again, and I’ll apply your settings and see what happens, but as it stands, sometimes it looks normal, other times it moves around… :frowning:


#708

It’s most likely browser cache or something like that.

It isn’t a bug as such in the card although I think @m.p.frankland will change the defaults when he upgrades himself to 0.86 as that was when all the formatting trouble started.

But the reason he made it possible to change stuff was so that you can pretty much make the card look like whatever you want. It’s easier to edit the lovelace file than it is to play with the css in the js file - that’s for sure.