Custom KNX Climate Entity

I have a special requirement of KNX Climate. I have a Group address for each temperature. Lets say i have AC in drawing room. So if i want to set temperature as 26 then i use group address 3/7/0


3/7/1 - 22 deg C
3/7/2 - 23 deg C
3/7/3 - 24 deg C
3/7/4 - 25 deg C

Something like above. It’s actually not a smart AC. Now how can i create a climate entity in Home Assistant keeping above in mind.

Hi :wave:!
This is indeed an awkward actuator. Id suggest to use a dropdown helper and use knx.send when changing the option.


Thanks a lot for quick reply.

Currently this is my knx configuration for the AC

- name: "Living Room AC"
  on_off_address: "3/3/0"
  on_off_state_address: "3/3/11"
  temperature_address: "3/3/6"
  target_temperature_state_address: "3/3/6"   
  default_controller_mode: cool
  min_temp: 26
  max_temp: 26

As per above configuration if I turn on the AC it sends the temperature address 3/3/6 which is actually 26 deg C in my case… 3/3/0,3/3/11 are correct above. They do the on off functionality without any issues.

I want to know if i can map a set of group address for each temperature in the above configuration by any way…

Any type of work around should also be fine.

I could link the group address with an input helper but how can i create a climate entity from it?

Any solution is fine for me as long as it works

Thanks a lot

Use a dummy (internal) GA for setting the new temperature. Process it in an automation to send to the GA your actuator need according to the payload received (new target temperature).

1 Like

Wow, thats an awesome idea. I tried to implement it by using a dummy group address “3/0/6” and modified the config as below

    - name: "Drawing Room AC"
      on_off_address: "3/0/0"
      on_off_state_address: "3/3/9"
      temperature_address: "3/0/5"
      target_temperature_state_address: "3/0/6"
      default_controller_mode: cool
      min_temp: 20
      max_temp: 28

i have kept the dummy group address for target_temperature_state_address. Now i get a slider to change from 20 to 28 deg C. But the properties in Developer Tools → States → Drawing Room AC shows the temperature as null. Due to this i am not able to create any automation.

Even a KNX read on that group address in ETS5 returns nothing

Any tips or suggestions would be very helpful.

You can’t set a temperature without a target_temperature_address. No telegram will be sent.

HA will try to read the current temperature from target_temperature_state_address - which is a dummy address, so there will of course not be any answer (-> null)- except you create an automation that answers to that.

So if you also can’t read the current target temperature (in °C) from this strange actuator, you’ll have to create some logic for that as well.

Super thanks for your quick response.

I have missed point you have mentioned.

I have fixed my configuration as per your suggestion but i still see the temperature field as null.

- name: "Drawing Room AC"
  on_off_address: "3/0/0"
  on_off_state_address: "3/3/9"
  temperature_address: "3/0/5"
  target_temperature_address: "3/0/6"
  target_temperature_state_address: "3/0/6"
  default_controller_mode: cool
  min_temp: 20
  max_temp: 28

Am i still missing something?

How do you send to that address?

The configuration creates a climate entity in home assistant right… I am thinking that if i change the temperature in the climate entity then the climate entity will send the temperature to the group address automatically…

Correct me here… Looks like i am missing something

Yes, it does.
But it will never respond to any read requests.
And it will try to initialize from the given _state_address. If there is no response it will not know the current target - until you set it once, then it will assume that value.

Thanks a lot. With the above input i was able to get the climate entity working

1 Like

Hi @dsukesh
Can you post your final configuration for this as I think it might be the solution for my setup. I have put this topic on hold.
My main issue is:
HA doesn’t accept same GAs (Room & Setpoint temperatures) in two thermostats (in my case Office Under Floor Heating & Office AC)


You have a room temperature GA and a room temperature set point GA and you want to maintain the same temperature across both of your climate entities. Is it correct?

I.e if you turn on both entities and set temperature… both should have the same temperature setpoint.

Correct, that is what I intend to do. but I want this logic to work in KNX first even if there is no Home Assistant since KNX is the main and backbone system and control this from Home Assistant as well.

Any help is highly valued.


We can achieve this in home assistant, but without homeassistant if you want this to work then maybe you should look into the processor that you are using for KNX. For example in my case i have an RTI Processor connected to KNX bus apart from Home Assistant.

Anyways for home assistant you can create a new knx copy entity in Homeassitant using KNX Expose …

Lets assume that you have a GA 3/3/8 which is a temperature sensor … Once you connect it to HA then lets assume its entity id is sensor.temp

Now use below

- type: temperature
entity_id: sensor.temp
address: “3/4/7”

Now the same temp is replicated to 3/4/7 which you can use for your other climate entity. Repeat the same for setpoint temperature.

The above is the easiest i could think of… This also helps you turn on individual climate entities… so if you turn on both then both will have same setpoint… else only the climate entity which is on will have the setpoint as per GA.

Let me know if it works

Thank you for taking the time to respond.
But still the second part of the problem; if HA is down/not available, KNX will not operate as required on its own. correct?!

Anyway I will try at at the earliest chance and surely will let you know the outcome.

Thanks again

A HA Knx climate entity is not a regulator. It is an interface to change properties of a Knx regulator. So when HA is down for whatever reason, you can’t change the setpoint / mode from it (obviously). But the Knx regulator (most commonly built into a heating actuator or room controller) will still drive the valves accordingly to its settings.

Mmmm, I think I need to re-setup my KNX as I messed it up trying to achieve this in a wrong way.

Anyway, I am thinking of applying the below setup in KNX, with the difference that for DAIKIN AC I have it connected via Zennio KLIC-DD v3.

What do you think? Would you recommend it?

I got the below from the PDF of the Clima. Underfloor heating with additional heat from Zennio Project examples