Dali Integration with KNX DALI Gateway

Trying to use Home Assistant to remotely control my DALI lightings. In a simple test setup I have one ECG (dimmable lamp) on a Dali line. This Dali line is connected to a Theben P64 KNX Dali Gateway. On the Dali line everything works fine. The Theben Gateway is also attached to a KNX line. On the KNX line there is a KNX IP interface. In ETS6 I configured everything including linking the necessary group object to a dimmable test light entity (ECG0). In the Home Assistant YAML file I added the dimmable light with the appropriate adresses read from the assignments in ETS. KNX integration in Home Assistant (secured tunnelling is also properly setup).

When I trigger KNX commands (on/off or dimming values) out of ETS the commands are routed properly to the gateway and the attached DALI ECG is reacting to on / off and dimming commands. The corresponding light panel in the Home Assistant overview is showing the changing on / off and dimming values as well. So the communication from ETS via the KNX bus to the Dali bus is working. Home Assistant can also read commands from the KNX bus in a proper manner.

However if I use the light panel on the Home Assistant overview I can set on / off status and dimming values but nothing happens. Ik looks like the light panel can read commands from the KNX bus but is unable to write commands to the KNX bus.

Anybody who has experience with this issue and that can help me in a direction to get this solved ? Help on this would be very much appreciated.

We will need to see your KNX config in Home Assistant (make sure to post them using the code tags and not screenshots)

I’m guessing you are wording it incorrectly, but setting a status will not do anything. Since its just a status update from the KNX device, in this case the Dali gateway.

Could you also post a screenshot from ETS showing the device with its group assignments?

Hi and first of all thanks for the quick reply. Please find attached the screenshots of the information you requested. Note that I kept the test system as easy as possible. Only one ECG, configuration directly in main configuration.yaml file and in ETS I did (on purpose) not make a DALI group but assigned a single ECG directly to ETS addresses.

and the yaml file with the KNX lamp configuration.

Hi :wave:!

Do you see telegrams in ETS diagnostics when you change brightness / switch state from HA UI?

It looks like you are using DataSecure. If so, you’d have to add the GAs to the interfaces tunnel and re-export the keyfile. Also look at “Dynamic Folders” in ERS to see if the Dali gateways configuration has to be updated. And make sure HA uses the tunnel you assigned the GAs to (you can select that when importing the keyfile).

Hi Matthias, find attached two screenshots providing ETS bus activity info. As I can conclude from the diagnostic monitor I can confirm that Home Assistant send commands to the KNX line. However when sending commands through ETS (that is actually leading to the desired activity on the attached ECG) the commands seem to be different.

Commands on KNX bus through ETS:

and the KNX bus monitor results when using the lamp template in overview in Home Assistant:

The blue shield icon indicates that this GA is using DataSecure. In the group monitor DataSecure-Telegrams are also blue. As you see the telegram from HA has a grey background - so it is not sending a secured telegram (probably because it doesn’t have the keys.
Either apply my suggestions above regarding DataSecure, or disable it.

Hi Matthias,

Based on your inputs I made the changes and it now works perfectly . Your help was very much appreciated.


1 Like

Hi @Foetoe

I’m also looking for a solution to integrate my Dali (not Dali2) lights with Home Assistant. Actually, I do have three separate Dali lines due to the high number of lights. The lights are controlled via Dali controllers from Lunatone. Moreover, I have Dali Enocean gateways attached from Eltako. With the HA Enocean integration I’m able to control the Dali lights from HA. However, when I turn on/off the lights via the Dali controllers I’m not getting in status update in HA, since the Dali Enocean gateway is only one directional.

Does your setup via KNX really allow for bi directional communication? I. e. would that work in my case?


Usually Knx-DALI-Gateways are bidirectional. So eg. Dimm values of a DALI-Load are propagated to Knx.
Not sure how DALI Switches work since I never used them personally.