[Danalock V3] Inclusion & Firmware update

Note, this initial post will be updated when more information is gathered.
And of course, all reactions will be highly appreciated! :+1:

Hardware used:
Device: Danalock V3-BTZE (with Zwave and Bluetooth)
Manufacturer: Poly-control
Firmware current: not sure (yet). If I remembered right, something like 0.17.x
Firmware latest: DanalockV3_101-025_D1_0.20.0_20220105075833 (0.20.0, March, 30th 2022)
Updated 20230902: [LINK] DanalockV3_101-025_D1_0.21.7_20230313134558 (0.21.7, March, 3rd 2023)

Z-Wave Controller setup (Home Assistant) Used:
Controller USB-key: Aeotec Z-Stick 7
Firmware: v7.17.2 (latest)
Home Assistant Add-on (used): ZWaveJS2MQTT (version: 0.43.0)
Updated 20230902: Z-Wave JS UI (version: 1.15.8)

Inclusion notes (working):

  • Inclusion needs to be done near Z-wave controller (important!)
  • When using S2 Security, PIN for S2 inclusion is mentioned inside the battery compartment cover (label)

Other information:

Question(s):
Can I update (OTA) the firmware by using Home Assistant ZWaveJS2MQTT Add-on controller software?

Anyone have tried that?

Yes you can.

1 Like

Did you tried it? Does it reset the device?

I’ve OTA updated a few devices, no they do not factory reset.

Tried with choosing the zip file, but no success.
Also tried with choosing the manifest.json file (unpacked zip files), with no success.

I’m kind of reluctant choosing the bin file, because of (maybe) bricking the device…

Anyone has done updating it by Z-Wave successfully?

ZwaveJS won’t try to update it if the file isn’t the right type of file, but according to their website, you update these locks via bluetooth on your phone rather than via ZWave.

Hey @Domoticon
Long time no “see” :wink:

Got almost same configuration HA. With the danalock.
Only I run my Z-Stick 7 only with z-waveJS. Not with the mqtt
And my HA is on proxmox VM on NUC love it :grin:
But the danalock I only have updated this with the app.

Few years ago it had to be done with a separate app of danalock now it can be done in the app itself.


But if I still know you well enough you don’t have the cloud based login maybe :wink:

The separate app is this one

I did not test it with latest FW only few years ago with first 2 updates then the app had update and it wasn’t needed anymore for me.

Update with zwave never tested also because HA just have the possibility in there latest firmware build in.

Today I update with app to 0.20.2

1 Like

Hi @D-Vine, nice to hear from you again! Excuse me for the late respond :smirk:

Your answer, seems to me, sure is valid.

:rofl: Spot on!
I have to try it, but I have to change my LAN setup and the Android App (blocked all LAN ↔ WAN traffic for security/privacy reasons). I will do so when I have some time left…

Did you noticed any changes with the new firmware? I didn’t find any changelog of the firmware…

FYI, I disabled MQTT in my Z-Wave JS to MQTT addon, as mentioned in the release notes:

Note: Unlike the title of the software suggests, you don’t need to use MQTT part (it is even disabled by default). It will work directly without MQTT using the Home Assistant integration. The add-on will provide a nice secondairy and extensive Z-Wave JS control interface in such cases.

Is there any special procedure on how to add the Danalock V3 zwave to HA. I have an aeotec z-stick 7 and I just clicked to add new device, put the lock in the inclusion mode and it was added. However, even though it does shows the lock’s status, nothing happens when I click to close the lock. It is completely unresponsive. Am I missing anything? Could you give me any tips on how to configure it correctly to make sure that I can lock/unlock from HA? Thank you!

As far as I remember you need to include the lock near the controller.

My working setup:
Productcode: Danalock V3-BTZE
Firmware: v1.2
Security: S2 AccessControl
Beaming: supported
ZWave+ version: 1

Other info:

inclusion

  1. Set the controller in inclusion mode 2. Push the switch once. 3. Wait 5 seconds
1 Like

Thank you for your reply! I posted a bit too early. I read through more topics later and found the same advice. I thought that I was close enough at around 2m but then I moved just 30 cm away and that solved it.

FYI: Updated Topic fist post.

Does anyone knows if any Z-Wave Parameters are changed or added (from firmware 0.17.x → 0.21.7) ?
I looks like the Bluetooth remains enabled even when I disable it by Z-Wave… :thinking:

E.g. I can access my lock by my Android Danalock App, which seems strange to me. I disabled Z-Wave by Home Assistant setting BLE: Always option to disabled. Also when using the Z-Wave JS UI Control PanelDanalock NodeValuesConfiguration v4 → [8-112-0-5] BLE: Always / Custom Configuration - Parameter 5 - get it is reporting the BLE is disabled (0)…

Strange…

Addition 20230902: I noticed two configuration options are added to my HA Danalock Z-Wave device, param005_1 and param001_1.

Same here, I will open a ticket at danalock.

1 Like

Did you get any response?

So far I have received only a ticket number. I’ll ask again