[Z-Wave JS to MQTT, Synology DSM 7] Aeotec Z--Stick 7 disconnects from HA Virtual Machine

Used Config:
Home Assitant 2022.6.0, running on a Virtual Machine.
Hosted by: Synology RS820+ (DSM 7.1-42661 Update 2)
Zwave Controller:
Aeotec Z–Stick 7 (FW & SDK: v7.17.2, marked as Silicon Labs, 700 Series-based Controller, ZST10-700)
Home Assistant Z-Wave Add-on:
Z-Wave JS to MQTT (0.42.0)
Home Assistant Z-Wave Integration:
Z-Wave JS
Driver version: 9.3.0
Server version: 1.17.0
Server-URL: ws://a0d7b954-zwavejs2mqtt:3000

The Z-Wave Controller connection is broken after a couple of hours.

I did some investigation and it looks like it loses connection with Synology VM USB port. When reconnection it in the Synology Virtual Machine (disconnect → reconnect it again) the communication is restored. So IMHO, it’s caused by the Synology.

When the connection is active, everything is working as a charm. I did some internet searching and there are many people with the same kind of problems, but I couldn’t find any solution.

Anyone can help me out here?

Thanks in advance, it is highly appreciated when somebody could help me!

EDIT: FYI, I couldn’t find any log messages which could pinpoint me into the right direction…

Do you have any logging of the Core when the USB device disappeared? (to see if it disconnects from the VM or the addon)

Have you tried disabling the Soft Reset functionality in the Z-WaveJS2MQTT control panel? What path does your Z-WaveJS2MQTT use and any logging of the addon?

Also, the DSM version you mention has been released yesterday, has it worked before?

1 Like

Bedankt @RickKramer voor je snelle reaktie! :wink:

The only message I can find is a USB connection error on the VM CLI (showing the HA CLI):

In all other log-files there is no trace other then no communication to the controller:
ERROR ZWAVE: Error while polling value 4-49-0-Power: Timeout while waiting for an ACK from the controller (ZW0200)

Because no mentions in my logfiles I added a Poll every 440s to get more info about the time my communication is lost, so that explains the above message.

What do you exactly mean, how can I do/find that?
FYI: in the Z-Wave JS to MQTT add-on I enabled Disabled MQTT Gateway (as advised by install documentation) , Disable DNS Discovery (due to auto install of Zwave JS add-on).
Also in ZWave JS Integration the ‘adding devices automatically’ is disabled.

No. I updated to DSM 7.1 from Version: 7.0.1-42218 Update 4 which had the same issue. One of the reasons I updated…

I did some further investigation (with my limited IT home enthusiast knowledge) and have two things I suspect:

1 - I use an USB3 hub between my Synology USB3 port and the Z-Wave 7 controller stick. I have to try to remove the hub and see if this helps.

2 - On the Synology an Email server is active (MailPlus Server). The messages from VM CLI are on about the same time the MailPlus Server updates the Antivirus/AntiSpam engines. I tried to manually update this services and the VM CLI messages were reproduced (only once) without losing the USB Zwave Controller stick. I have to do more investigation on that. Also I tried switching the VM USB controller (USB2 ↔ USB3) with no result on behaviour.

So, I’m in the dark at this point, but will have to do some further investigation, I guess…

I you have any suggestion I could try, please advice, it is very appreciated!

I tried option 1 (above posting) and rewired the Z-Wave 7 controller stick USB connection separately to Synology USB port (without the hub).

At the moment it seems to be the right solution, I don’t have had no disconnections since the last time I posted… :crossed_fingers:

I’ll keep you posted…
EDIT: Looks to me it is working as it should be, will mark this as topic solution.

1 Like

I’m not able to find a compatible USB-Hub for the Synology, but when searching on the Synology site I stumbled on this page:

USB devices should be connected to your Synology NAS directly. Connecting any devices through a USB hub is not supported.

Bummer… :cry:

I’ve used a USB hub on my Synology NAS with Aoetec Gen 5, one of the keys is to be using a USB 2.0 hub not a USB 3.0 hub.


I have updated DSM from 7.0 to 7.1 this morning, and I have the following error with my Zwave USB key. everything was fine before update:

Driver: Failed to open the serial port: Error: No such file or directory cannot open /dev/ttyUSB0

What i need to do?

I have Zwave to MQTT install in docker

thanks for your help

That depends what is the underlying problem. I use a Synology Virtual Machine setup, where I can (virtually) disconnect/attach the USB device from it’s (virtual) USB port. That’s how I discovered my USB-Hub was the problem.

I don’t know if this can be done using a Docker setup. I read some comments that Synology Docker setups had some difficulties because the USB devices are not recognized, by default (security measure by Synology). In a VM the USB devices are managed by the Virtual Machine OS (Home Assistant), and therefore irrelevant for recognizing USB devices, if I understand correctly.

Is the Z-Wave-device mentioned in Settings → System → Hardware → All hardware (triple dots at top-right)?

Which brand and type if I may ask?
And is it externally powered?

it is working, i have just switch from Docker to VM USB connected!


1 Like

Nice to hear and thanks for reporting! You’re welcome :+1:

I use this one as it was recommended to work with the Aoetec Stick and Synology.


1 Like

Thank you for your respond, it’s appreciated! :+1: